Problem with DMA on XP pro

vbimport

#1

Hi i got a LTD163 (master )and LTR32123s (slave) on the secondary channel. Initially both drives were running in UDMA33 mode, but i discovered today that now XP says they are in PIO mode, despite "DMA if availbale" is selected. In bios they are selected for UDMA. Even if i change to PIO or DMA in xp, it doesnt ask me to reboot or anything. How can i get them to run in DMA mode. I dont understand, it was working fine... bloody XP :mad:

Cheers
Sergy


#2

Doesnt matter i uninstalled the secondary channel off XP and reinstalled it… now both drives in UDMA 33 mode 2.

CHeers
Sergy


#3

Two reasons this could hav happened to you:

  1. You updated your ata storage drivers from intel.

  2. You accidently disabled DMA mode in bios.

For solution to 1:

Goto My Computer/properties/hardware/device manager/IDE ATA/atapi controlers…

Look under all three listings…Master controller and the 2 ide channels.

Look at your driver date… should be the one that came with XP 7/1/2001 version 5.1.2600.0.

If it is dated in 2002 then you updated your intelata drivers from intel and that is a no no. Roll back your drivers under all three listings using the xp roll back feature under the properties/driver tab of all three listings and you can choose your “DMA if available” option again under each of the 2 ide channel listings (Primary & Secondary).

I accidently did this to myself and lost my DMA on my slave channels. Rolling back the divers under ALL three listings brought it back for me (Master & Primary/Secondary Channels).

For Solution to 2:

If this is still not working, look in your system bios and hunt down to see if you disabled DMA by accident.