Problem with dashes showing up as underscores

vbimport

#1

I recently converted a Linux mkisofs cd writing program with a .net program that uses the Nero SDK 1.06. Everything was seemingly fine and is ok for those with Windows XP for reading what I write.

But when I mount the CD under SCO Unix OpenServer, all my filenames that had dashes or minus “-” characters are automatically converted to “_” (underscores) when I look at what is on the CD there. When I look at this same CD on Windows, it has the dashes in the filename.

I have tried several combinations of parameters to the nerocmd.exe with no success. I really want to figure this out so I don’t have to try some other cd/dvd writing support from Windows.

Does anyone have any idea of what command line parameter I need, if there is one, that would allow the dash character under Unix?

Here are my command line parameters:
–write
–real
–drivename D
–verify
–iso-mode2
–relax_joliet
–recursive
–underrun_prot
–iso BSys73 C:\stuff\bsys\enhancement\7.3*.*

example of previous Linux command that made the image:
/usr/bin/mkisofs -r -f -l -J -V /bin/date +%y%m%d_%H%M -o /d/cdselect.iso $2 >>/d/log/mkisofs.log


#2

Add this to the command: -relaxed-filenames