Problem with copying a copy, after custom mode

I have this happen a couple of times - not know if it’s a progem bug or if I@m mis-using the options.

here’s the sequence.

  1. I copy a DVD in custom mode, mayube removeing some initial trailers/adverts & removein unwanted audio & languages.

the copy works fine.

  1. I then decide I want another copy of what I@ve done so I copy the 1st copy back onto my hard drive using the same FVDfab platinum program.

NB at this stage the HD version still looks findeif I open it wth powerdvd.

  1. Now for the crash - I lanuch FVFfab & point it at the HD copy as it’s source file - it tries to analyse whats there and then either crashes, or fails to see some of the titles ( which are still there when I view with powerdvd ). Whn I say it crashes, I mean I get the "error…must close " text and the screen inviting me to submit details & IFO files to the authors

So how come the program does not like re-copying its own customised copies ?

is it a bug , or has the customise process caused logic errors or unresolvable links to appear in the DVD titles indexing & file structures, which then crash the program when it tries to re-analyse the DVD structure ?

My most recent example was yesterday using version 3.1.4. - I’d restored a customised movie copy to my HD - there was 4.3Gb of data in the HD folder, yet whan FAB looked at it it could only see the extras title - only 20-30 minutes worth. It could not apparently see the main movie at all, yet powerDVD could see it ???
I could not see anything helpful in error logs so I gave up & deleted the whole mess.

related question: am I doing this in an overcomplicated way: if it’s true that DVDfab platinum removed all encryption when it made the 1st customised copy, then should I just be using windows software or basic DVD writer software to copy that copy, and not bothering with DVDfab platinum the 2nd time around ?

This is not normal behaviour. I’ll try one in the morning and see if it works for me. If you try it again in the meantime, save the IFO files of the 1st disc copy and also the IFOs of the copy you burn to HDD. I need to know if you are using the Preserve Menus or No Menus option in Customize.

Hello cybmole
Next time you do a backup copy and you think you may need to make another for some reason then do this,… open “Common Settings” and [B]un[/B]check the box next to “Delete tempoeay files when done” this will keep the files on your hard drive this way you do not have to make a copy of a copy BUT a copy of the same files that was used the first time :bigsmile:

thanks - I always use preserve menus in customise. and I use a 2 step copy process. Original to HD, then HD to copy, then I delete HD once I’ve checked that copy plays OK in my stand-alone DVD player.

& the resaon for wanting to copy the copy is that sometimes it took a while to deternime which custom titles were worth keeping & which were just annoyances. It involved watching the full DVD with PowerDVD software & noting title & chapter numbers of the bits I planned to remove.

So If I went all the way back to the original source disc in order to make the 2nd copy, I’d have to go through all of that again, unless I’d kept my notes of what titles/chapters to include/exclude. It can be some weeks later that I want to copy the copy e.g. to lend to someone without risk of losing copy 1, & by then I’ve forgotten which titles I excluded & why.

NB In custom mode I’m nearlly always removing the title that plays first, as that’s usually an advert or a logosplash screen. I’m,wondering if fab leaves the pointer to that initial title in the DVD index file as this does no harm on playback. A dvd player will skip over a missing title & keep going; but tmaybe his msissing title then confuses DVDfab’s attempt to re-analyse disc structure.

Next time I do once I’ll record before & after IFO file sizes or look for a file compare utility to see if the IFO is changed when titles are omitted in custom mode. Or is there a simply way to view IFO file contents ?

Save the IFO files themselves! Fengtao can look at these and tell what is happening. In Customize/Preserve mode, DVDFab replaces any missing content with your choice (in Common Settings) of either a “content removed” slide or just a black screen. If any of these replacement files are corrupt or missing the results can be unpredictable (they are in a folder named “CGP”). You can look at the IFOs yourself with a program called IFOEdit (which is free). Sorry I don’t have a link handy, but a google search will turn up several download sites. I’m still going to try one later and will let you know here what happens.

You should have given this info in your first post and you would have gotten a different reply from me :rolleyes:

Ok guys _ I have another instance of this problem. Movie - a scanner darkly. Copied to Hard Drive in custom mode. There is 6+GB on the HD ( = main move + making of ; foreign languages and adverts removed). The main movie plays OK from HD using powerDVD. but when I open the same HD folder with DVDfab it does not find the main movie . only the “making of” files.

The HD directory contains all of the usual VOB, BUP & ISO files. all of the 1Gb files are there and are same size as on the DVED.I’ll zip both the original TS- IFO & the HD version of the same file below if I can & maybe someone can diagnose what has gone wrong.

I was going to make an IPOD version from the Hard drive copy but I can’t because DVDfab can’t find the main movie again. I’m still using version 3.1.4.0.

PS as futher checks I’ve loaded the Hard drive copy movieiinto windows movie player & it’s all there. I’ve also opened the same hard drive folder with IMTOO DVD ripper and again it’s all there.

But not according to DVDFab platinum ???

evidence.zip (2.71 KB)

You need to email these to fengtao(at)dvdidle(dot)com along with a brief explanation of the problem. Tell him whether they were made with or without the “No Menus” option. From looking at the IFOs they seem to have been made with “Preserve Menus” checked (which still should have worked). He will also need the title and region of the original disc (the IFOs report it as PAL)

I read elsewhere that the DVDfab programmers read this forum, so should see the issue. the DVD titile was given - A scanner Darkyl. i’t s PAL disc, and I used preserve menus.

I redid the disc using main movie option & was then able to copy from the copy files OK, so it’s only a problem with custom mode.

It maybe also worth noting that the 1st thing you see when you play this DVD is a list of languanges on screen - which I have to scorll through until you reach English on the 3rd screen. I don’t know if this type of disc layout is a factor in the problem. You don’t get to a normal looking root menu until you’ve completed this step, and this was one of the “features” that I tried to cut out when making an English only custom copy. So it’s a disc which is made so that it can be sold in lots of (mostly European) countries, and does not automatically default to English.

an update on this elusive bug - I can now cause the crash to happen , or not, byt just operating the VDfab menus in a different sequence:
here’s what I’m seeing. ON my HD I have a custom version of Last King of Scotland. I decide to ipdod it but whn I open Fad I see there’s a choice of audio streams so I close fab open powerdvd to check out whihc satream I want, close that & go back to FAb. OK so ar. But now what I open the movie file in fab I get a crash. Very strange. so more testing reveals this:

method 1. this works with no crashes. set Fab to ipod or custom mode, then select the HD movie file. no problem & I can now select any of full disc, main movie, custom etc with no errors.
method 2: this is how to crash it. First I launch DVDfab - which defaults to opening in full disc mode. Then select the movie from the dvdfab/customise folder, while DVDfab is still in full disc mode. Now I’ll get a crash as soon as I switch to main movie or to ipod or to custom options!

I’ve gone around this several times & it’s very repeatable, yet vey puzzling. Why should opening the files in full disc mode lead to different behavour than opening the same files in some other mode ???

I also suspect the following actions may be contributory but will be cleared by a reboot:
Open a movie in DVDfab from Hard drive, but make the mistake of selecting the VIDEO-TS folder not the movie folder. (Easy to do by misatake if you also use POWERdvd as that’s what you have to do with powerDVD to play a Hard drive copy. ) It seems that DVDFAB does not like being asked to open at the VIDEO-TS folder level and will subsequently crash a lot until the PC is rebooted .

I don’t have any useful logs to post - nothing useful appears in the DVDfab logs as no burn attempts have been made.