Problem with computer shut down command

vbimport

#1

Good day to all my friends at MyCe

Recently I updated to windows 10 from Windows 8.1. The problem I am encountering (and I also had it in Windows 8.1) is that the computer does not shut down when prompted. Either it stays switched on or it restarts. To say that this problem is frustrating is to say it mildly. It also seems to be a common problem and the gurus at MS are either asleep or not aware of it yet. I got no help at all from the internet. I usually switch the computer off from the power supply switch although I know that is not ideal. Twice I got a dreaded blue screen with a message “Driver Power State Failure”, and that the problem was being resolved but things remained the same. Can anyone help me please?

Regards to all

Lino


#2

[QUOTE=linogatt;2759476]…Recently I updated to windows 10 from Windows 8.1. The problem I am encountering (and I also had it in Windows 8.1) is that the computer does not shut down when prompted. Either it stays switched on or it restarts…[/QUOTE]

Hmm, not too much information, but one solution springs to mind as a firstie:
tap your windows key and type powercfg.cpl then hit enter
(This is the equivalent to clicking Settings->System->Power & Sleep->Additional Power Settings)
Once there, Click on [B]Change settings that are currently unavailable
[/B]
If the [B]Turn on fast startup (Recommended)[/B] setting is not listed, then check [B]Hibernate[/B], click the [B]Save changes[/B] button. Close the window and start over from the top.

Under [B]Shutdown settings[/B], uncheck [B]Turn on fast startup (recommended)[/B], click the [B]Save changes[/B] button. Close the window and restart you machine.
Now see if the machine will shut down like expected

I do think the setting is listed as it is known to cause your troubles from time to time. if it is not, and after you check [B]Hibernate[/B], the setting comes up unchecked, check [B]Turn on fast startup (Recommended)[/B], resteart and then uncheck [B]Turn on fast startup (Recommended) [/B]again

If it does not solve your challenge, tap your Windows key and type CMD right-click on the Command Prompt icon that appears and choose [B]Run as administrator[/B] in the command window, type
[B]Shutdown /s /f /t 10[/B]
This should shut down your windows after 10 seconds

Good luck :slight_smile:


#3

Xercus
I began to do what you suggested but drew a blank. Firstly when I clicked on the windows key and typed powercfg.cpl nothing happened. Then I went into settings but on Power and sleep there was no “Change setting that are currently unavailable” and had to stop. What did I do wrong? My OP is Windows 10. Thanks for your help
Lino


#4

Opps, my bad, please select [B]Choose what the power button does[/B] once you get there. then follow the above


#5

I couldn’t find any of that in Windows 10 either. Edit: New instructions from Xercus solved that.

Are you sure that the physical switch on your computer (not the power supply) isn’t malfunctioning? If it is stuck in a position that makes contact, do you think that might be causing the computer to come back on?


#6

I don’t know if this will work for Windows 10 .
The latest OS I have it on is W7 .
Try it if you like .

Right click on you Desktop.
Select “New” & “Shortcut” .
Browse to:
C:\Windows\System32\shutdown.exe
"Next"
Name it anything you want.
"Finish"
Right Click on the new shortcut.Properties.
Shortcut tab/Target .
Paste in this:
C:\Windows\System32\shutdown.exe -s -t 00

If you want a different icon you can select “Change icon” & pick one.


#7

[QUOTE=cholla;2759497]I don’t know if this will work for Windows 10[/QUOTE]

That works on Windows 10 as well, but based on what he writes, I think that the /f parameter should be given as well to force running applications to close and that implies a /t parameter greater than 0

[QUOTE=Kerry56;2759494]Are you sure that the physical switch on your computer (not the power supply) isn’t malfunctioning? If it is stuck in a position that makes contact, do you think that might be causing the computer to come back on?[/QUOTE]

It may cause this issue as well. In my experience a pulse button usually stop making contact rather than stick in a contact position, but it is a possibillity.
To figure out if this is the cause, some BIOS implementations has a setting for what to do after sudden loss of power with either Off, last state or On as the choise. If it exist, selecting Off would verify this to be the cause if the computer comes on without having to press the powerbutton after turning on the PSU.


#8

Hello all
Tried your solutions but nothing worked. Something’s wrong and come to think of it I had the same problem in Windows 8.1. Don’t know what else to do. Don’t want to format as I have Windows 10 and I don’t think I can get it back. Never had these problems when I had XP. Any other suggestion please?

Lino


#9

Hello
Me again
How can I fix the Driver_Power_State_Failure?
Lino


#10

Hi Lino.
Again there is a little to little information to go on
The Driver_Powerstate_Failure is followed by a 0xnnnnnnnn error code.
Without this code, there is no point of departure for an explanation to the specific fault you are experiencing.

On a general level though, start here and work your way through it. If you still do not know what is going on, try a search using the complete 0xnnnnnnnn code to see if anyone else has experienced the fault and maybe even find the solution to the challenge.


#11

You will want to try other suggestions first.
This one is to test your computer & hardware to see if it is the problem.
If you have an old hard drive that will work on your computer .
Unplug the one you are now using with Windows 10 on it.
Install an older OS say Windows 7 or XP .
See if the computer will shut down correctly .
If it does then the problem isn’t the computer but the OS.
I guess it could still be the hard drive with Windows 10 on it but I doubt that.

I know that is doing it the hard way.
IMO the problem is some of the W10 drivers don’t work well with your hardware .
They may never work correctly . Unless MS come out with a lot of updates & one or more of those fixes your problem.


#12

Hi Xersus and Cholla. Thanks for your suggestions. There is no code with the message Driver_Power_State_Failure. Just a sentence that "Your computer has run into a problem and needs to restart. Gathering some information and we’ll restart it for you"
Then, "if you want to look it up Driver_Power_State_Failure"
I suspect it’s in the OS itself. I’ve had the computer for 3 months, brand new. The same error appeared in OS 8.1 but not with such frequency. I believe that it has to be MS themselves who will solve the problem in an update


#13

I would not hold my breath as to that it will be fixed by Microsoft as it is the first time I hear about such a problem. Checking the Microsoft community site for Windows 10 upgrades likewise does not show the error you are experiencing. Do take Cholla’s advice if you have a spare hard drive.
If the PC is brand new, it may pay off to complaint to the store as well. It may be a flaw on the motherboard as well causing this


#14

I agree with the computer being as new as it is I would take it in for warranty service if possible. It seems this computer has always had this problem to some degree .

I agree that waiting for a MS update can be useless & even more so if few people have the problem.

I have a situation of my own regarding this.
When I got Vista & this is still the same for W7.
There was free tech service for Vista at MS when I attempted to have them correct a problem. I even made it to the third tier of support.
I probably spent 6 to maybe 8 hours on the phone & computer with MS service techs. I went as far as going back to the OOB condition.
Their end comment was . “We now know about this problem & there will be an update to correct it.” That was in 2008 & I’m still waiting.
The problem is if you use a DVD standalone that has the [B]rare[/B] capability to record a DVD in -VR mode . Neither Vista or Windows 7 can open the DVD. It may even see it as a blank disc. Software like IsoBuster can see the files but Windows Explorer can’t. Which means media players & other software you might want to use for conversion can’t either. [B]I have posted this in the forum & it has been well discussed . No solution was ever found .[/B] One last note that was posted in the threads this was posted in is Windows XP & even Windows 98 can see the files.


#15

When your computer does not shutdown in after an (as admin executed) shutdown /s /f /t 0, there is something really wrong with your computer. You should consider a total reinstallation.


#16

[QUOTE=Mr. Belvedere;2759879]When your computer does not shutdown in after an (as admin executed) shutdown /s /f /t 0, there is something really wrong with your computer. You should consider a total reinstallation.[/QUOTE]

From the [B]shutdown /?[/B] information:
/f Force running applications to close without forewarning users. The /f parameter is implied when a value greater than 0 is specified for the /t parameter.


#17

Hello all
The solution to my problem was an update to the motherboard. It worked quite well. As to the notion that few people are experiencing this problem , I suggest that you are not quite right. There are thousands as can be seen on the Microsoft forum websites


#18

Have been facing the same problem for few days…thanks for sharing the valuable information


#19

It is the idea… To make threads as universally usable as possible. A thread should try to achieve that. Yesterday, I read a reply somewhere else and I was overwhelmed by the usability of the answer. Pure advice, no less I noted.
That answer will stand until it, as this thread, becomes obsolete due to changes in technology. :slight_smile:


#20

[QUOTE=Xercus;2763820]It is the idea… To make threads as universally usable as possible. A thread should try to achieve that. Yesterday, I read a reply somewhere else and I was overwhelmed by the usability of the answer. Pure advice, no less I noted.
That answer will stand until it, as this thread, becomes obsolete due to changes in technology. :)[/QUOTE]

Hi Xercus, since the thread is about shutdown code, I was wondering if there was a way to add just 1 program ( Skype) to shutdown.exe , all my machines have Skype shutting down correctly with the shutdown of the computer, but I have one rig, yes Windows 10 64bit Pro, that Skype will not shut down using the correct method, but it does shutdown with the computer from other sources like when after installing updates it has a reboot command, it works then but the traditional method of using the Start button, shutdown, it will not shutdown I have to manually " End Program". Any ideas?