Problem upgrading 1620 firmware

vbimport

#1

OK FOLKS.

I got my BENQ 1620 PRO 16xDVD ±R/RW today also ! BUT I HAVE A PROBLEM !:

First I installd the DVD into my computer. It came up perfect in the bios, and in my device manager.

Ok, now I would try to burn out all my digital pictures on a DVD… I use Nero 5.5.10.15. But it faild when burning… had to restart the computer…

Then I looked at the BENQ webpages, that the new firmware should deal better with nforce chipset, which I have… I downloadet the firmware, and tried to upgrade. Now the upgrade faild…

"ATAPI DVD DL DW1600 Current firmware : FS02
==> New firmware Version : B7V9

Invalid Firmware version. You cannot upgrade this drive."

—> Have I lost my original firmware? What happend ???

Regard
André / Norway


#2

First things first: UPGRADE Nero. I’m running 6.6.0.8 I think.

Then you have to convert the 1600 to a 1620…there’s probably a guide here somewhere. I’mn not exactly knowledgeable aboyt the process.

Maybe just getting the CVT and WinDWFlash is enough.

Cheers,

  • Jie

#3

OK FOLKS.

I got my BENQ 1620 PRO 16xDVD ±R/RW today also ! BUT I HAVE A PROBLEM !:

First I installd the DVD into my computer. It came up perfect in the bios, and in my device manager.

Ok, now I would try to burn out all my digital pictures on a DVD… I use Nero 5.5.10.15. But it faild when burning… had to restart the computer…

Then I looked at the BENQ webpages, that the new firmware should deal better with nforce chipset, which I have… I downloadet the firmware, and tried to upgrade. Now the upgrade faild…

"ATAPI DVD DL DW1600 Current firmware : FS02
==> New firmware Version : B7V9

Invalid Firmware version. You cannot upgrade this drive."

—> Have I lost my original firmware? What happend ???

Regard
André / Norway


#4

Try this:

STEP #1

Go here: http://dvdpro.club.st/firmware/BENQ_FW.htm

DL the WinDWFlasher and CVT file of your choice (EG: B7P9 or B7T9)

Load CVT into flasher and reboot.

STEP #2

Go here: http://support.benq.com/front/BenqMain.asp?MenuHead=128&ShowType=program&FileURL=service/driverlist.asp&Dataid=16041&downloadclass=Driver&product=3731&langu=null&ops=null&GenMenu=&RootId=undefined

DL Official FW of your choice (B7P9, B7T9, B7U9) and flash your drive.

Note: if you want to use MCSE on your drive, to boost the pressed DL ripping speed to 16x MAX, do this:

Load official BenQ FW (after doing Step #1!!!) into MCSE program ([url=http://ala42.cdfreaks.com/)

Then CHECK OFF “increase read speed” checkbox and hit Save. Then flash as normal and reboot.

NOTE: Always flash with your drive EMPTY.

BTW: Do NOT post your problem in multiple threads please!!!

  • Jie

#5

I’m not sure your version of Nero supports your burner


#6

But I don’t think Nero would FU** up my DVD Drive…? Befor this happend, it came up as a DVD R/W in “my computer” (winXP SP2), now it is just a cd-rom(K:) in my computer… It seems as it has lost its firmware completly…

any suggestions out there?

André / Norway


#7

It seems that the firmware is indeed messed up somehow. There’s no 1620 firmware called FS02. Are you sure you really have a 1620? Try flashing it with a cvt file in dos. After that, make sure you update nero before trying again. :slight_smile:

Out of curiosity, could you check the back of your drive and tell us what it says such as the original firmware that came with it?


#8

ATAPI DVD DL DW1600 FS02 is the revision of the boot code of your drive. Usually the drive changes from the boot code to the main code when windows boots. Try your drive in a different PC. If it behaves the same, return it.
Other things you could try are to remove your nforce ide driver and use the default microsoft driver, temporary disconnect all unused disks and cd/dvd drives, use a different power connector, use a different IDE cable.


#9

I don’t believe thats a benq firmware . what does windows report of the drive string


#10

FS02 is an old Liteon 411S firmware??? This is strange.


#11

Do you have a Liteon drive in the machine also. If so you have to choose the correct drive in the drop down menu…

Additionally, you’ve Hijacked a 1640 thread…


#12

Hi Again !

I think my DVD DWI1620 PRO drive lost its firmware completly yesterday. It came up like a CD-ROM in my computer. But I followed the advice to Ma_Jie and uploaded a new *.CVT file/firmware, and now it’s back to normal. (DVD-RW Station in my comuputer)

I have also upgradet my Nero to version 6.0015 something.

…And yes, I am now awere of the mistake of posting a 1620 post in a 1640 thread :slight_smile:

Anyway, thank you for quick and accurate answers!

Regards

André / Norway

—>PS: What kind of software do you use for CD/DVD quality test ? (All the screendumps of quality test in this thread)


#13

Please do not post your 1620 problems in this 1640 thread.


#14

@ingeam
Please post in a thread relating to your problem or start a new thread. Also crossposting is against forum rules. Please respect CD Freaks by respecting our rules and policies.

Your posts and replies have been merged into this thread.


#15

Got the same problem…

But now http://dvdpro.club.st/firmware/BENQ_FW.htm doesn’t work anymore…

What do do now then.?


#16

Welcome to cdfreaks :slight_smile:
If you specify exactly what your problem is it will be easier to help you.


#17

Hi…

Got the exact same problem as the one who started this thread in the first place


#18

Rather than people go look for main poster problem in order to understand yours, why don’t you just briefly explain what is the issue that you have a prolem with.


#19

Sould update my firmware, but the program crashed…

And now my burner is named: ATAPI DVD DL DW1600 FS02

ANd it wont even Eject the tray…


#20

You should try everything that ala42 mentioned in post #7 of this thread first. If you want WinDWFlash and some CVT files just PM me your e mail address and I will send them to you.:slight_smile: