Problem updating firmware on Asus 5224a

vbimport

#1

I decided to return the Asus Cendyne and picked up a Lite-on Cendyne instead.

I just picked up a Cendyne 52x cd-rw that appears to be a rebadged Asus 5224a. (The Cendyne part model is CDW-5224a, which matches the description on their support page).

The firware reports that it is a Cendyne drive (not Asus) with revision 1.20 (which is consistent with Asus firmware revision numbers).

I downloaded and tried to apply the Asus 1.35 update with their Windows executable, but I get a message saying an Asus drive can not be found. I tried moving it to a different IDE channel and playing with master/slave positions, but it didn’t matter.

Normally, I would think that the reason it can’t be detected is because the firmware reports this is a Cendyne drive, but on the Cendyne support page, they specifically supply an Asus firware as an update. This leads me to believe the drive should be recognized by the Asus firmware.

I tried mtkflash, but it would not recognize the memory type of the drive. I can’t find an ASF version of the 1.35 firmware, or I would try the Asus flasher.

Any suggestions?

The system is a Abit KR7A-Raid (VIA 266a) with an Athlon XP 1800 running Windows XP Pro SP1. (of course the drive is attached to the primary IDE channels, not the RAID channels).


#2

I have the same problem and would like an answer. :slight_smile:


#3

Had the same problem, but rather than uninstalling IDE drivers, moving drives round, etc. I just moved it into one of my other PC’s where it flashed just fine.


#4

I wonder if that is my problem. I may have it connected to the secondary IDE line as a master. My primary ide may have the original cdrom set as a slave along with a zip drive.

Thoughts.


#5

Well in my PC (where it would not flash) it was connected as sec master. However in the PC where it did flash I am pretty sure I also had it connected as sec master so I really don’t think that is a factor.

Also both PC’s had VIA based AMD boards. The one that did not work was running win2k and the one that did was running XP.


#6

I will leave the situation on hold. Tried the ASUS 1.35 firmware and it still say device not found.

No answers here. :frowning: