Problem to change firmware in my PBDS writer

vbimport

#1

I have a PBDS_DH-16A1P_RF11 writer and I want update firmware to LITEON WL08 but don’t run.

I have readed different informations on this procedure on forum but I have lots problems to do it.
Can someone explain better the correct procedure to a beginner new member as me in order to complete with success the change

to Liteon firmware, please? Thanks
I have done a backup of original EEPROM nad its firmware to BIN file.
The writer’s jum is on MASTER of secondary IDE channel.
Then I have used the program EEprom 3.8.3 and choosed:
“CrossFlash --> Upgrade Drive” and I select 16A1P + DW1680 option
(In the writer there is a blank CD but proved also with blanks DVD-R)
Then this, the program tells me “Drive conversion completed successfully” and shows me with arrows (Current model 16A1P +

DW1680).
I have reboot my system and then I run the original firmware “WL08.exe” under Windows2000 and program shows me the advise:
“No matched drive detected! This utility is only for LITE-ON DVDRW LH-16A1P drive” infact the drive in not coverted and is

always PBDS_DH-16A1P_RF11 !!
I have proved again with firmware WL08 FB-EON patched but same error.

Where is my error?
How can I do now?

THANK YOU VERY MUCH


#2

The official flasher looks for a Liteon drive id. Try this LH-16A1P flasher.


#3

Thank you very much for the answer, but I have prove also Wl06 Stock as you have suggest me, but nothing to do.
For me the problem is that the model is not changed using CrossFlash/Upgrade drive.
The program EEprom Utility 3.8.3 when have finished shows the message “Drive conversion completed successfully” but the bios when I reboot my system shows always PBDS DH-16A1P RF11 drive and not Lite-On LH-16A1P.
Is for this reason (IMHO) that the program shows always the error: “No matched drive detected! This utility is only for LITE-ON DVDRW LH-16A1P drive”. The drive is PBDS and not Lite-On!
I don’t understand why my drive cannot change ID and other people of forum made this without problem whith same model. :frowning:
If there is someone that can send me a copy of its flash.BIN and EEprom backup of LH-16A1P I can prove using Flash Utility 2.2.4 and EEprom program to restore the firmware with this method. Using EXE firmware files don’t run.
What do you think, can run ??

Thanks again