Problem setting booktype AD-5200S

vbimport

#1

Hello Liggy,

I just flashed Liggy’s AD-5200S Bitsetting Firmware 1.09 to my AD-5200S Optiarc burner in order to be able to set my booktype to DVD-ROM for mediatypes DVD+R and DVD+RW . However i can not get this to work. If i run
NECWinFlash.exe and then pick BookType it tells me DVD+R SL (none) and dvd+r (active) is greyed out and likewise for DVD+RW (none) dvd+rw (active) is greyed out too.
DVD+R DL (none) is the only one which is changeable.
Running necflash.exe -setbt DVD+R DVD-ROM perm e: from the command prompt gives: “This booktype operation is not supported with your firmware” while the firmware that i flashed claims to be bitsetting for DVD+R and DVD+RW mediatypes. Could you tell me what’s going on here and how I can possibly hopefully fix this? Thanks a lot.


#2

You must have either flashed a firmware that does not support bitsetting or something on your PC prevents the bitsetting commands to be forwarded to the drive. There’s also a possibility that I did something wrong when patching, but in that case a couple of people already would have complained as the AD-5200S is already quite old.

To rule out that you flashed the wrong firmware, could you please download and run QueryDVD, select the drive and hit the green button? Under vendor specific info you should read “BT-LIGGY” for a bitsetting firmware.


#3

First I have to say: thanks a lot for the fast reply and support :slight_smile:
I did as you asked and the tool shows:
Identification Optiarc DVD RW AD-5200S
Vendor specific info Nov05,2008 BT-LIGGY
Region Control RPC1

So this should confirm I did flash the right firmware.

I have no clue whatsoever which “something” on my PC might prevent bitsetting commands to be forwarded to the drive, I kinda doubt that is the case.
Could it be that maybe you did do something wrong patching in this specific case? I would really like to have the bitsetting capability for this drive.


#4

It’s indeed a buggy firmware patch. AD-5200S firmware consists of firmwares for two different bootcodes and probably also two different hardware revisions of the drive. While one of the patches seems to be OK, the other one is missing at least one patch. But I need to check that in detail later when I’m not at work anymore.


#5

Hi Liggy…any luck yet? Just curious…


#6

Hello Liggy…did I read your last message right that you are planning to release a fix/working firmware version for my drive as soon as you have some time? Could you confirm please? Thanks.


#7

Yep. Will check and for sure fix it, but may delay that until my holiday (2 weeks from now)


#8

Thank you for replying again.
Ok great…hope you will be able to do this asap as i really need the bitsetting feature and i can’t use the burner until it has been fixed :slight_smile: Appreciate your efforts!


#9

Hi Liggy,

By no means I want to sound pushy or inpatient but I was wondering if you will have some time for the firmware fix anytime soon? I’m really waiting for this one. Thank you!


#10

I just uploaded a modified version of this firmware that should allow changing the booktype. I just forgot to call my routine instead of the original one in this firmware. Everything else seems to have been patched properly.


#11

Hi Liggy. thank you for your effort but I am afraid it still sin’t working. I did flash your new version of the firmware (even twice), I also noticed it was binairy different from the older one, but still I have exactly the same issues as before. Which means I still cannot modify my booktype which causes some real issues with other devices that I own. I do hope you will be able to dive into this once more and will be able to fix this. Thanks a lot in advance.


#12

Are you still thewre Liggy? Could you reply to my post above please? Like I said: firmware is still not capable of booktype setting.


#13

With repatching, I just found another bug in the firmware (bootcode 12 this time), fixed it and uploaded the fixed versions. Repatching the firmware for bootcode 14 resulted in a binary identical file.