Problem Re-Installing Software

vbimport

#1

I (well actually my dad) restored my computer to a previous date because of small viruses etc. Problem is the most of the software was still in the start menu but when I clicked the app the ‘Unable to locate…’ dialog box appeared. The programs dont appear on the uninstall program list, but when I re-install my programs they work again.
All but one worked which is Microsoft Visual Basic 6.0. When I launch the setup.exe after a brief startup it then cancels with a dialog box saying ‘There is insufficient memory to run setup. Try closing any open applications or restarting windows.’ I have tried everything to no success.
Can someone please throw any suggestions my way I’d be grateful. Thanks.


#2

[QUOTE=PughLfC;2146456]I (well actually my dad) restored my computer to a previous date because of small viruses etc. Problem is the most of the software was still in the start menu but when I clicked the app the ‘Unable to locate…’ dialog box appeared. The programs dont appear on the uninstall program list, but when I re-install my programs they work again.
All but one worked which is Microsoft Visual Basic 6.0. When I launch the setup.exe after a brief startup it then cancels with a dialog box saying ‘There is insufficient memory to run setup. Try closing any open applications or restarting windows.’ I have tried everything to no success.
Can someone please throw any suggestions my way I’d be grateful. Thanks.[/QUOTE]

First off we need to know your father’s computer specs?? And what do you mean restore the computer? Sounds like one of you memory chips went bad if it was working before. Time to update or upgrade your memory. Try switching them around and see if you don’t get the same message.


#3

what is operating system?

what is method of re-install?


#4

The computer is fine, 900+mb of ram (newly installed), 80gb hard drive, running Windows XP Home, virtually free of viruses etc. I cant actually remember why it was restored or how, and I know that sounds a bit awkward. I think it was a restore to a previous date using avast on bootup, which found infected files and acted accordingly, but I dont know what it actually did. But what I am saying is, all programs re-installed successfully, bar VB6. What can anyone suggest?


#5

Perhaps (I’m not sure) but maybe Microsoft .NET framework is needed for VB6…Do you have it installed or maybe when restoring to an earlier stage, it’s no longer functional…I’d look into that perhaps…

http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en


#6

[QUOTE=t0nee1;2147918]Perhaps (I’m not sure) but maybe Microsoft .NET framework is needed for VB6…Do you have it installed or maybe when restoring to an earlier stage, it’s no longer functional…I’d look into that perhaps…

http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en[/QUOTE]

Actually I think he needs netframework 1.1 and then update to 3.5. I think VB6 as well needs to have framwork installed to work properly.


#7

ok thanks for the replies i’ll give both a try.