Problem: NEC ND-3540A doesn´t support UDMA 2

vbimport

#1

I bought this brand new NEC ND-3540A drive, last wednesday. Installed it on my Silicon Image 0680 Controller as a Secondary Master.

Well after some burns, I did some transfer tests on Nero CD-Speed, and realized the readings were to unstable. So I thought it could be bad quality burns, the drive itself, etc. Later I came to this forum and I saw some smooth readings reported by some users of the same drive. So I started suspecting!

I then decided to check a full Nero CD/DVD Speed transfer test. This is the result:

What caught my attention were those 14 MB/s you can see on the image. I know the drive can´t ever reach the 16X speed both at reading and writing, being limited to those 14 MB/s!

So I installed the Controller Add-on card software to check it´s DMA mode. This is the result:

So here I can see the real problem. The drive´s DMA mode is set to MDMA 2 mode. Not enough! The other strange behaviour is the ATA Version, being just PRE-ATA 2! Both my Lite-ON SOHW-832S and JLMS XJ-HD 166S are ATA/ATAPI 5!

So I was happy for a moment. I thought problem solved! Let´s go change it to UDMA 2 mode. When I was there I was surprised with this:

Where is the UDMA 2 option?

Well, the drive must support UDMA 2 to be able to operate at it´s rated speeds. Is my drive deffective? Is the card the problem? Perhaps a compatibility issue between drive and add-on card!

Thanks in advance!


#2

Several controllers only work reliable with harddisc drives. The usual advise is to attach your optical drives to onboard controllers. To be sure that it’s not the quality of your burnt disc, you could also do a quality check at 5x speed with Nero CD Speed.


#3

engine, the controller is not able to support optical drives at UDMA2. Once I tried to tweak SiI680 with PX-716 and failed. Some cdfreakser made it though.


#4

I just atached the NEC drive to the onboard controller. I am doing the transfer test now. It trasnfers up to the 16X full speed while atached to the onboard controller. Great!

Just that advice doesn´t work for me! I have Three optical drives plus a ZIP drive. The LG drive is on another system. I want all my drives as masters for better transfer speed.

No offence, but that isn´t true. Both Lite-ON drives I have work at UDMA 2 while atached to this Controller. The NEC drive somehow doesn´t!

The problem is that I have two 0680A Controllers on this system. You can identify them on the above pictures as PCI-680U-0 and PCI-680U-1. On PCI-680U-1 Controller I have a RAID 0 set. So I must have the RAID BIOS on this controller. Silicon Image’s Flash utility doesn´t let me chose to wich card I want to flash. It simply flashes the BIOS to both cards at the same time! So I must use The RAID BIOS on both cards, or the IDE BIOS on both cards. The IDE BIOS on both cards is not an option because of the RAID 0 set I want. So it leaves me with the RAID BIOS on both cards! Unless I mess with the hardware. I don´t want to do that.

Anyway the problem is solved now. I moved the NEC drive to the onboard controller. And moved the Lite-ON drives to the add-on card controller. This way I have all drives at UDMA 2!

This is the transfer test now:

Note the 25 MB/s! As oposed to the 14 MB/s the drive did before!

Thanks anyway guys!

I just wanted to plublish the problem here in case NEC or Silicon Image see it and want to do things right. Since some companys doesn´t answer my e-mails!

Thanks CDFreaks!


#5

You’re right. I forgot to edit (or delete) the first sentence after I edit the post and added a third sentence (some cdfreaks made it).


#6

Seems the Controller does support Optical drives at UDMA 2. But some optical drive brands don´t work at more than MDMA 2 with this Controller. Others like Lite-ON and Sony (based on Lite-ON) work at full UDMA 2 though!


#7

I can confirm that.
Only MDMA2 with my Nec 2500A (external controller SiI0680-based) and at the same time UDMA2 with my Litey 832.
Finally I decided some time ago to reserve all my onboard IDE slots for optical drives, and since then I am happy. :slight_smile:

Regards,

ET


#8

FACT: RAID cards do not fully support the ATAPI standard, so some optical drives will not perform at full capability when fitted to such a card.

Surely, to have the SIL cards with different BIOS, why not remove one, then flash the remaining one to IDE only, then refit the one with the RAID BIOS? That way, the IDE only BIOS will run your NEC at UDMA2 and you’ll still have RAID on the other card.


#9

Offcouse I have thought about that. I am just to lasy to do it! I think I am going to wait for a decent flash utility from Silicon Image.

However some users reported that the IDE BIOS also works at a maximum MDMA 2 with NEC drives!

So, since I have all the older BIOS for this card. If someone wants to try them out, I can provide them. You can´t find the older BIOS on Silicon Image’s site, I guess. So let me know if you want them.

Regards!


#10

I use the SIL 0680A IDE card and my 3520 and 3540 will both work at UDMA2. I use the latest IDE BIOS.


#11

you have to test and see


#12

Get that thing flashed to the non-raid bios if it isnt already took me 2 mins, im running all the opticals in my main rig (see sig) from it and ive had 0 problems, originally i was running my hard drives from it with the raid bios and the system locked up when i was transferring a large amount of data (which might have been caused by my failing PSU which blew a week later) but ive had no problems with the opticals attached to it.

btw both my Pioneers are running at UDMA 4 on the card (as they should be :slight_smile: )