Problem flashing Optiarc 7241

vbimport

#1

I’m having a problem flashing my Optiarc AD-7241S using Binflash.

The drive is detected :-

"
Binflash - NEC GUI version - © by Liggy, Herrie and r-man
http://binflash.cdfreaks.com

Identified drive: 78 - 3038
Detected drive from Firmware: 77
“

However, when I attempt to flash, using either the command line or GUI versions of binflash, it reports: “firmware is for a different drive”.

I’ve downloaded the firmwares from Liggy’s website and have been attempting to flash to 104bt_rpc1.bin, 104_rpc1.bin and 1u0bt-rpc1bin with the same result.

I’m running Windows 7 as a user with administrator rights and have tried the 32 and x64 versions of Binflash 1.52

Both Binflash and DISCInfo report that my drive is indeed an Optiarc AD-7241S with 1.03 firmware.

Any ideas what I’m doing wrong?


#2

You actually have an AD-7241S according to the output, but the firmware you’re trying to flash is for and AD-7240S. This cannot work.


#3

Thanks Liggy!

Failure on my part to scroll down your firmware list or make intelligent use of CTRL + F.

I’d stupidly assumed that, as the 7241 firmware was not listed immediately below those for the 7240, the 7240 firmware was designed to also work for the 7241.

Please forgive my idiocy and rest assured that I have punched myself in the face for not using CTRL + F. :smiley:


#4

I wish I could improve the site layout to make things clearer but I don’t have an idea what a good layout would be that makes things clearer but still provides all the information in at least two languages and even if I had an idea I probably wouldn’t have the time to implement it.