Problem encoding X-VID to DVD

vbimport

#1

Hi,

Chicken man - thanks for the guide - its spot one. I have 3 tv shows that I’m converting one at a time. The first and third one have converted fine :slight_smile:

I’m having a problem with the 2nd one though, which is strange because its in exactly the same format as the other two - and I’ve checked with G-SPOT and WMP that it plays just fine.

The first time I tried it I got a strange error saying that the my desired frame size of 768/80 (i think) was too large because of the width. Now whenever I try it, the whole process completes but on the step to create the Encoded_Video_CCE_PAL.mpv file, it starts and gives a feasbile ETA predicition but then the window gets cancelled by the script after only a few seconds even though it seemed to be getting along fine - the Encoded_Video_CCE_PAL.mpv file ends up only 150k or so. It then goes on to do a load of .mpv files which takes a few minutes - not sure what they are.

Do you have any ideas what the problem might be? Here’s hoping! :slight_smile:

Thanks again,

Andy

Some log information is attached.


#2

A couple of problems, the avi has a 4:3 aspect ratio but you selected “Anamorphic(encode as 16:9)” when you should have selected “16:9(borders added encode as 4:3)” As you can see in the Avisynth script, borders were added to the left and right side of the picture and it would have looked squashed (everyone is a cone head :smiley: )

The fact that it had to do multiple Q analysis attempts with crazy results suggests the AVI has internal problem, I’d check it with DivFix and DivXRepair.


#3

Hi,

Thanks for you help. I have run DivFix and it see’s nothing wrong with the source which I kind of expected as the stuff at digitaldistractions is always spot on.

So I tried re-encoding one of the ones that worked just fine previously and that one didn’t work either. So I re-installed CCE (I’m using eCLCCE 1.81) and I re-installed DVD2SVCD but to no avail. The encoding seems to be going just fine before the script (I presume) cancels it. :confused:

Any other thoughts on what might be going on? I got 2 out of 3 done, nearly ready to burn my first DVD :slight_smile:

Looking forward to the Cricket tomorrow?

Cheers,

Andy


#4

The problem could also be the actual Xvid codec you have installed. Again, uninstall and install ver 1.0.2 from http://www.koepi.org/


#5

Hi,

I’ve tried everything now, I just can’t work out why the D2SR0BA script cancels the CCE encoding a few seconds in when it seems to be going fine.

I’ve tried closing D2SR0BA just before CCE starts and that works in that CCE dosen’t get cancelled and it creates all my files in around an hour. However it then seems to ignore the setting for the requested file size (which I need to get right) even though that setting looked right in CD Size field of the Bitrate tab in AVI2DVD 1.2.2-3 just before I pressed go in the conversion.

Is it perhaps something that D2SR0BA starts off after the main CCE encode which does the sizing? If so can I do that bit manually?

In the output directory, is it necessary to hold on to all of the files or can I delete everything but themain encoded video and audio files?

Thanks again,

Andy


#6

Oh, and out of interest, the CD size that you set - is that the size you want the audio & video to take up combined? Or just the size of the video?

Sorry so many questions, but I’m determined to get to the bottom of this and get it working :slight_smile:


#7

The Roba script auto shuts down the CCE encoding that DVD2SVCD started, this is normal. Then RoBa starts CCE up again to find the best Q value to fit to the CD size your asked for and then finally does the full encode. Just let it go and do its own thing, thats what its all about.

CD Size is exactly that, the size of the CD/DVD your going to write the final files to, nothing more, nothing less. Dont start trying to make it more complicated than it really is.