Problem burning to NEC 3520

vbimport

#1

Hello.

I recently just purchased a NEC 3520a from newegg.com I was using a Pioneer DVR-105 and was able to burn cds and dvds with no problem. After the swap I was unable to burn anything to the NEC with Nero. Changed the drive to be primary master, single drive on the channel, and still no luck. Reinstalled XP SP2, and VIA 4-in-1, same problem. Nero goes to burn, caches the files and then locks. Can’t even kill the process nero.exe. Infuriated I installed linux and was able to burn two different types of dvds with no problem.

I thought maybe nero wasn’t liking that I hadn’t set a region code on the drive yet. That didn’t fix anything. Something weird I did notice though, All of my Hard disks and the nec drive are showing up as SCSI disks in the windows device manager. Read a couple of different online posts and saw that this was “acceptable”. And after trying to upgrade the Via atapi Bus master driver, and not being able to boot I figure the installed driver was the correct one. Also I’m unable to use CDeX or iTunes to rip audio cd’s (from the nec drive or a liteon dvd reader), but Windows Media Player 10 is able to play and rip the files.

Thinking that not being able to burn might be wacky firmware I decided to upgrade it to Liggy and Dee 1.U6. Under windows it said unable to flash and then the drive would blink green continuously until I rebooted. Under linux using necflash -scan it was unable to find a device, and trying to flash the device node anyway said it was unable to flash. Booted from a WinPE disk and tried to flash, it got farther than in regular windows, but after sending the checksum, it just errored out on every block it tried to flash.

Any ideas/suggestions on how to fix any of this? :slight_smile:


#2

Try removing the Via drivers and replace them with Microsofts default IDE drivers. You may also try a new 80 conductor IDE cable.

You should NOT have tried to flash your drive without the system seeing the drive correctly. The blinking LED means the drive is in safe mode. Lets hope you can get your system to find the drive and recover it.


#3

Currently the default Microsoft drivers are installed. I’ll try a new ide cable in a few hours when i get home and see if that might work.

As for the system seeing the drive correctly, it seems it does, it just shows up as a scsi device. and can’t burn to it.


#4

Microsofts default IDE drivers

what are they called?


#5

Tried 2 different brand new 80 pin cables and neither worked. I did figure out my flashing problem with linux (i wasn’t root, wooopsie).

So now it’s more of a windows problem than hardware. I’ll probably install Windows 2000 later on a seperate partition to see if it will burn no problem. Anyone else have any ideas?

Forgot to mention earlier that my motherboard is a MSI, using the KM400 chipset.


#6

I’d remove all burn applications. Also remove the Primary and Secondary IDE channels. Shut down PC and reset CMOS. Reboot PC. Can you read CDs and DVDs with the NEC?

See if you can backup a DVD using CloneDVD and AnyDVD (download from Slysoft.com).


#7

Installed, Win XP Home (i was running pro coughnemesiscough). And it installed a different atapi driver, the pro one said Via … (dual mode), where the home one just says Via Bus Master … . So apparently this dual mode driver is the culprit here. Now when I try to upgrade the driver on it, I get sent into an infinite reboot unless I select Last Known Good Configuration which puts me back to the dual mode driver. Tried it in safe mode.

Anyone know of a way around of upgrading the driver successfully. Not really feeling like reinstalling once again just to fix a driver problem. Recovery console maybe?


#8

Most PCs don’t need atapi driver to function properly.


#9

Out of curiosity, what burn speeds were you seeing under linux? I’ve got a thread here: http://club.cdfreaks.com/showthread.php?t=129987 and I’m trying to get above 2x with my 3520A. Thanks for any input you might have.