Problem burning dvd, buffer level changing and burning takes long time

Hi,
I’m having a problem burning dvds. I have the sony dru-530A burner and use nero 6 to burn my dvds. I just bought my burner about a week ago so it is brand new. At first, I wasn’t having any problems but now all of the sudden I am.

When I start to burn a dvd w/nero the buffer level jumps up and down the whole time. At first, it was only doing it when i tried to burn in 4x speed, but today it started doing it in the 2x speed. I’ve been using memorex dvd-rs 4x dvds to burn with.

It will burn the dvd, but it is now taking over an hour to complete the burning and the remaining time will go to 00:00 after the time it is should take to burn the dvd and the total time will keep adding mins until it’s done burning. Before it would take about 25-30 mins for 2x and 10-15 mins per 4x. The burned dvd will play in my stand alone dvd player, but every once and a while will freeze. It didn’t do this on the burned dvds before this problem when I played them.

I have no clue what to do.

What do I need to do to fix this? many thanks for the help. :slight_smile:

I have no clue what to do.

How to Enable Direct Memory Access (DMA)

the dma is enabled. I was searching through the threads and found out about that and I checked it.

on the secondary ide channel<properties<advanced settings i saw
Device 0
Device type - auto detection
Transfer mode - dma if available
current transfer mode - ultra dma mode 2

device 1
device type - auto detection
transfer mode - dma if available
current transfer mode - PIO mode

Now, the device 0 was enabled, but device 1 isn’t. Do i need to do something with the device 1? I actually tried to enable it but it is still PIO.

For the primary ide channel it looks like this:

Device 0
Device type - auto detection
Transfer mode - dma if available
current transfer mode - ultra dma mode 5

device 1
device type - auto detection
transfer mode - dma if available
current transfer mode - not applicable

is there something i’m not doing right with the dma or is there another solution? :slight_smile:

Originally posted by chandlertigger

on the secondary ide channel<properties<advanced settings i saw

device 1
device type - auto detection
transfer mode - dma if available
current transfer mode - PIO mode

Do i need to do something with the device 1?
What’s your so called device 1 ? Uninstall this channel and re-boot the PC.

i’m not sure what it is, i’m not very computer literate. I don’t want to delete something I may need for my computer to run. Would that be a problem and how would I go about deleting it if it isn’t?

another question, a friend told me that my computer might not have enough juice to run the dvd burner, but I doubt that. My computer is only 1 year old and a dell. I would think if that was the case, then it wouldn’t burn it at all, but it was running fine until yesterday.

how do i find out what device 1 is or do I need to? I’ve tried to find an answer to the problem, but getting no where.:confused:

Originally posted by chandlertigger

I don’t want to delete something I may need for my computer to run.

how do i find out what device 1 is or do I need to?
Don’t you worry, the channel is going to appear on re-boot, most likely healthy.
This subject has been discussed a zillion times, you know.

Run [COLOR=blue]Nero Info Tool to view it : [/COLOR]

thank you for your help. I searched through the forum before posting, but could only understand part of what everyone was talking about, so I thought maybe posting it myself I would be able to understand it better.

I figured it out. I had a friend come over and fix the problem for me. I had to delete the secondary channel and reboot and it found the channel again with the right thing in the box on device 1. So atleast I know what to do if it ever happens again. Hopefully it won’t and thanks again.
:smiley:

Originally posted by chandlertigger

I had to delete the secondary channel and reboot
and it found the channel again with the right thing in the box on device 1.
Excellent ! I told ya it would work. :wink:

Windows supposedly recovers from channels locked into PIO mode, but in practice it doesn’t. The problem is the MasterDeviceTimingModeAllowed (or SlaveDeviceTimingModeAllowed) values in the appropriate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}[number] key. If there’s repeated errors on the IDE channel, Windows reduces the value from the default hexadecimal ffffffff, which locks down the maximum allowed speed even after a reboot.

I believe this is regarded as a known bug in Windows XP SP1, and that there’s a hotfix now available that stops such a degradation from persisting across a reboot (or, alternatively, it makes the back-off to PIO mode less aggressive - I think it may actually be this). However, I can’t find the Knowledge Base article on this now.

As editing the registry is potentially dangerous, the usual advice is instead to uninstall the relevant IDE channel and reboot. That sorts out the problem.

David

I have found an amazing number of people who have put posts everywhere seeking a remedy to the fluctuating buffer problem in nero.
When I got this problem last week, I worked it out. You can’t have your burner running as an IDE slave off another device. If it is, see if my decription matches your problem:

I have an NEC 2500 DVD burner.
It was working fine. But after a while, the buffer levels started to fluctuate and burning a DVD took twice as long
I upgraded to nero 6.3…something and that made it worse.

What I did:

  1. I went into device manager - IDE ATA/ATAPI Controllers.
  2. I right clicked on ‘Secondary IDE Channel’ (the IDE channel for my burner and DVD rom).
  3. I clicked uninstall.
  4. After Uninstall, I SHUT DOWN.
  5. I opened up the case

My burner was configured as a slave running of by DVD-rom (master).

  1. I switched the master and slave. ie… I made by DVD burner the master.
  2. I restarted windows (XP). I recognised new hardware and installed the drivers for the DVD drives. Presto - back in business.

I think that you shouldn’t have your burner running as a slave. Hope this helps someone out there.

Can anyone confirm or deny this? My NEC is a slave on my secondary IDE, master is a straight CD rom player. No problems so far …

Yes having The Burner (any burner) on the same channel with another CD or DVD will reduce the Burner performance.

Reduce performance …ok, but what about creating coasters? I mean, if the other drive is not running, how can there be a problem?

What happen if you have 2 dvd burners that are the same make and model is a LG
Thanks

[QUOTE=mamba;613444]Reduce performance …ok, but what about creating coasters? I mean, if the other drive is not running, how can there be a problem?[/QUOTE]

All connected and powered drives do still “run”, or better call it “are on”.
Not all ODD can work together without problems.

[QUOTE=matrix777;2001362]What happen if you have 2 dvd burners that are the same make and model is a LG
Thanks[/QUOTE]

i have this same setup.

i have two LG dvd writers and when i set the secondary to DMA it will switch back to PIO mode on it’s own. :sad:

why won’t it stay on DMA mode.

Joe - try changing the IDE cable for a new one.

Then try each drive by itself and see if DMA sticks for them both.

[QUOTE=Arachne;2079468]Joe - try changing the IDE cable for a new one.

Then try each drive by itself and see if DMA sticks for them both.[/QUOTE]

thank you Arachne.

i will try this over the weekend. :iagree:

[QUOTE=chandlertigger;571404]the dma is enabled. I was searching through the threads and found out about that and I checked it.

on the secondary ide channel<properties<advanced settings i saw
Device 0
Device type - auto detection
Transfer mode - dma if available
current transfer mode - ultra dma mode 2

device 1
device type - auto detection
transfer mode - dma if available
current transfer mode - PIO mode

Now, the device 0 was enabled, but device 1 isn’t. Do i need to do something with the device 1? I actually tried to enable it but it is still PIO.

For the primary ide channel it looks like this:

Device 0
Device type - auto detection
Transfer mode - dma if available
current transfer mode - ultra dma mode 5

device 1
device type - auto detection
transfer mode - dma if available
current transfer mode - not applicable

is there something i’m not doing right with the dma or is there another solution? :)[/QUOTE]

there is one solution for this but it is a very long process if you format the c: drive partition and reinstall the os taking a backup it will fix the buffer fluctuation problem with cd and dvd if you are using a laptop make sure your connected to the power supply make sure it is not running on battaries when u burn the DVD or CD that solves the buffer problem the other choice is to findout which file got currupted in windows and try to replace it with a file which is not currupted i dont know which file is responsible for the buffer in dvd writers