Premium won't read discs/burn now

vbimport

#1

I tried to erase a TDK cdrw today with my Plextor Premium and the disc never finished, it just sat at 0%. So after 25 mins I restarted the pc because the drive was locked and when I put a normal game disc in it, it won’t read the disc, the pc just hangs while it tries to read (I tried to erase the disc with my liteon dvdburner and it couldn’t erase the disc either, the disc is bad). I tried to do a cdr burn and it looks like it burned fine but the disc is not readable in any drive (burned surface looks fine). Now my drive is out of warranty so if anyone knows a way to possibly revive the drive I’d be very greatful if you could let me know.

If there is no way to get it working, I mainly use the Premium to backup my games. I want to get a better dvd burner (liteon one is crap) so my other question is, can the new dvdburners from plextor (the one with gigarec) burn securom protected cds with blindwrite (a clone)? I know it can’t do the dvds but can it do the cds? This would save me money if it can so I don’t have to buy two drives now.

Thanks for any help on this situtation.


#2

Try to flash another (older) firmware version 1.05 for example. I assume you use the latest version. 1.05 is very stable while 1.06 may have problems with erasing CD-RW (I had some problems myself). Someone here at cdfreaks found that if you don’t eject the CD-RW after erasing with 1.06 you’ll get errors at the next burn.

Write here, if this helped. If it didn’t, perform a self test to see if your drive may have really died.

Greets,
weaker


#3

Thanks for your reply but here is the situtation. I bought these cdrws at a garage sale and the woman told me that they wouldn’t work in her burner so I thought she had a cheap drive or something. I bought about 8 of them and when I tried to erase the disc in the premium it just kept writing and didn’t stop when it should have. I’ve tried the other cdrws in my liteon dvd burner and they don’t work in that drive either.

So after I tried to put a normal disc in the premium it won’t read it at all and the burns don’t work at all either, says it might be for a different format other than windows. Now a few hours after posting here, the drive will read some discs now but its very slow and starforce protected game TrackMania Sunrise worked before in the premium but now it can’t verify the game disc. I tried to do a burn again and samething, disc can’t be read in any drive afterwards. I installed dvdinfo pro and it will give me the media info for discs but its not working much at all. I’ve never had any problems with the premium until this happened. All cdrws worked great, I didn’t need to eject the disc after either.

I’d also like to know will the Plextor dvdburner PX-716A/SW burn a securom protected cd (not dvd) with blindwrite and make a working clone like the premium can do? I know it can’t do dvds with securom but can it do cds?

Thanks.


#4

I can’t help you with copy protections. But you might know that copy protections are (in most cases) intentionally placed errors on the disc. So the error correction of the drive tries to correct them which takes time and makes reading sometimes really slow.

Does your Premium work correctly with other brands of CD/CD-RW? And did you try to flash the firmware?

weaker


#5

yes I just tried the v1.05 firmware and the samething. I’m not talking about safedisc copy protections or similar (read errors), I’m talking about securom which uses physical characteristics (it has a delay between sectors and a bwa needs to be made with blindwrite and the premium to reproduce a 1:1 copy). I also tried other cdrws (memorex) that worked before in the drive and don’t now. It says it erased the disc and burn was okay but its not readable in any drive. This is also the case for the cdrs I’ve tried in it as well. Everything looks fine besides that, do you think the lazer overpowered itself on the TDK cdrws and now doesn’t have much life left? I would really like to know if the plextor dvd burner can do securom cds with blindwrite though, I hope somebody can answer that question.

Thanks


#6

I think the laser can’t overpower itself. I think you have to run the self-test oft the drive to get further insights. See http://club.cdfreaks.com/showthread.php?t=49767#general-defective
Regards,
weaker


#7

Okay I’ll check that page out, thank you for your help and quick replies to my post.