Premium Still Buffer Underruns

Hi all,

I have a problem with my premium writer, which I bought 5 weeks ago. Its running as master in UDMA mode on the secondary IDE channel of my Win2000pro system (no other device on this). Other hardware is:
ASUS P2B, PIII600Mhz, 448 MB RAM PC100CL2.

The problem is, that I get multiple buffer underruns while burning a CD after some 20% of the CD is burned. Due to BurnProof the CD is ok, but also reading performance is affected. PlexTools read test shows, that the rate drops every couple seconds to something about 8x (please see attached jpg). I also got CRC reading errors while copying a data cd to hdd. My old Teac cd-rom would read that same cd wihtout any probs at all. Don’t know what to do anymore. I installed latest SP, firmware, chip drivers, disabled virus scanner, searched for background programs etc. The strange thing is, if I set the IDE channel mode to PIO, the read transfer rate shows no drops at all, it monotonically increases up to about 20x, where it remains. (I haven’t tried writing in PIO mode, so far.) Of course, I read this forums faq, but UDMA is already set. Is my system too slow? May the writer be damaged?

I would appreciate every hint.
Regards, -Alex.

Welcome to our forum LeVoeff!

Judging from your report I would say you have a DMA problem. You say it’s enabled but which drivers are you using for your IDE controllers? It’s recommended to use the default Microsoft drivers instead of, for instance, the latest VIA drivers which you’re probably using? Please report back!

Thanks for the warm welcome,
G@M3FR3@K.

Concerning DMA, looks like your right, I found out that I have similar trouble reading from the Teac cd-rom, i.e. gaps in transfer rate, too. The drivers are from Microsoft though, no VIA at all. The chipset is Intel BX440, very stable and reliable so far. I’ve already tried to remove the IDE controller from device manager and rebooted the system, to no avail unfortunately. Perhaps, reinstalling windows is an option to try out, at least I could count out software issues that way. On the other hand, I’m not keen to do so :confused: BTW, the IDE cable is brand new and ok. On the internet I also found voices who claimed that ACPI mode of Win2000 may responsible for this due to IRQ settings. Have you any idea?

Thx, -Alex

I have no experience with Windows 2000 unfortunately. Since you’re already using the default IDE drivers I don’t really know another option you could try. Perhaps someone else has an idea?

If i remember right the 440 chipset works with 100MHz FSB right? Anyways, since the MS drivers might not serve you right, maybe the Intel Application Accelerator might be better (if it supports your chipset), you can grab it from www.intel.com
Also it might help if you tried burning with different, better quality
media.

You can finally try moving the drive to another system if possible and see if the problem persists.

Hi Hemispasm,

you’re right, BX440 with FSB100, but at least with faster RAM (clock2). Anyway, intel accelerator doesn’t support this chipset. I’ll try better media and maybe the drive in another pc, too.
After all, I could burn an audio CD 24x with no buffer underruns, yesterday.
-Alex.

An additional question: is ist possible that the power supply unit isn’t sufficient? It’s still the one that the system had when I bought it 5 years ago. Just a thought…

Ok, the problem has gone away. I’ve moved HDD and Premium drive to another Asus MB with an Intel815 chipset. After that, no buffer underruns occured, but I still had little problem when performing read transfer test. With every tested CD, reading performance would heavily drop down when reading about the last 5-10 percent of data (see pic). Also the overall rate wasn’t as high as expected. However, upgrading to firmware 1.05 yesterday let the reading problems disappear, at least the three CD’s I tested yesterday would read perfectly linear up til the end.
After all, it seems to be a happy end…

:bigsmile:


Thanks for the update, LeVoeff. Good to hear your problems are gone now!