Power DVD and Radeon 4850 = no Blu-ray? (Lite-On DH-401S)

vbimport

#1

[qanda]This thread is about the Lite-On DH-401S. Click here to see full specs[/qanda]Ok so I have the Lite-on DH-401S Blu-ray reader and a MSI Radeon 4850. My blu-ray drive has firmware 56 which is most current on the lite-on website and my 4850 has catalyst 8.10. My blu-ray drive is using the windows driver but I cannot find one for the lite-on drive, only firmware. I have acer x221W monitor which is HDCP complient. I am using cyberlink power DVD the free one that came with my drive, fully up to date. I also am using Vista 64 w/ 4 GB RAM and a 3.0GHz dual core AMD 6000+.

I have tried 3 blu-ray titles. Black Hawk Down, The Patriot and Iron Man. They all give me audio and a black screen. I can see the menus but not anything behind them, just the plain old menus. No video plays but audio works just fine.

I have looked all over and many people have had this problem but no one knows why. Some say it’s power DVD some say it’s the ATI drivers. I have rolled back the ATI drivers to 8.4 the supposedly last “working” one and same issue. Only thing I have not tried is upgrading to Power DVD 8.

This is driving me nuts! Please help! Anythings appreciated.