Post new firmware and tool ANNOUNCEMENTS here

vbimport

#203

I’ve read the firmware from it in DosFlash
PX-880SA_defect.zip (1,4 MB)
…during reinstall the EEprom the system hanged-up :frowning:


#204

Probably all software is corrupted.
Try to get DosFlash -Write firmware first.
It should flash firmware after flashing.
Do you have a copy of the Eeprom drive?

Firmware to be installed by DosFlash.


#205

Hi czary2mary1,
thank you so much for the firmware and yes i’ve had Eeprom saved and now it will be recognice … BUT the laser is defect :frowning:

can i exchange the laser from an other device like an Optiarc AD-7191S?
BR


#206

Search for Sanyo SF-DS19L \ S laser
These are the Optiarc-Sony AD-5240 \ 724xS
Find clones in LiteOn DH16AAS \ AAL or LiteOn iHAS x24A, or Asus DRW24B1ST \ LT \ BenQ DW240S, HP dvd1260d, Philips SPD2525P,
Available in China are very poor quality - counterfeit product.
http://www.aliexpress.com/store/product/Free-Shipping-Original-SF-DS19T-SF-DS19L-Optical-Pickup-SFDS19T-DVD-Laser-Lens-Optical-Pick-up/813763_32780119542.html

Here you have to exchange:


#207

Firmware 1.K9 for Plextor PX-891SAF-PLUS:

https://workupload.com/file/qhAqNX4

No changelog known.

Maybe someone else could upload it to FirmwareHQ.

It’s quite awkward that Vinpower doesn’t offer firmware downloads on their website.


#208

Here is Firmware 1.KB for Plextor PX-891SAF-PLUS.

https://workupload.com/file/ZQnzUqy

This link won’t be working too long. Somebody else please upload this to Firmware HQ.

According to Vinpower 1.KB = 1.KU. It seems that newer samples of the drive are shipped with 1.KU installed, while 1.KB is the same for updating older samples.

No changelog. No official download link on Vinpower website. :unamused:


#209

Thank you again.

Have you used this flasher successfully? The program design appears to be quite different from the previous integrated flasher/data packages.


#210

Yes, I have updated the firmware successfully.

  1. Unpack 1.KU.rar manually.
  2. Make sure that PCDriveUpdater1.5.1.exe and data.bin are in the same directory.
  3. Start PCDriveUpdater1.5.1.exe.

#211

Just experienced a repeated flash failure with this 1.KB flasher for the PX-891SAF-PLUS.

My drive originally came with 1.K8 and I updated it successfully with the 1.K9 flasher posted earlier this week.

In the same environment I unpacked the 1.KB archive into its own folder and ran the updater using elevated privileges. It allowed me to select the Plextor drive, recognized it is having V1.9 and listed the to-be-updated-to firmware as V1.KB. After some whirring it announced a failure and invited me to retry - which I did, without progress,

The drive was frozen with the LED continuously on. Windows recognized it as an unresponsive CD drive, and Nero reported it as having firmware V. 0WKF.

Fearing it was bricked I went for broke and re-flashed using the 1.K9 flasher - successfully - returning the drive to its former, functional state.

It seems as though people have used this flasher successfully - so I’m at a loss to explain why it failed. Possibilities:

  • Different hardware variants of the drive
  • Flasher confused by long or complicated path name in finding folder containing the binary (if so, why then did it display the correct upgrade firmware rev?)
  • Some other idiosyncrasy which the integrated flasher does not have,

#212

As mentioned earlier I successfully updated to 1.KB.

Drive seems to be working fine except for one thing. According to IMGBurn device buffer fills only up to 75 percent. With 1.K7 it was around 95 percent.

I informed vinpower.eu about it. They’re investigating this right now.

Please report your problems as soon as possible to Vinpower. 1.KB seems to be bugged, maybe seriously flawed. You’ll find a mail adress on their website. Thanks.


#213

I’ll stick with 1.K9 then.

I was going to ask Vinpower about the flasher, but they might balk since they did’n’t … um … actually send me the misbehaving code and it isn’t publicly posted.

There is a posting on cdrinfo.pl which says (translated):

Special firmware version for duplicator drives and print robots. Included with update flasher and firmware version. FIRMWARE IS NOT INTENDED FOR RETAILED VERSIONS - THE DRIVES MAY NOT WORK AFTER UPDATING CORRECTLY IN COMPUTER KITS.


#214

Official download of

  • Firmware 1.KB for PX-891SAF-PLUS and
  • Firmware 1.JB for Plextor PX-891SAF

http://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/downloads.aspx

Changelog for both drives:

• Optimize FTI CDR writing strategy
• Optimize MKM CDR writing strategy
• Optimize FTI DVD-R writing strategy
• Optimize Maxell DVD-R writing strategy
• Optimize Optodisc DVD-R writing strategy
• Improve DVD+R DL writing quality
• Improve DVD/BD Player compatibility on DVD+R DL media when booktype is set to ROM
• Improve Device Buffer Management Control for legacy system compatibility


#215

I think the 75% device buffer topic has something to do with “Improve Device Buffer Management Control for legacy system compatibility”.

Since the New MTKs has such a small intergrated buffer, the timing of legacy system’s write command must be very different and they may did something to work around it.

Even though the device buffer shows 75% on Imgburn, everything worked well on my 891SAF after flashing it to 1.JB!!


#216

I now know why I have been having firmware flasher issues with V1.KB.

See Plextor PX-891SAF PLUS


#217

New Update:

**Firmware 1.KD** for PX-891SAF-PLUS
**Firmware 1.JD** for Plextor PX-891SAF

https://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/Downloads.aspx

Changelog:

•Optimize Ritek DVD+R writing strategy
•Increase failure tolerance on DVD recordable media.
•Finetune write power for CD/DVD recording.
•Improve support on DVD+R DL 8.7GB recording capability. (on supported drive model)


#218

Do you think you can upload that .bin for FW 1.07?
I tried to crossflash my Drive to iHas but I guess something went wrong and not my drive won’t even read discs anymore. It’s still detecable though.
Thanks!


#219

Hello Sir!
Do you think you can reupload stock PX-L890SA (1.07) bin? thanks


#220

flash_PLEXTOR_DVDR_PX-L890SA_1.07.zip (630,9 KB)


#221

Sorry is it possible to have the firmware 1JD for PX-891SAF in BIN format?

Thank you


#222

Plextor PX-891SAF: new Firmware 1.JE

Plextor PX-891SAF PLUS: new Firmware 1.KE

https://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/Downloads.aspx