Possibly turned my drive into a paperweight with an eject button

I tried to update my Asus burner’s firmware and the windows firmware utility froze. After about 20 minutes I shut down the computer. Now BIOS doesn’t like the drive at all and rarely starts with the drive in. I tried hooking it up to a USB IDE connector and that didn’t recognize it either. Any suggestions?

new here,
alan

Which particular model?
If it is a newer one, it might be that you could try flashing it with XSF.

it’s a 52x cd writer, model crw5224a…seems like it’s a popular one.

kage, how about this: http://club.cdfreaks.com/showthread.php?t=67974

ok i got this figured out. i guess what i need is a bin or a hex of the firmware for that drive (asus crw-5224a). i have an *.afs version of it, but you can’t convert that to binary as far as i know. anyone own this drive? i’ve looked everywhere.

so nobody has this drive?

Most people around here use a Plextor for CD’s only other wise some like me use DVD RW’s to burn CD’s.