Pls help! Burst rate stuck at 17mb/s

vbimport

#1

Hi guys. Juz bought an internal benq 1620 (bp79). Was testing my burst rate and found it to be only 17mb/s instead of the usual 23mb/s. Can someone enlighten me how to make it to 23mb/s so that i can burn at 16x. I have enabled DMA in both bios and OS but still no improvement. Below is my specs info. Thks guys

System: PIII 750mhz
Board: Abit BX6 II (i440BX-W977)
OS: Win 98 SE


#2

Your drive could be operating in DMA Multiword 2, which has a maximum transfer rate of 16.6 MB/sec… I would doublecheck the BIOS, and make sure that it is set for Ultra DMA capability, not DMA Mode 2/PIO Mode4. The drive has to operate in Ultra DMA Mode 2 (max 33 MB/sec.) to achieve top speed and efficiency.

If the BIOS is set properly, try uninstalling the drive in Device Manager and reboot. Windows will redetect the drive and hopefully allow UDMA transfer rates. Also, check your IDE cables. A bad cable could be causing your problem. It’s best to use an 80 wire cable with the drive. If the drive is set as master, it should be at the end connection of the cable.


#3

Hmmmmm, I’ve got that board on one of my older systems.
What chanel do your have the BenQ on? Is it jumpered to master?
Do you have “auto” selected in Bios/standard CMOS/drive detection on the chanel that your BenQ is on?
Any change made? What happens?
If not,
Try moving the BenQ to your Future ATA IDE Controller, use “80 wire” connector & enable Future ATA IDE Controller in Integrated Peripherals in your Bios.
What happens?
You may have to upgrade OS to WIN XP…I run that on this system, no problem. Have older NEC 2510 internal IDE (not future ata) get 25MB/s on burst. Unfortunately will only write at 8X, but does this well.


#4

If your motherboard is capable with UDMA, the motherboard setup disk should include a PCI IDE CONTROLLER driver for Windows 98. Use auto in your bios setting for IDE0, IDE1, IDE2, IDE3 should be fine.

40 wire cable is good for 16MB/s and 33MB/s (all three connectors are black)
80 wire cable is good for 16MB/s , 33MB/s, 66MB/s, 100MB/s (The connectors are black, gray and blue)

As long as you didn’t connect a harddisk to a 40 pin cable that is fine. Don’t worry.


#5

This is how my award bios look like. can u give some comments if it’s running on udma? The only options for udma is disable and auto.


#6

my benq is on sec master
my tdk cyclone on sec slave
both are set to auto in cmos
There isnt any “future ATA IDE controller” option in my integrate peripherals. also, my award bios is released 1999. does that matter?


#7

not sure which type mine belongs to, but all my hdds and writers are connected by a single “cable” with connectors fixed to each device.


#8

windwind - Hi - hit the ‘pause’ button at the very last of the POST screens when booting-up [ie just before Windows fires up]: you should then see details of what actual transfer protocol your BIOS is using for your IDE/ATAPI devices.

  • hit the ‘enter’ button to continue/get out of ‘pause’ . . . .

#9

ok, this is what i got. Is this fine?



#10

I am VERY supprised that your HDD’s are running at UDMA33… It looks like you have them wired with an old 40 wire cable & not a new 80 wire cable.

I suggest that you take a look at the cables linking your HDD’s & CD’s up, if they look similar to a floppy cable (widely spaced wires the same as the floppy) then you have old 40 wire cables & need to replace them with 80 wire cables. Even though the BenQ is a UDMA33 device it benifits from the better signal quality of a high speed cable.

Appart from that UDMA33 is the correct speed for the BenQ drive.


#11

Not really. It looks like the Intel BX chipset does the best it can, that is UDMA 2, 33MB/sec.


#12

Not really. It looks like the Intel BX chipset does the best it can, that is UDMA 2, 33MB/sec.

Yeah, forgot that the BX was from the old stable.


#13

hey thks guys for the many response i’ve obtained. So it narrows down to the 80 wire cable? indeed i shld be using 40 wires (becos i have NEVER change my cables since i built this sys). So guys, changing to 80 wires will improve my burst rate from 16~17mb to 23mb/s ???


#14

No, the 80 wire cable will not change the speed.


#15

hmm…wat could be the cause then? ponder ponder… :confused:


#16

What model exactly is your motherboard?
Mine is B6-II v1.2 with Award Bios 12/03/01
Go to:
http://www.lavalys.com/
Download Everest 1.51, Home Edition…will give you very good info on your system.


#17

mine’s a BX6 2.0. is urs running fine?


#18

ala42 is right. No “80” IDE-cable will ever speed-up a slow IDE bus… :wink:
BTW, I use a 3y old 40 conductor cable and get 27Mb/s burst and transfer rate.
[Asus P4P800-E mobo]

Here is a simply tool to identify your mobo (incl. version) memory and cpu. :slight_smile:


#19

Run the CD-DVD speed as what you do normally. Then try to close all the application before you start CD-DVD speed. Compare the burst rate between the two test.
If there is a noticable different.

Is there any spyware in your system?
Are you using antivirus and firewall program?
Try to disable anitvirus before running the test and while burning any dvd


#20

Could be your system doesnt have enough horsepower. DVD burning requires extensive CPU time, plus your hard drives are old as most of us have ATA100/133’s.
You just may need to upgrade your system.