Plextor PX740A External CD / DVD Burner

vbimport

#1

[qanda]This thread is about the Plextor PX-740A. Click here to see full specs[/qanda]Guys, I have some questions regarding my PX740A External Burner:

  1. The tray often won’t come out after I pressed the eject button. I always hear a clicking sound from inside the drive and it sounds like the tray wants to come out but something prevents it from coming out (just my guess though). If i try to press the button again and again, the tray will eventually come out after like…15-20 times of eject button pressing frenzy.

  2. After the tray (finally) come out , 9/10 times, if i place a media (with or without content) and close the tray, my system freezes, and yes, CTRL ALT DEL is not working.

Prob no 2. has been happening for like a year but i don’t mind since sometimes i can solve this by un-plugging and re-plugging my 740A USB connector to my CPU before i insert any media. Recently, prob no. 1 came. Having these 2 problems at the same time is horrible.

I’m using Win XP as my OS and I’m using USB 2.0 as an interface for my 740A.

Any suggestion?


#2

Hello and welcome to CDFreaks!

The Plextor PX-740A is based on a Benq 1640 drive. So if you haven’t found anything about this problem here in the Plextor forum, you should also look in the Benq forum. For example here are two threads that deal with your problems:

http://club.cdfreaks.com/f92/benq-1640-tray-open-close-problems-198561/

http://club.cdfreaks.com/f92/benq-1640-click-when-opening-closing-tray-145393/


#3

[QUOTE=ult1ma;2167321]1) The tray often won’t come out after I pressed the eject button. I always hear a clicking sound from inside the drive and it sounds like the tray wants to come out but something prevents it from coming out (just my guess though). If i try to press the button again and again, the tray will eventually come out after like…15-20 times of eject button pressing frenzy.

  1. After the tray (finally) come out , 9/10 times, if i place a media (with or without content) and close the tray, my system freezes, and yes, CTRL ALT DEL is not working.[/QUOTE]
  1. The sticky tray problem is a common one for the PX-740A/UF. It seems to happen slightly more frequently with those drives than the BenQ DW1640 the drive is based on. I’m not sure why this is so, but my anecdotal experience buying lots of DW1640-based drives points to the problem being more common with the Plextor rebadges.

  2. First of all, stop pressing the button. You’re only making the problem worse. When you press the button the first time, leave it alone until the drive makes the clicking sound and then for a few seconds after. When you’re sure it’s finished trying to open, then, and only then, press it again, and press it only ONCE. On some drives it can take as many as three or at most four tries before the tray will open. Continually pressing the button does not help, because at some point, the tray is in fact opening, but because of your button pushing you’re actually causing the tray to close again, defeating your own purpose.

  3. Make sure you have the latest version 1.02 of the PX-740A firmware on your drive. If not, update it. One thing you may consider, since the drive is acting up, is to cross-flash it into a genuine BenQ EW164B, which is the external version of the BenQ DW1640 (just as the PX-740UF, which you have, is the external version of the PX-740A). Read the FAQ in the BenQ forum for more information about that. If you do decide to cross-flash, use firmware version BEFB.

  4. BTW, it’s a little unclear from your wording, but are you using an actual Plextor-made PX-740UF external drive, or do you have an internal PX-740A that was placed in a third-party non-Plextor enclosure?