Plextor PX708-A and UDMA

vbimport

#1

Hi!

I got a Plextor PX708-A (Firmware 1.04) since last week and got a problem with the Ultra DMA Mode.

Windows XP won’t work in UDMA with the drive - PIO is automatically chosen by the OS and even if i try to change to UDMA it stays on PIO.

Now i tried this tipp: http://club.cdfreaks.com/showthread/t-59601.html
This worked very fine after one reboot. But since the second reboot the drive is working in PIO mode again.

In the BIOS of my Asus A7V333 (VIA KT-333) i also tried to set it to UDMA - i can switch in the menu but also the BIOS won’t work with the Drive in UDMA together.

I got round cables - unshielded. All my other Harddisk Devices (3 HDDs) working with this cables in UDMA only the Plextor wont.

Configuration:
HDD1 - Primary IDE as Master
HDD2 - Primary IDE as Slave

HDD3 - Secondary IDE as Master
Plextor PX708-A - Secondary IDE as Slave

Can anybody help me and tell me what my problem is?

Mario

PS: Sorry for the bad english!


#2

Hi and be welcome :slight_smile:

About your English: nothing wrong with that. You made quite a clear post, so we won’t complain. OK? :smiley:

Anyhow, you say that your Plextor drive doesn’t work in DMA mode with the round IDE cables you’ve got. Does that mean that your Plextor DOES work fine with standard IDE cables?
If so, we know the cause of this problem.


#3

Originally posted by Dee-ehn
Anyhow, you say that your Plextor drive doesn’t work in DMA mode with the round IDE cables you’ve got. Does that mean that your Plextor DOES work fine with standard IDE cables?
If so, we know the cause of this problem.

Hi,

i’ve tested it with a normal IDE cable and i get the same result - only PIO mode.

Is it a Mainboard BIOS Problem or is it a Windows XP Bug? And can BIOS detect shielded cables? Because in BIOS is written that you can only USE DMA if you use shielded IDE cables.

I don’t have shielded ones, but all my other HDDs work fine in UDMA5 with it.


#4

It could be a mainboard (BIOS software) bug, but it could as well be a software bug. Even if the BIOS says DMA mode is not possible (the story about the shielded cables is something you shouldn’t worry too much about, that’s just a way they ensure themselves that you won’t be calling the helpdesk too often) it could be that the DMA function works OK in Windows.

Maybe you can read my sticky thread ‘My optical drive is…’, there are some good hints there!


#5

My problem “faded” away after i read this article on the Plextor Website:

Article ID. G00012
Why do I get data corruption or CRC errors with Windows XP or NT?

In rare instances, the Windows Operating Systems will generate event errors when writing data to a Plextor PX-W2410TA, PX-W4012TA, or PX-W4824TA, or generate CRC (Cyclic Redundancy Check) errors when opening large self-extracting files from the CD. The data errors may cause the system’s UDMA driver to step down to PIO mode. PIO mode does not use CRC to check for data errors. PIO mode is much slower, and the system must be reset to UDMA for optimum performance.

This situation will generally occur when the IDE cables are routed too close to each other, or run parallel to each other for more than a few inches. The phenomenon is called “crosstalk”, and is caused when signals from one cable or wire are picked up by another cable or wire that is too close. The higher data transmission speeds of UDMA can cause “ringing” of a signal, generating an electrical field that can affect signals on an adjacent cable, much like a radio picking up static when near high-power electrical lines. Crosstalk can be reduced or eliminated by an air gap between cables.

Some vendors coil up the cables or tape them together for ‘neatness’, or run one cable atop another when routing from the motherboard to the peripherals. The solution to crosstalk is to separate the cables by a few inches, or replace the standard IDE cables with UDMA 80-pin cables. The UDMA 80-pin cable uses the same 40-pin connector as the standard cable, but adds ground lines between the signal lines to reduce or eliminate crosstalk.

It is also possible the system motherboard ATAPI controller may not meet timing specifications. Installing the jumper on the drive UDMA connector quite often will alleviate this problem.

> http://www.plextor.com/english/support/faqs/G00012.htm

Now i bought two shieldef UDMA-133 cables and everything is working fine.

Maybe you can include this in a Sticky Thread.

Greetings from Germany
Mario


#6

Thanx Mario,

It’s great to know that your problem was resolved by replacing the cables.

Last week I build a system for a friend (equipped with a Asus A7V-KT600 mainboard) and I was quite wondered that the board still came with a 40 pin IDE cable. I think I’ll be adding this to the sticky thread, as this might be the case in more situations!