Plextor PX-891SAF PLUS

vbimport

#141

Did you use the official 1.KB from vinpower website?

http://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/Downloads.aspx

If this doesn’t work I’d recommend to contact Vinpower:

http://www.vinpowerdigital.com/main/ContactUsForm.aspx


#142

yep, even restarted the computer and tried it again and like i was saying it shows up everywhere except the update utility??? guess i’ll shoot em an email and see what they say. thanks.


#143

Did you connect through USB or SATA directly?

I am using Windows10 64bit and connect directly to SATA without any issue updating to 1.KB.


#144

Just a caveat about the 1.KB flasher as it seems to be problematic for some.

I have the boxed retail version of this drive which was originally received with firmware 1.K8. The drive is housed in a Vantec NST-530S2 external enclosure which uses the Sunplus SPIF225A SATA-to-USB2 bridge chipset. (For what it’s worth, this enclosure has been used with a diverse collection of SATA optical drives for both data operation and firmware updates without incident. While I understand all the risks and caveats of doing certain critical operations through a USB-to-SATA bridge, I have really never been bitten). When I had the problems (posted upthread, and summarized below) it hadn’t even occurred to me that, “in this day and age”, this could present a problem anymore.

I had originally attempted to update using unofficial updater linked to in this thread. It caused my first-ever flash failure in one of these external enclosures over a course of 10+ years of doing so. Looking at the LED’s it seems that the new flasher erased the flash ROM successfully but was unable to faithfully transfer the payload data, with the flasher indicating a programming failure, inviting me to try again (did so, no difference). The drive was left in a semi-bricked condition, frozen with the LED continuously on. Windows recognized it as an unresponsive CD drive, and Nero reported it as having firmware V. OWKF.

Using the V1.K9 flasher, also linked to in this thread, which appears to use an older flash firmware updater program, and in the same environment (Win10 x64) I re-flashed successfully - returning the drive to its former, functional state.

When the “official” V1.KB flasher was posted to the Vinpower web site, I tried this all over again with exactly the same result. The flasher appears to be the same basic code except that the payload is integrated instead of being stored in a separate binary. After the failed flash, I recovered using V1.K9 and the older flasher program, and then transferred the drive to a different enclosure which uses a JMicron bridge chipset and successfully updated to 1.KB. Put back in the Ventec enclosure it works as before.

I conclude that the new flasher is using some commands to transfer the flash binary to the drive that are not properly passed by the Sunplus bridge controller. Perhaps there are other issues as someone posted that it did not recognize their drive when connected via a motherboard SATA port.

I contacted Vinpower about all of this. They indicated that their programmers were aware of my issue (but apparently did nothing, though they said they would refer this to the programmers again). They suggested updating the “driver” for my enclosure (I assume they meant, firmware). Failing that, to flash using a USB enclosure using a JMicron bridge controller or by direct SATA link.

I mentioned in response that the SPIF225A does not appear to be field flashable (and so was judged to be immune to the “BadUSB” malware). Nobody (even station-drivers) has postings of firmware for this controller. I was actually hoping they would go back to the earlier code. Will see if things change when everyone returns from the holidays.

FWIW.
YMMV.


Post new firmware and tool ANNOUNCEMENTS here
#145

well after a few emails back and forth with vinpower support I finally got my retail drive to flash from 1.KU to 1.KB. they sent me an updated updater yesterday that still wasn’t working and giving me an error and then i get home from work today and they already sent me another updated version. so at this point looks like they got the bugs ironed out. i’m asuuming they will be updating the download page soon but if anyone wants or needs a copy of the version they sent me, just hit me up and i can forward the email to you or upload it to my onedrive and give you a dl link (or post it here but not sure if that’s allowed??). got to say tho, vinpower support is second to none! a big thank you to everyone involved. the community here at club.myce is pretty awesome too! love it! now… if we could just get the rest of the world to be as nice we’d be in good shape. cheers!


#146

+Freewayy it’s sata connection on asus sabretooth 990FX r2.0 but check out my other post from today for an update! thanks!


#147

Looks like there is another new firmware 1.KC available from Vinpower.

Change Log:
• Improve Servo Stability
• Improve Tray Sensor Mechanism
• Finetune CDR Writing Strategy

http://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/Downloads.aspx


#148

What are they?


#149

They got lost in the transition from the old web site to the new. I no longer have the images.


#150

I see.


#151

anyone else have a fix for tray not opening when you hit the button? where after you press the button you here the motor sound like its trying to open but doesn’t unless you got a finger nail long enough to get in there and pry the tray down and then it will open? just started doing it last week. saw there was a new firmware and i updated but still doing it. It happens randomly with or without a disc in the tray. and it once it gets stuck its stuck until you pry it a bit then its usually good for a minute.

had it for at least a couple months now so i’m sure it’s out of warranty. any suggestions?


#152

Either the drawer motor is going bad, or (more likely) the belt that opens and closes the drawer is slipping.

This is a longstanding categorical problem with aging Lite-On drives, but I have never heard of it happening on such new hardware.

Disassembling the drive to replace the belt is really not an intricate task; the trick is finding a new one of the same thickness and diameter. It is were my drive I would have a look inside in case there is something less serious; perhaps some grease from the drawer gear has oozed onto the belt, causing it to slip but not fail. Cleaning it off might fix the problem/


#153

ok, guess i’ll have a look… at some point… this sux. glad i’m not a high volume duplicator. just a music nut.


#154

oh, and thanks.


#155

anyone test this drive in EAC to see if it can overread leadout or leadin?

to test you have to insert an EAC reference audio CD and disable accuraterip auto config of the drive on the drive options page. EAC will then allow you to scan a reference CD and give you a report on the offset and if the drive can read the leadout and lead in. by being able to read leadout and leadin the drive can read a few samples on an audio CD other drives cannot read which are replaced with silence on other drives. here is a list of reference CDs you can insert for EAC to do this http://www.exactaudiocopy.de/en/index.php/overview/basic-technology/list-of-included-reference-cds/

dbPoweramp and other tools might be able to test and report on overread of leadout/leadin as well.

looking for any drive that actually do this on the market today for best audio rip ability. anyone know? I know for a fact the iHAS124-14 F and iHAS324-17 F CANNOT, so the only other option is to try the AD-5290S/AD-5290S Plus/Plextor PX-891SAF Plus/PioData drives which are labeled as ‘duplicator grade Lite-ON’ drives, and maybe LG drives sold on newegg. as AD-5290S is based on iHAS124/324 doubt it will work, but it does report the ability to overburn CD-R to 99 minute which hints at the ability to overread the disc (not aware of if the iHAS124/324 themselves allow overburn of CD-R to 99 min). AD-5290S Plus/PX-891SAF Plus as described is entirely different drive - so its worth testing to check. not many drives on the market today so there’s not a lot of choice. overreading leadout/leadin seems sort of rare to come across. :smiley: :slight_smile:


#156

New 1.JD/1.KD firmware release from Vinpower for Plextor PX-891SAF/PX-891SAF Plus.

Change Log:

•Optimize Ritek DVD+R writing strategy

•Increase failure tolerance on DVD recordable media.

•Finetune write power for CD/DVD recording.

•Improve support on DVD+R DL 8.7GB recording capability. (on supported drive model)

https://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/Downloads.aspx


#157

New Firmware 1.KE:

https://www.vinpowerdigital.com/main/TechnicalSupport/Downloads/Downloads.aspx


#158

Astonishing - continuing to see ODD firmware updates every few months these days.


#159

Verbatim DVD+R DL 8X
Mediacode: MKM003 Made UAE Printable
Plextor PX-891SAF Plus fw.1.KE
ImgBurn 2.5.8.0
Burned at x4 —>Possibility to Burn 4x 6x 8x

Audi map navigation 6,67GB


#160

Hello guys,
Do you know if this drive caches audio data?
I’d like to use it with EAC and caching would be a drawback.
Thanks in advance.