Plextor PX-716A Dead?

Hello all. I just come across a Plextor 716A for a buddy and wanted to make sure it works.

I hooked it up to my backup pc and swapped it with my current PX-716A-setting it identical. Dvdidentifier said the fw version is 1.10,just like my working plexy. This backup pc is not hooked to the net.

The yellow/green light kicks on,but when time for the writing,blinks green and says insert disc. I’ve tried all the blank discs in my collection. I even tried playing an original on it and the yellow light blinks. I also tried uninstalling drivers and reboot and same result.

I had 0 issues with my regular 716a,using plextools that came with it.

My questions:

  1. Would there be a conflict with plextools with the 2nd plexy?

I’m thinking this is a refurbished drive,I noticed the seal was broken and the official plextor sticker label removed.

  1. I’m guessing the firmware is lost, needs reflashed–couldn’t hurt any?

If I reflash, It’ll be on my main pc which has only had HP and Benq drives. I’ll swap out my 1650 from it-being identical to my backup pc,running secondary slave.

Benq’s,No problem. Plextors,I’m a newb! I saw a few plextor threads and the links gave a lot of different utilities.

I have downloaded Plextools Professional V3.11- the free version.

Anything else I need to d/l?

Thanx!

Yes…
at the least go to plex site and d/l last firmware…v1.11

Since it is refurbished,
open it up, dampen a Qtip with alchohol and clean the lazer lense…[tiny glass looking lense in middle of unit.]

I have had 2 plex 716A units I though were ready to be trashed brought back to life this way.
.

good luck…

Will do rago.
Have to work today and suppose to be a major snow/ice storm heading my way this afternoon.

I also downloaded PXupgrade32-v1.26

You can read this thread and try this in case the lases lens clean does not solve the problem:

http://club.cdfreaks.com/f43/help-px-716a-burns-read-cd-ok-dvd-burn-fail-229412/#post1903189

The laser pickup problem seems to be a common problem with the 716. I’d try both, at least you can not loose!

[I]Saugmon,
this a more in depth repost of mine a while back…[/I]

I had the same problem with 2 previous Plextor 716A units.
CD burning/writing would not be affected but dvd burning/reading didn’t work…
Reinstalled Nero, Image burn, plextor stuff, you name it.
here’s the fix for many units…

Shut down, Take the unit out but Don’t do any "remove hardware"
or stuff like that since you will be putting it back in, turning the PC back on and Windows will be non the wiser…

cut the “do not remove tab” on the side of the burner.
this voids 1st year warranty unless you want to send it back but this is what they do to most of them…

Open the Plextor up. 4 little screws I think…
in the center of the inside you will see a tiny glass lense.
this is the laser/lazer?
take a small cotton swab and just dampen it in regular Alcohol… DON’T SOAK IT…
Clean the lense in a circular motion,
don’t worry if you don’t see any dirt cause it’s there in some form be it cig smoke, dust or whatever…
put the unit back together and turn it on.

I have saved 2 Plextors this way…
same errors like power calibration error, cannot read disk etc…and it is usually a not so clean lense…

Tony

rago88
View Public Profile
Send a private message to rago88
Send email to rago88
Find More Posts by rago88
Add rago88 to Your Buddy List

« Previous Thread | Next Thread »

Thanx for the help rag088 and TM.
I finally got a hold of the dealer.

I’m going to rma it before I start tearing into it.

I did get some knowledge and programs in case my main PX716A starts acting up.

I’ve got a nice stash of q’s,I’d hate to sell any of them to my buddy.