Plextor PX-712/SA Severe Problems?!

vbimport

#1

Hey everyone, stumbled upon this fine site while I was searching for an answer to my dilemna. Let me give you a bit of a background on why I’m even here…

I had my first experience with a plextor drive when I acctually bought my iomega 12x drive. Wow was that a reliable burner. I then had a plextor branded 40x24x40x. Same deal… one of the most stable burners I’ve ever used.

Now… for Xmas, I recieved a lovely new 712/SA from my girlfriend.
Install the unit into my computer, and it’s amazingly silent.
Reinstall windows… Fast as can be… GREAT I’m thinking. Misc programs all installed, now time to install World of Warcraft lol.

Get about half way through the install… and the burner starts making a really funny noise. A VERY loud buzz. Drive spins down to a stop, and the computer freezes. MMk I think? Must have been some reinstall gremlin. Try it again. Don’t even get 10% into the install. Same buzz… same freeze. My drive came loaded with firmware 1.04.

Is this drive defective? or is something else wrong?
I’ve also been reading some horror stories about the 716 which I was thinking of getting. BTW she ordered the drive from zipzoomfly.com and they say it’s a special order item, and that it’s non-refundable. Is there any way that if these drives are having this many issues that I can make them take it back?

Thanks everyone,
Chew


#2

If everything else worked just fine then I wouldn’t think your drive is the problem. I remember there were some problems with the game Halo 2 and its used copy protection but that’s about it. Have you tried reading the game in a different drive? Did you try to read other games with the drive?


#3

yea, that’s the thing, I’ve installed other games just fine with the drive, however WoW simply will not work. And the kicker is that it happens at different times when I try to reinstall it.

I’ve successfully installed WoW with the game when I went into plextools and limited the speed of the drive to 10-24 X CAV. This is the only setting the drive didn’t spin out of control, and give me that buzz then lockup my computer.

The game installs just fine on any other drive that I’ve tried.

Thanks guys,
Keep em coming :slight_smile:

Chew


#4

Try upgrading your firmware to 1.05 via the plextor website. Have you examined your WOW disk? Try cleaning it. Perhaps there is some schmeg stuck somewhere on it.

Has your drive worked well otherwise? Is this the only disk giving you problems?


#5

I assume this is the SATA version from the model no.?

If so, is your mobo on Plextor’s Compatability List?


#6

Well, I decided not to even worry about it…
I went to Best Buy to get their last 716, took it home, and took the 712 back in the 716 box. Yea shady I know, but after being on the phone with Zipzoomfly all day, I was sick of it. And I just told best buy that it was defective, and they shouldn’t sell it again lol.

So now I’ve got a better drive for my xmas gift.

Chew


#7

Oh Chew, not a good idea. Plextor will notify BestBuy. Bestbuy, which scanned the drive’s serial number to your reciept when you returned the drive, can track that back to you. You might want to think of a good excuse when they come for you. Yikes.


#8

acctually… gotta love cash. there’s no record of me even purchasing anything at that best buy which acctually just opened.

I know it’s shady, but after working for the company and having them screw me… (long story) I figured it was the least I could do to return the favor.

Plus, no scanning of SN’s was ever done.

Chew


#9

??? I’m not going to ask. All’s I know is that BestBuy always scans the UPC barcode and takes down your name, address and signature when you return an item. But again, not going to ask . . .


#10

Another good reason to be careful with open box items at Best Buy.Thanks Chew.