Plextor PX-708A firmware 1.06 released!

vbimport

#1

PX-708A/UF V1.06

Fixed Bugs:
If DVD-R/RW medium is written by using the firmware version 1.05, a medium that cannot be recognized with some DVD devices may be created.
PX-708A/UF V1.05

Added:
Support for newer DVD-R media.
(Including support 2x/4x speed writing on 8x DVD-R media)
Support for newer DVD-RW media.
(Including support 2x speed writing on 4x DVD-RW media)
Improvements:
Write performance on DVD media.
High Speed write performance on CD-R media.

http://www.plextor.be/download/ftp1/708A106.exe

enjoy


#2

Thanks dolmar! I’ve updated the title of this thread so it’s more clear this way :wink:


#3

Nothing yet on the Plextor Europe download page :frowning: http://www.plextor.be/English/technical/downld_firmw_708A.html , so after having rather bad expirience with 1.05 I will wait for others to try this time :wink:


#4

Well, work just bought me a 708UF for backing up files and such…the firmware applied just fine, but I probably won’t be burning too many DVD’s at work yet. I can let people know how the CD part of things go fairly soon, though.


#5

sweet deal, but i think ill wait for someone to test it before i run and apply it :wink:


#6

this firmware does not work either. Now +rw burned at 4X are not readable in anything. I reburned the same imaged on nec with same media and it worked fine.

Guess i am going back to 1.04


#7

God bless you Dolmar for being our little guinea pig…errrrrr I mean tester. lol:bigsmile: :bigsmile:


#8

Thanks for not argueing with me like last time i said there was a problem with 1.05 and then 20 peple said my drive was broken and stuff… and then within 2 days plextor recalled the firmware and everyone start to notice there burns had a ton of errors and did not work either.

Btw just finished burning the same image at 4X on +RW with plextor and firmware 1.04 and the disk is readable.

I think it is a real shame that plextor can get this drive to correctly either.


#9

Well this sucks. I just upgraded mine but have not had a chance to burn anything yet. I figured they’d get it right after having to pull the previous firmware. I mean, what are the chances they’d release another screwed firmware after they had to pull one already?? I guess I’ll try to burn a 4x DVD+RW soon and test it out on my Sony stand alone. I may just go back to 1.04 as I had 0 problems with that firmware. My NEC drive is at work, so, I can’t even use that at the moment. What a pain!


#10

Originally posted by dolmar
[B]this firmware does not work either. Now +rw burned at 4X are not readable in anything. I reburned the same imaged on nec with same media and it worked fine.

Guess i am going back to 1.04 [/B]

Works fine for me on my TDK 840G. Recorded 700MB data to Memorex 4X +RW using Nero 6.3.0.3 and it reads back fine on my dvdrom. What media/software were you using? Was it video or data?


#11

Also copied a 20min home video DVD to the same Memorex 4X +RW and it plays back fine on my Sony set top player. I learned one thing though, my dvdrom can’t keep up with the burning as it kept going into burnproof(or whatever) every 2 seconds. Even through that it plays back with no problems. Not sure if it was due to having them on the same chain or because the dvdrom can’t read fast enough.


#12

I used a sony 4X dvd+rw dvd and it was unreadable in my computer and my dvd player. Also my nec would not read it but nero allowed me to to format disk only in my nec drive … not the plextor that wrote it.

After i re-flash down to 1.04 same image burned with nero worked fine on same media.


#13

Originally posted by dolmar
[B]I used a sony 4X dvd+rw dvd and it was unreadable in my computer and my dvd player. Also my nec would not read it but nero allowed me to to format disk only in my nec drive … not the plextor that wrote it.

After i re-flash down to 1.04 same image burned with nero worked fine on same media. [/B]

i can’t see any problem with firmware 1.06 yet.
burnt 4 DVD+R 2 at 8X and 2 at 4X.both played perfectly in my PS2.
i also burnt a Memorex 2.4X DVD+RW (CMC MAG) and my DVD reader could perfectly read it.
it looks like this new firmware is having problems with sony DVD+RW media…


#14

NoLimit, were you able to burn at 8x on 4x media with version 1.04 & did that media work on your ps2???


#15

Originally posted by jaydee123
NoLimit, were you able do burn at 8x on 4x media with 1.04 & did that work ok in your ps2.

those dvd+r’s i tried were TY’s (Plextor DVD+R) and as far as i remember i burnt a disc or two at 8X with 1.04 and they worked in the PS2.


#16

I got some the plextor branded media and it was richojpn and they work in ps2 but the movie will get pixilation durning playback at random. I burned 1 game at 8X too and game loaded but freezes at random too. I riped the dvdr on my computer re-burned it back at 4X and the game worked 100%.

But i know there are like 10 versions of the ps2 and i know orginal ps2 did not read +r media at all and some of the newers ones do a good job reading most media.

I got a v7 ps2 btw so not sure if the newer V8-10 do a better job reading +r media or not.


#17

1.06 firmware appears to be rocking!
I had some troubles with CD-R/RW disc performance, and
since upgrade they seem to be gone. Now my 708A can write and read Memorex (Infodisc) CD-RW media just fine, which it refused to do with older firmwares.
Furthermore, it does not take up to 2 minutes to write lead-out anymore (Nero 6.3.0.3), just few seconds like it sould be.

I hadnt any probs with DVDs with older firmwares, so hope 1.06
isnt introducing any :slight_smile:


#18

I installed 1.06 and burned 3 CD-Rs (Ritek) from .iso images plus a single coaster using Plextools Pro, but the coaster was created due to my own stupidity.

The burned CD-Rs work just fine in other drives.


#19

CD’s don’t appear to be the issue. It’s burning DVD+R’s at 8x that’s the problem. I haven’t needed to burn anything to DVD+R since I upgraded so I’ve not had a chance to try it yet. I did a DVD+RW at 4x a little while ago and will be checking that out shortly on my Sony stand alone. Hopefully I won’t have to go back to 1.04…


#20

Here is one other interesting observation I made about the 1.06 firmware for the PX-708A.

With 1.04, there would always be one ‘unreadable’ block at the end of any burned data CD according to Nero CDSpeed 2.11. This never affected the readability of the disc, and there were never any problems copying any files from it. (And yes, I did test with numerous CD drives. And it never happened with burned DVDs.)

But with 1.06, there is no longer an unreadable block at the end of the disc. Yay!

I don’t know if this means anything important, but I just thought I’d mention it. :stuck_out_tongue: