Plextor PX-708A firmware 1.05 released

Released by Plextor Japan.

[quote]Plextor PX-708A firmware 1.05:

[ul][li]DVD record efficiency improvement of media
[/li][li]The high-speed record efficiency improvement of CD-R
[/li][li]New DVD-R correspondence of media
[/li][li]New DVD-RW correspondence of media[/ul][/quote
[/li]
Thanks, Count!

Update: Plextor Japan has pulled this firmware version from their website because there were some problems with it. More information here.

  1. is this firmware released by plex japan be the same release from plex europe or america?

  2. how come plex japan released fw1.05 before plex europe or america?

wait a sec, is it because plextor is a japanese company and in the japanese tradition, the japs gets the technology first…

Kool, every morning i visit the plex usa site for firmware updates, this morning same ole 1.04, been waiting for this…

Well i guess plextor is not going to add -r burning at 8X i guess that is not so bad either cause they still can not get 8X +r burns to work correcly on 4X media.

I updated my plextor drive to 1.05 and use richojpn to burn a movie this morning and guess what? It still not will not play on my xbox and it skips on both my samsung and sony standalone dvd players. I guess plextor thinks we want faster burns that are not as compatible and will only play in a select few dvd players. When is plextor going to figure out that either this media needs to burned at 6X like all other dvd burner are burning it at and add a way to burn 6X to there drive or just do what sony did and only write to the media at the rated speed.

I have no idea if i used real 8X media if the xbox or my other 2 standalone dvd players would play the burns fine.

Have ABSOLUTELY NO PROBLEMS with x4 Verbatim DVD+R DataLifePlus burned on x8 with 1.04 - burns perfect , runs perfect , haven’t tried with 1.05 yet .

I’lld like a hack for TDK Plex, perhaps it will work like 1.04 did? Keep your eyes peeled. Might wait 8 weeks for TDK to update.
I guess thats not so bad.

Also never a problem yet, burning Ricoh discs at 8X.

Well then you are lucky. If you read on this forum there are lots other people having the extact same problem as i do. As you tell from my other posts it seems that very few standalone players can play the disks plextor burns(apex works) while most skip towards the end of the moive or can not read them at all.

I have verbatim too and i have seen the same results with them plus verbatium 4X takes just under 10 minutes to burn while the richojpn take just over 8 minutes to burn a full 4.5 dvd. Which means it really burning then at 6X cause on my nec 2500a it just under 10 minutes to burn a full 4.5 gigs on richojpn but thoses burns work in everything i put them into with out skipping or getting dirty disk errors on xboxs.

Not sure what player you have either. If you go on any of the xbox forums you will also see people complaining like crazy that burns off plextor at 8X to 4X media do not work at all in xbox and you get “dirty disk errors”.

Now all the burns that do not work on most standalone dvd player seems to work fine on my computer. So this leads me to believe the problem might be how standalone dvd player read the disk vs how a computer does. And how they are able to recover from alot of disk errors vs a computer.

Standalone players i have tried are as follow:
Samsung 931 - Skips in the last 1/3 of the disk
Sony ns770 - Skips in the last 1/4 of the disk
Sony ns700 - starts to skip about 1/2 into disk but can not play the last 10% of the disk at all.
Sony ps2 V7 - get massive pixilations all over the disk but does not skip tho.
Xbox any version - returns dirty disk error about 1/2 into disk.
Apex - Not sure the model it my friends but i give him all my test burns cause they play fine on his player

@dolmar

No Pioneer, Yamaha or Harman player i tried had Probs with Plex708 4x @ 8x discs. Bear in mind that especially Sony Players have really BAD transports and thus problems with low reflectivity .

Then why would same media burned at 4X on plextor work fine or at 6X on nec? Well maybe the problem is limited to cheaper dvd player too who knows it very strange. All the dvd players i have under 100 bucks except the samsung 931 with built in scaler and that is only a 200 dvd player. And as far as xbox same story is true plextor at 4X or nec 6X work fine but not at 8X

Thanks a lot

Perhaps I was premature in my praise of burning 4X at 8X with Ricoh discs. First, I don’t have an XBOX, or PS2. The dozen or so 4X +R Ricohs burned fine and played fine on my Panasonic A320.
That being said , this hardly makes me an authority on how well the Plex burns 4X at 8X. Since the Office Max Bargains with my BenQ drive, I’ve been ripping with my Plex and burning with my BenQ.

By the way the same TDK hack tecnique for the 1.04 update works here as well.

May be I am lucky but I execly have KiSS standalone DVD/MPEG4 player that played everything I burned on my Plex :slight_smile:

May be your drive is defective ? I heard that there was a pretty huge bunch of defective players sold that show same problems like yours - best indication - look on the disks you have problem with , defective players produced noticable nerrow “rings” on the media (bottom,writable surface) that looks just like some copy protection . Plextor replaces drives with this problem very fast :slight_smile:

Where these so called burners only defective at 8X? like i said i do not think the media is the problems cause when i burn it at 4X on the plextor it works fine and it also works fine with n nec at 6X. There was another thread on here where other people had the same problem i have.

If you goto xbox-scene.com under dvd authoring same thing with this media burned at 8X on plextor seems not work on xbox but the nec/liteon burns same media at 6X and it works fine.

What did everyone on the other forum get a defective drive?

I have a strong felling the problem is that richojpn media can not be burned at more than 6X with 100 compatiblity.

I have a ton of the richojpn media cause office max, staples and office depot have had it on sale alot. So u can get it between 30-40 cents per disk.

Dolmar buddy i feel your pain…same problems here also…i have 5 standalones in my home plus a xbox/ps2, bought alot of ricoh’s too…ricoh plex burned seems only to play correctly on my mintek 1600, i have 3 apex’s, ad703, ad1500,ad2600 except for the later it wont even play any disc’s burned properly with my plex, even burned a 2 gig IMAX film at 4x and wont play…just freezes on startup…mintek played it
We both can admit it that plex sucks and i’m so glad i bought my NEC for $100…i tried to take the plex back to bestbuy but was past the 30 day limit…e-bay is looking like a good idea.

Originally posted by dolmar
[B]Where these so called burners only defective at 8X? like i said i do not think the media is the problems cause when i burn it at 4X on the plextor it works fine and it also works fine with n nec at 6X. There was another thread on here where other people had the same problem i have.

If you goto xbox-scene.com under dvd authoring same thing with this media burned at 8X on plextor seems not work on xbox but the nec/liteon burns same media at 6X and it works fine.

What did everyone on the other forum get a defective drive?

I have a strong felling the problem is that richojpn media can not be burned at more than 6X with 100 compatiblity.

I have a ton of the richojpn media cause office max, staples and office depot have had it on sale alot. So u can get it between 30-40 cents per disk. [/B]

why don’t you try burning at 6X with the plex?
use DVD Decrypter and force the writer to write at 6X (on 8X capable media of course)
im not really 100% sure it works and i don’t have many dvd players to test on.
let us know

Let’s see…d/l new firmware…install [nice “Plextor” logo, so this is safe]…OK, restart like it sez and…desktop icons which were hidden have suddenly reappeared…try to logon to cdfreaks and no connection…can’t access anything on 'net…shut down machine, reboot and try agin…no joy there…play LOMAC for an hour…try to logon to 'net again…finally I’m at cdfreaks but it wants me to logon…try other some other forums and it seems that all of my “automatic” logon cookies are gone.

Anybody having any issues with this firmware?

If you use DVD Decrypter and force it to 6X it will start to write the disk at 6X when it normally shifts into 8X it will down shit to 4X. This has been tried before by many.

Oh well like i said no -r 8X support and still no working 8X support onto 4X richojpn media.

Originally posted by dolmar
Well i guess plextor is not going to add -r burning at 8X i guess that is not so bad either cause they still can not get 8X +r burns to work correcly on 4X media.

i have no problems burning TDK 4x DVD+R at 8x, havent had any playback problems either. using firmware 1.04

What player are you playing back the dvds on? It seems some people are having the same problem i have while other say it works fine. I want to make this very clear the burns will play back fine on my computer and on 1 friends apex just not on my 3 standalone dvd players nor on my xbox or ps2.

And on the xbox forums everyone else seems to be having the same problem so i think it got to have something to do with how certain players read these disk. It kinda of like cdr if u burn 52X cdr some cd players seem to have problems reading them while order cd players do not. Might have something to do with lasers some company put in the standalone players and how well they deal with errors on the disk. Who knows maybe it time to make a list of know players that can read the 8X burns form the plextor.

Btw i call and spoke to tech support who said they never had a batch of dvdr ship. And they had no idea what i was talking about but said if i want to mail back my plextor drive they could test it.

Personally cause it seems lots of people with xbox has the same problem on richojpn media that the problem has something to do with how plextor writes to this media.

Thanks a lot.

May be there are many different discs with RICOHJPN out there. When TDK burn fine at 8x and cheapo Ricohs come out as crap I think B grade quality is the cause.
With my genuine Ricohs i never had a single problem but they cost me 1,50€.

dolmar wrote:

I updated my plextor drive to 1.05 and use richojpn to burn a movie this morning and guess what? It still not will not play on my xbox and it skips on both my samsung and sony standalone dvd players. I guess plextor thinks we want faster burns that are not as compatible and will only play in a select few dvd players.

How are you backing up a movie? There are so many variables in authoring and burning dvds. I’m assuming you burned it at 8x speed. Does it skip and not playback correctly when you burn @ 4x speed? I understand wanting to use the 8x speed capability since that’s the reason we all purchased this drive. Have you ever tried burning with IMG TOOL BURN?