Plextor PX-504UF not recognize DVD-R

vbimport

#1

My new PX-504UF drive does not recongnize DVD-R media, even the mitsubishi DVD-R that came with the package. It always shows 0 bytes total size in windows explorer under its driver letter. My Easy CD&DVD creator 6 also doesn’t detect any DVD media.

If I put in a CD-R, it is able to recognize it by telling me the CD-R media’s total size on window explorer, and is able to burn.

Does anyone know why it doesn’t recognize DVD-R but CD-R? Thanks in advance.


#2

The Plextor PX-504A and PX-504UF are DVD+R burner only! They cannot burn DVD-R media. The later Plextor drives (PX-708A and PX-712A) can burn both formats. Are you sure you got a DVD-R disc with your PX-504UF drive??

Welcome to the forums!


#3

Looks like you beat me to it, was just going to say…


#4

Sorry about that :wink: :stuck_out_tongue:


#5

Thank you all for the reply.

I made a mistake on the original message. The mitsubishi media I put in (which came with the package) is DVD+R.

I actually have two problem:

  1. If I don’t disable my built-in toshiba CDRW writer, the PX-504UF drive is not accesible.

  2. After I disable my CDRW driver, I have the problem in my original message. PX-504UF can see CD-R media, but the DVD+R I put in shows 0 byte in total size and free space in Windows explorer, and Easy CD also can’t find any media in it.

Thanks again for helping.


#6

Hehe~
Comparatively interesting.:slight_smile:


#7

Could you please give us some more information on your system akeww? We need info like Operating System, installed software, hardware, etc. Have you tried using different software? Please report back.


#8

It’s on Windows XP Pro on a 2.8GHz compaq n800w notebook. I have easy CD creator 6, and also a toshiba CDRW. The 504UF is connected via usb2.

I only tried easy CD, but I doubt it’s the software since Window explorer is not even showing the size of the DVD+R media. I also tried with some other DVD+R I brought rather than the mitsubishi one, same result.


#9

When you say that Windows cannot detect the size of the DVDR disc, are you talking about blank discs or written discs? Blank discs will always be detected as having 0 bytes available. Have you disabled the IMAPI write engine in Windows XP? It could be interfering with your other burn software.

Judging from your post I assume when you turn on the Plextor drive it is detected by Windows? Can you use the drive to read CDs/DVDs with? If it does work all right when reading media then there could be a problem with Easy CD/DVD Creator. I’m not very fond of this software and prefer Nero 6 but I don’t want to force to install something you don’t want. It will however help you to pin down the problem. Please report back.


#10

I tried Nero also, but with same result. Now I can’t even remember how I get the first issue solved. Even I disabled the other CDRW writer, and reboot, the 504UF is telling me the drive is not accessible. I can’t even get it to recognize any media now.

Sorry for being a quiter, but I think I will just return it to the store.

Thanks for helping, you guys are just great! :iagree: