Plextor PX-504A firmware 1.02 released

vbimport

#1

Added:
-Support for newer DVD media.
Direct download.


#2

Thanks G@M3FR3@K!

I was begining to wonder if Plextor was keeping up
with this model.

I love mine!:bow:


#3

No problem cstring :bigsmile:

I have this drive too although I don’t use it very often. I tend to use the PX-708A because I burn DVD-R mostly :wink:


#4

I was pondering the idea of getting a 708a but I will wait untill
untill I get a new pc together, perhaps an athlon 64 system or
maybe a new intel?

I got my 504a @ newegg when they 1st got them in.
I could’ve saved $50 if I’d have waited a few weeks
but you’ll never hear me complain.:cool:

I have burned everything with this drive and the only fault I’ve found, w/1.01 firmware, Fuji discs wouldnt make subdirectories.
Havent tried it with 1.02, but I probably wont buy fuji again.
I mostly use verbatium +R/RW.


#5

I upgraded to firmware 1.02 on my 504 intern, and now i am unable to read the data dvd-roms written on Datawrite 2,4x media. dvd-video on Datawrite media is still ok. Other media like tdk and verbatim seems to be fine.

I Tried to downgrade to 1.01 again, but i got an error message and then the drive showed up like a nec (in the firmware upgrad program), so then i upgraded to 1.02 again.

It seems that i can successfully write data to Datawrite media, but not read it again with the plextor under windows 2000.

It kinda sucks because i have burned more that 200 disks of that brand and have 100 more on a spindle…

Does anyone have any suggestions on how to downgrade to 1.01 or getting it to work otherwise?

Regards, Amundn


#6

I think downgrading to a lower firmware version should work just fine. I don’t know why your drive shows up as a NEC but it’s not alarming since the Plextor PX-504A is the same drive as the NEC ND-1100A. What was the error message you received?


#7

Unfortunately I don’t remember the exact error message I got first time I tried to downgrade the firmware, but the good news is that when I tried it again today, it worked flawlessly, and now I can read my Datawrite dvds again! :smiley:

Thanks G@M3FR3@K for the tip that downgrading should work just fine. When it comes to firmware i’m a little too familiar with the creative nomad jukebox’s firmware that refuses to downgrade.


#8

Here is a link to the Media i used that don’t seem to be working well with plextor PX-504A firmware 1.02:
datawrite.co.uk

Plextools show Manufacturer ID = RICOHJPN and Media ID = R00 if that is of any help to anyone.


#9

Good to hear downgrading worked. If you want you can try contacting Plextor and inform them about this issue. Perhaps they can fix it in firmware 1.03 when it’s released. A newer firmware is generally always prefered since it has the best media compatibility… well in theory that is :wink: