Plextor Premium and Windows 7

vbimport

#1

I have a Plextor Premium USB model designed for XP. When I attempt to use it with 7 home premium 64, the driver fails to install. The unit shows up as USB mass storage device. I know that 7 Pro has an XP emulation mode (virtual I assume) Do you think downloading that would help? I am at a loss here as I assumed that 7 was backwards compatible with all USB 2.0 devices. Any help would be appreciated as I really want to use this drive as it is one of the best ever made for CD burning. Thanks Dr. John Dozier


#2

Hi and welcome to the forum :slight_smile:

Can you try to connect the drive to a different computer? Just to be sure that the IDE --> USB bridge of the burner is working correctly.

Did you try to connect the drive to a different USB port? Or to an USB hub?

Try to use this free tool. Run it [I]without[/I] the premium drive, uninstall the premium USB driver, then connect again the burner: let’s see if this time windows is able to install correctly everything :slight_smile:


#3

It will be later in the week before I can do as you suggest. My old laptop runs Vista so do know if that will help. We will see. Thanks for the help.


#4

You’re welcome :slight_smile:


#5

Still shows up as not connected on the software you suggested. On the computer it shows as mass storage device but with error 10 warning. Any ideas? Thanks


#6

Did you try to uninstall the driver with that program?

Can you check in Windows device manager if there are any yellow marks somewhere? Maybe you need to update mainboard’s chipset drivers.


#7

The computer is a brand new Asus G73 with sandy bridge. Nothing seems to work driver will still not install. Knew I should have bought a Mac.


#8

The first release of Sandy Bridge maniboards had a hardware bug but all affected boards should be removed from the market. For what I know, this bug was completely solved with the new releases. I wonder if you got a defective board.

Maybe your plextor drive has some compatibility issues with the USB3 ports. Be sure to connect the drive to an USB2 slot.


#9

Mine has the new board and I am using USB 2. I am also highly frustrated. There is just a basic incompability. A friend in Charleston has an XP computer. I will send the unit to him and see if it works. Thanks for the the help though


#10

BTW I also check all drivers in Device manager. All are up to date.


#11

At the moment I can’t find any idea to solve this problem :o


#12

Just as a thought, why not boot up a linux CD and see if it finds the drive?


#13

I do not have a linux cd, but driver failed to install on a Vista computer


#14

You can find a lot of LiveCD available totally free :slight_smile:

Take a look here for a more complete list :slight_smile: