Plextor firmware

vbimport

#1

Hi, I have a Plextor 1210a. Like I always do, I flashed the firmware with the latest and greatest. To my suprise I find that I can not copy some cd's now and find that since firmware revision 1.04 they have no longer will copy (at regular speeds) some disks.

I want to flash with a previous version but it will not let me (go backwards) using the Plextor flash files.

I found the utility to flash with .bin files but I can only find version 1.05. I NEED version 1.04 and they (Plextor) has removed the 1.04 and earlyer .bin files from thier web site. Where can (I have searched all over) get this file in a .bin format rather than a .exe ?

PLEASE HELP!


#2

Download from my SafeDisc 2 list: www.sd2.does.it (scroll down to Plextor section and click on the link next to PX-W1210A). I would have used a direct download but that doesn’t work from GeoCities. It’s a ZIP-file containing the 1.04 fw and the flash-util.


#3

Got the file, tried it, will not let me do it, says “Upgrade failed : Sence 70 00 00 00”

Seems I can not go back past 1.05

The TLA# is 0307
Any other ideas?


#4

Originally posted by Kicker|MyU
[B]Got the file, tried it, will not let me do it, says “Upgrade failed : Sence 70 00 00 00”

Seems I can not go back past 1.05

The TLA# is 0307
Any other ideas? [/B]
Nope you simply can’t downgrade. I had the same problem here with TLA#0305. Back in the days when there were rumours that SafeDisc 2 worked with fw 1.4 I wanted to try it but like I said you can’t downgrade with TLA#03xx… Sorry :frowning: