Plextor Firmware 1.04 problem!

vbimport

#1

Hi
Please Help!!!
It’s 2 days now that i am trying to update my plextor’s (241040A)
firmware but the message i get is “ASPI manager not Found”
I have already installed the adaptec ASPI driver for windows XP
v.4.70.1.I have tried both modes to update the firmware self extracting file and binary file with PXupdate from dos but nothing worked the message is always the same. :frowning:
Thanks for your help!!!


#2

Have you run ASPICHK.EXE (free from Adaptec) to see if it installed properly?

You might also try Force-Aspi (comes with Nero, or free download from Ahead), or an earlier Adaptec version.

All I can think of from the info you supply.


#3

I have already tried all the things you said but the message remains always the same!!!:frowning:
Thanks for your replay


#4

Are you running the original XP or the SP1 update?

My system (XP SP1) indicates it’s running the following drivers:
Existing drivers:
“File ‘Drivers\ASPI32.SYS’: Ver=4.71 (0002) built by: WinDDK, size=16512 bytes, created 17/07/2002 10:05:10 AM
File ‘Drivers\atapi.sys’: Ver=5.1.2600.1106 (xpsp1.020828-1920), size=86912 bytes, created 28/08/2002 8:27:50 AM (Adapter driver for rec”
and I have no trouble with firmware updates (recent include 1.05 to 1.06 on Plextor 12/10/32S SCSI CD burner and 1.0b to 1.0c on Sony DRU-510a DVD burner.)

This would be the ASPI layer installed by the XP installer so far as I know.


#5

This are the results from PXinfo:

Operating system : Windows XP V5.01.2600 Service Pack 1
Windows ASPI (wnaspi32.dll) : Adaptec ASPI for Win32 DLL, V4.71 (0002) ( not used by PlexTools )
Roxio ASPI (cdral.dll) : n/a
Ahead ASPI (wnaspi32.dll) : Win32 Nero Aspi Library V2.0.1.59 ( not used by PlexTools )

As you can see the ASPI layer is the same version as yours
but the problem still remains!!

Thanks to all for your replays!!!


#6

It looks to me like your system just has too many choices and confusion is creeping in somewhere.

You might try temporarily uninstalling any Roxio software you’re using, also Plextools.

Alternatively, if you have access to another PC, try moving the device to it, update the firmware and swap it back again.

Or, possibly, just start Windows XP in safe mode and see if the update works then.

It might also work from the command prompt (Win-key/r and type in cmd/enter)

Personally, I’ve always had a preference for updating firmware (another name for BIOS) from DOS, but many mfrs are now making this difficult or impossible.