Plextor compatability issues

Hi all; This is my first post here.

I have a new system I just built about 2 months ago.

MOBO - ASUS P5B-Deluxe
RAM - 2gb OCZ dual channel ( second edition )
Sound - SoundBlaster X-Fi Extreme Music
HDD - Seagate 320 gb SATA
Optical - Plextor PX-716 SA/SW ( SATA )
500 watt MIOS power supply
Video - BFG GeForce 7600 GT OC PCIe 256 mb RAM
Generic internal memory card reader ( USB )
OS - Windows XP Pro

When I first booted up and installed Win XP it seemed to work OK. Within a month I started to get lots of errors ie: missing files, dll etc etc.

I decided to wipe everything out, re-format and re-install XP. I got lot of errors during the install saying that several files were missing and disc wouldnt read certain files ( re trying didnt help. ) I tried several re-formats and reinstalls with no sucess.

I did the self diagnosis routine with the Plextor 716 and it failed the test, saying it had read / write errors.

I then tried a different Plextor DVD drive, the PX-755 SA but had the same results / errors that I had with the PX-716 SA drive.

I took my computer to Canada Computers in Hamilton, Ont where I bought my components. They swapped out everything. They even tried a different XP installation disc. Still read errors.

They tried several SATA DVD drives and it allowed them to load Windows without errors. They even tried an IDE DVD drive with success.

I’ve contacted Plextor by phone and emails. All they tell me is to contact my MOBO vendor. I aske the ppl at Plextor if there were compatability issues with the Plextor SATA optical drives and the ICH8R chipset that was on my ASUS P5B-Deluxe, they told me that they weren’t aware of any issues???

Does anyone here have any ideas whats going on her or have had any of these problems?

Thanks :slight_smile:

Plextor Sata drives, and compatibility issues with some motherboards have been discussed on this site in great detail. Please use the search function, and you should find more information than you need to help you resolve your issue. I seem to remember something about some motherboards just not working with sata optical drives.

Thank for the reply harley2ride :slight_smile:

I realize that the Plextor SATA drive compatability issue had been discussed in detail on this forum as I had read many of them before deciding to post. As most of the posts were all a few months old I assumed that by now Plextor had resolved these issues. I also couldn’t find a post having to do with my MOBO specifically ( ASUS P5B Deluxe ) I did post a message on the ASUS site but no response from them yet.

I find it kinda weird that Plextor still has compatability issues with their optical SATA drives when you consider that they were one of the first people to bring these drives to market:( Calls to Plextor have been no help whatsoever. And to have 2 drives, both not working with my MOBO is to much!! The PX-716 SA/SW is one of their first and no longer available, but I got a newer PX-755 SA 2 weeks ago, and it won’t function properly either. Go figure!!! Talk about BAD luck LOL!!

I pick my computer up today with an LG H62N SATA drive installed that they tell me works OK. If I get a refund for the two Plextor drives I will be happy…

audio1

Hi [B]audio1[/B], welcome to the forum. To take full advantage of SATA2 hard drives (e.g. NCQ - Native Command Queuing) you must enable AHCI (Advanced Host Controller Interface) in the computer’s BIOS. This doesn’t sit well with SATA optical drives however, which prefer legacy/IDE mode. It’s a choice you must make. You could also try connecting the burner to the JMicron SATA port on your mobo. I have used Plextor SATA drives on various chipsets without AHCI and they all worked fine.

Thanks Cressida;

I don’t have my computer here at the moment to check the BIOS, but if I remember correctly it was set to IDE mode by default. ACHI wasnt enabled. On my first boot when it was new I went through the BIOS to make sure that all settings were as recomended in the ASUS manual. Hmmmmmmm?? Maybe you are on to something :slight_smile:

Their is one JMicron SATA port on my MOBO. I didn’t use it or load the JMB363 drivers because it is for if you are going RAID, and I’m not … sooooooo I assumed. So you are saying that I can plug my Plextor drive into this port??

Thanks for the post, it was the most interresting / informative yet :slight_smile:

I will mention it to the computer tech today when I pick my computer up and maybe try it tonite.

For now it’s 6:30 AM and I’m going to bed for a few Z Z Z Z’s!!!

thanks

I did go to Hamilton on Saturday with the intentions of picking my computer up and also purchasing the LG H62N burner. Although the ppl at Canada Computers there did give me a refund on my Plextor 755-SA.

But after showing them you post ( above ) they asked me if they could keep my computer another week so they could try connecting the Plextor to the JMicron port on my MOBO etc etc. On of the techs there was mentioning that he thought that the MOBO might be defective, that there might be a problem with the SATA controller chip. They don’t seem to be prepared to swap out the MOBO to eliminate it as a suspect. They said that I might have to send the MOBO in to ASUS for testing / repair and that it would take approx 4 to 6 weeks.

I just hope they get to the problem soon as I’ve spent almost $2K there in the past 6 months.

Stay tuned :confused: :slight_smile:

Keep in mind that the choice to use AHCI or not must be made before installing Windows.

Good luck in finding a solution to the problem.

I did take my computer to Canada Computer, they had it for almost 3 weeks. They semed to think that there might be a problem with the chipset on the MOBO. So I RMA’d the board to ASUS. They replaced it with a new one without telling me what the problem was, if there was one??

I re-installed the new MOBO and all components except this time I installed an LG 62N SATA DVD drive. I formatted and installed WinXP Pro with no problems … but guess what?? Within a week or so I was getting errors again!! I installed a Plextor again with the same errors. Hummmmmm!!

One nite while looking in Device Manager under IDE ATA / ATAPI controllers / secondary IDE channel / advanced settings, device 1 is set to " auto detection. The second box is set to DMA if available, but the current transfer mode seems to be stuck in PIO mode. I checked the BIOS and it is set to AUTO. I’ve tried resetting to DMA mode but to no avail.

Any suggestions? I would have thought that the Tech at Canada Computers would have check this…

audio1

Well, it’s obviously not a Plextor compatibility issue any longer :slight_smile: . I’d be more inclined to think you have a bad stick of RAM or a bad SATA cable in there that’s causing these errors. Switching the cables is easy enough and for the RAM you can run a diagnostic like Memtest86 (just google).

PIO mode is not good, uninstall that IDE Channel and reboot. Maybe you should install your mobo’s chipset drivers. Didn’t it come with a driver CD? The Intel Matrix Storage Manager includes the SATA driver. And is AHCI switched off in the BIOS now? I suppose so or else you wouldn’t have been able to install XP without the driver. Some people claim their optical drives work with AHCI, but it’s certainly safer not to use it if in doubt.

My RAM was checked when Canada Computers had it and it was OK. The SATA cables were the first thing that I swapped out and they were OK also.

Yes, the ACHI is disabled in the BIOS. The drivers you are talking about are for RAID. They are the drivers that have to be loaded during the installation of XP, and NOT after ( you know, the F6 thing ) You can install XP without loading these drivers. They are only needed if you are going to use a RAID configuration, and of course I’m not.My My Seagate 320 Gb SATA HDD is running in the Ultra DMA mode 5 with no problems and stays there.

Once I knew what the problem was I Googled " stuck in PIO mode " and came up with lots of info on this issue. Some of the postings I have read are as old as 2002. It seems that its an issue with XP and there has never been a patch for it in all this time ( not sure when SP2 came out )!!

Apparently whats happening is, and this is normal for optical drives, is that if you have a disc in the drive that is difficult to read for whatever reason, it will downgrade the data transfer rate from lets say mode 5 to 3 then 4 etc. If it reads 6 or more errors in a row it will go into PIO mode . Once its reading OK it should return to DMA mode automatically as long as you have selected " DMA if available " in the properties menu for the IDE controllers in Device Manager. But its sticking there. Apparently this is a glitch with XP. Rebooting dosen’t help at all.

I’m going to try the un-install the drive as you mentioned, then re-installing to see if windows will put it back on DMA mode. Apparently doing this works sometimes, but not always. But it will eventually go back into the " stuck in PIO mode " :frowning:

According to what I have been reading a perminent fix is to go into the registry and do some editing which I’ve never done before and am not too comfortable doing so. I’m presently looking for someone who knows how to do it.

Here are a couple of Microsoft links that I have been reading about this issue:

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx

I must say that this has been the most frustrating experience I’ve hade to date with a computer LOL!!!

audio1

I was just reading one of the Microsoft pages again and it says that this issue was fixed in SP2, but on the same page it states that you have to edit the registry. Thats confusing to me. If it was fixed then the registry should have fixed itself, wouldn’t you think? :iagree:

audio1 :confused:

Sorry, I’ve never had to use a registry mod to fix this kind of problem. Most of the information that you will find on this “stuck in PIO mode” issue applies to PATA (IDE) ribbon cable connections. I’ve never even seen it mentioned in relation with SATA connections.

What happens if you try to run the Intel Matrix Storage Manager installer (after having installed the Intel INF Update Utility of course)? Does it say no compatible hardware found or similar?

Sorry for taking so long in responding to your last post cressida, been working lots of overtime :frowning:

Well I did as you suggested and uninstalled the secondary IDE channnel in Device Manager. I had to do it twice but it finally reinstalled and is now in Ultra DMA-5 mode. But i was surprized when I put a CD in the drive because it is still not working properly. An audio CD will play somewhat, it loads very slowly then part way through a song it will quit, the LED on the drive will blink on and off for awhile, then it will spin up and play a bit then repeat the process all over again. Eventually the computer will lock up completely and nothing will get it out of lockup except to push the reset. When it reboots and I open the Windows Media Player I get a prompt that the player was not shut down properly and it has disabled the codecs. I restart again and the Media Player is OK.

I just tried to access the installation CD that came with my motherboard and the LED just keeps blinking forever. I kept it in the drive for as long as 15 mins and it just keeps blinking and the drive won’t spin up at all. I wanted to look on the CD to see if the Intel INF Update Utility was on there as I don’t recall seeing it during my initial installation.

I looked in the manual for my MOBO and it states that the Matrix Storage Manager installer is to be installed with all the drivers needed during installation of XP ( F6 ) if you are installing a RAID system. I decided I didn’t need to do this at the time because I wasn’t going to use a RAID array, but maybe I need this stuff installed anyway, but from what I read it dosen’t seem so. I don’t want to do it now unless I’m absolutely sure I need it because it means that I have to re-format and reinstall XP all over again :frowning:

I did look on the ASUS website to see if there was a BIOS update for my MOBO and there are newer ones but none mention that it will solve the issue I’m having. My BIOS is v 0614 BTW.

I’m not sure where to go next to solve this issue??

Even though the DVD drive isn’t reading properly and produces errors from time to time it still remains in the Ultra DMA-5 mode and dosen’t revert to PIO mode. At least I’m one step closer LOL!!

Thanks for your help so far cressida :slight_smile: