Plextor 716UF & iTunes not getting along

I’m new to the forum - actually, Plextor’s helpline referred me to the site. It is a bit overwhelming (maybe others felt this intially as well?). Anyway, I hope someone can help with this issue:
I’ve hooked up the 716UF & it’s working properly thru PlexTools. It appears to work in iTunes, b/c when I insert an audio CD, iTunes recognizes it (it shows up, gracenote adds the info, etc). But when I click “import”, it seems to finish the burn in about 1 sec, plays the “all done” chime - but no files are added in the iTunes library. If you find the iTunes Music file (via the explorer), it shows the songs as mp3s, but they are essentially hollow files - they will not play even if you dbl-click on the file name.
Why does iTunes recognize the drive, pull up the CD info w/o a hitch, but not import? More confusing is why it thinks it really is importing?
I’ve updated the firmware, checked the PlexTools options ad nauseum, found little help from iTunes/Plextor help & Plextor tells me it’s not a drive issue (and they’re probably right). I’m at a real loss and I’d really appreciate a fellow Plextor owner’s help. Thanks.

Welcome to CDFreaks fakeplasticbuzz (is that a play on a Radiohead song?)

According to this site,

it sounds like you are performing the correct procedure. Now, I’ve read somewhere that iTunes has complete control over how it arranges the files and folders under Windoze and what you see under Explorer may not, in fact, be the real file location. According to the site above, you can verify this by Edit|Preferences|Advanced tab.

There may also be some other aspect in the iTunes configuration that’s preventing conversion/storage. Again, look under Edit|Preferences|Import tab to verify that you are encoding the files properly.

Sorry I can’t help more, but it certainly sounds more like an iTunes issue rather than a drive issue because the drive is clearly working and supplying enough disc Table of Contents information for Gracenote CDDB to find the album.

If you can insert an audio CD, double-click on the track number in Explorer, and hear the music playing (through Winamp or MS Cdplayer), then it is definitely an iTunes issue.

Good luck, and if you find out anything further please let us know.

I have iTunes installed and also a PX-716UF. I will test track ripping tonight when I get home!

As promised I’ve tested it. I’ve loaded an audio CD into my PX-716A and iTunes recognized it. After loading the tracks I simply pressed the Import button (in the screenshot below it’s called Importeren since I have the Dutch version of iTunes). It worked without a problem… I am using iTunes version The second screenshot shows the tracks on my hard disk after ripping/converting them via iTunes/PX-716UF.

Ps. If you’re interested, I can highly recommend ml_ipod for use with Winamp 5 to manage your music files on your iPod. It’s a lot easier to use than iTunes.

First let me say thank you, ftp & GF, very much for your responses. I have iTunes 4.9 & I believe all the settings in the Preferences are in order. Prior to the 716UF, I used my PC’s installed CD-R drive to import. But I wanted to get the highest quality “read” I could get (i.e. the 716). So I know 2 things: a. iTunes will import from my current CD-R drive & b. the 716UF will burn mp3s through Plextools - both w/o errors.
I am not an Apple bandwagon guy, but I have an extensive CD collection & I’ve been looking for a database - downloaded several trials & even purchased 2 database programs - the best I had found to this point was OrangeCD available here: It’s decent, but doesn’t do what iTunes does - esp. searching w/in songs for info like “comments” (which I use in detail) etc. It’s the best db software for my specific purposes (not for all, I’m sure).
It kills me that GF’s works like a charm b/c I know it can work, but something’s amiss. Your screenshot shows a step my 716 will not reach - the actual importing & the grey graphbar showing progress - I don’t get that far, but again only with the 716.
So it is not solved yet, but in the process I did learn a great trick which I’ll post separately.

This “trick” may be nothing new to many, but it was to me:
Using PlexTools to improve audio quality over iTunes - but keep iTunes info:
You import a CD into iTunes, it defaults to the iTunes codec. I ripped the same CD using PlexTools & LAME (made possible after importing the LAME dll file into PlexTools - see manual). I did some blind A/B’s & found in EVERY instance, I found the LAME mp3 to be superior to the iTunes mp3.
How to get them there? As with other audio files, you can dbl-click on the file & it will begin playing in iTunes - the PlexTools-ripped mp3s will go directly to the iTunes library - side by side w/ iTunes mp3s. Now, if you go into Explorer & delete the audio file only for the iTunes mp3, then try to play the song - iTunes will ask the standard “No audio - Would you like to locate the file?”. This I knew (and you did too, no doubt).
But if, when you locate, you select the Plextools/LAME version of the song, iTunes will not only adopt the superior audio but RETAIN the text of the iTunes mp3 - including all notes & corrections you may have made. I thought for sure it would default to the PlexTools info, but it doesn’t. In fact, you can delete all the text from the PlexTools mp3 in the library (like Year, Composer, etc) prior to the “relocation” & it will magically reappear when you “locate” the missing audio file. [** One note, if you delete the artist, it will be harder to find, b/c the file leaves the Artist’s (Explorer) folder immediately.]
This may not seem like much to most, but I am a stickler for audio. It pains me to use any lossy format, but I must in order to gain the ability to use the database part of the program (won’t fit in AIFF/WAV). Every little improvement helps. I’m ripping at 320 kbps & LAME’s 320’s are clearly superior to iTunes’.
PlexTools DAE & iTunes 'Info" were not a perfect match - you had to manually enter some info that would be there already if you used iTunes (like track #, etc). Using this method, you can easily upgrade the iTunes file’s sound quality w/o re-typing a thing. I imagine this would work for anyone’s favorite codec.
(My apologies to all who just thought "No sh*t, Sherlock - but it was news to me).


I seem to be having similar problems with iTunes recognising audio CD’s when I inser them. If I eject the CD and re-enter 2 or three times, iTunes will recognise the CD, but it hardly ever happens on the first time.

Have you solved your problem, and if yes, perhaps the advise will also sole my issues.



My problem is still unsolved. iTunes will recognize the CD from the 716 & pull up the CD info via Gracenote. Once you click “import”, the problems begin. It would be easier to understand if PlexTools did not import mp3s.

Question: does anyone know how to enable the DMA (direct memory access) for the P716UF? Mine is greyed-out. But PlexTools tells me DMA is enabled on my PC’s 2 existing drives. As far as I can tell, the other settings are the same. Would anyone know A) how to enable DMA and B) if this would make a difference?

UF is external, there is no DMA. you either run of the usb2 host or firewire (if avail)…

What about a cd that had protected audio?? Some of you seem to be from Europe, and I hear protected CD audio discs are common. Could iTunes be disallowing due to DRM?

Thanks, Dr. Pino. That would explain why I can’t select the DMA option.

As far as protected audio, I don’t know. The Dell drive imports w/o a hitch.

I’m not from Europe though, I’m from Texas.

no prob :smiley:

i never thought you were european :disagree:

Problem Solved! : (obligatory smiley here)
And after solving it, I felt pretty silly - so I post the solution w/ humility but hope it can help another user.
In iTunes “preferences”, under the “import” tab, I deselected the “Use error correction” check box. Now works like a charm.
I found this after :uninstalling/reinstalling iTunes 4.9 (Windows), then running the CD Diagnostics (under Help) - everything looked in order. Then I checked the iTunes help & saw a link I had not seen before, found here: It explains it pretty clearly. I thought I had searched their help inside & out, but somehow I missed this link, under the “troubleshooting” headings on a separate page.
If a more knowledgeable patron could explain why disabling error correction allows the Plextor to work or why enabling it does not allow the Plextor to work, I would love to hear it. But as suspected by many, it was not a fault of the Plextor 716UF.

“How could I stay mad at you?”

Much thanks to all who contributed their help. If I knew all of your addresses, I would burn you a copy of my favorite songs, but that would be illegal. Seriously, thanks. Hope I can return the favor sometime.

p.s. I don’t know if this will help those whose iTunes is having trouble recognizing their CD’s, but it’s worth a try.

glad you sorted it out :iagree:

I wouldn’t say this problem is sorted out mate. And Fakeplasticbuzz I certainly wouldn’t feel silly as you put it.

I have exactly the same problem. I have always used iTunes with the “Use error correction” check box ‘checked’ and everything worked fine until I upgraded to iTunes 4.9.
I have tried it with this box unchecked still no joy and I have even upgraded my CD Drives firmware and still no joy.
It’s a right pain in the @rse which no one, not even apple can give a definte solution to.

I feel really p!ssed off as I have had my iPod for 2 years and have had no problems until upgrading to 4.9. It is now useless.

Can anyone help?



Maybe a stupid answer but can’t you just downgrade again or uninstall and re-install the older version?

Welcome to the forums Shanz :slight_smile:

or better yet, don’t use iTunes at all…use the iPod plugin for winamp…or ephpod or something…so many other options out there that are better than itunes…

I agree, I do that myself as well :iagree: I use WinAmp and the ml_ipod plugin. Works great for me.