Plextor 716SA...got it to detect...BUT

vbimport

#1

I finally got my Plexotor SATA drive to detect by switching it to my Promise Silicon controler on my Abit IC7-G motherboard…it detects in XP Pro but not in BIOS…very odd…and…i was able to rip and audio disc no problem…and copy stuff from the disc to a folder on my drive…but when it came to installing a game…BF2…i got all sorts of read errors…like can’t find this file and that file…why? why would everything else work fine but get errors w/ this dvd install? I tried the game at my work and it installed no problem…not one error or anything! So now i’m looking at the drive as the problem.

is this a known issue? my motherboard has the latest bios and i have the latest chipset drivers and was able to flash my 716SA to the latest bios. I’m so not happy.

help me out?

oh and the reason I switched over to the prmoise controler was becuase I couldn’t get the drive to detect in XP w/ the intel sata controler…it would detect in bios but not in XP and now w/ the silicon/promise controler…it has been reversed…yes to xp and now no detection in bios…

??? return it and just get the regular IDE version!?


#2

I would.

Unless it works right out of the box, and you have a pressing need for S-ATA (IDE connectors all used), the rule of the thumb has to be to go with the IDE version.


#3

I had the exact same problem with my 712SA, in the bios the IDE setting for the SATA the bios would not see the drive, Windows XP on the other hand would. If I put the SATA setting on RAID the bios would pick it up occasionally but not always, Windows XP then would not see the drive, not until I loaded the SATA drivers. Funny thing about the promise drivers, they have two different sets, one for the ide mode and one for raid. If I tried to load the promise RAID drivers I would blue screen even tho the bios was set at RAID, i then went to load the IDE drivers for the promise they loaded up just fine.
I called plextor and got an RMA, they were as perplexed as I am, they gave me a number and they have it now.


#4

I had a similar problem with my 130A (Plextor PATA DVD-ROM). Installing any application from any CD always resulted in a message like ‘Installation file corrupt. Installation aborted’. Though, w2k was able to install itself from that drive without any error.
Finally it was the faulty driver of the PATA interface of the NVIDIA nForce4 chipset of my ASUS A8N-SLI Deluxe motherboard. Installing a different PATA driver version from NVIDIA solved the problem.
In your situation I’d try to install some driver from the original SATA chip manufacturer (SiliconImage 3112 or 3114? - look at www.siliconimage.com). If this doesn’t work you should try a different drive (PATA).

What do you mean by ‘not detected by the BIOS’? Stupid question: Have you ever entered the extra BIOS of your SATA controller by pressing ctrl+s or something? If your drive really doesn’t show up in this BIOS then your mb and drive obviously don’t like each other.
Have you disabled the onboard intel ICH5R SATA controller? Uninstall the ICH5R drivers with the windows device manager.


#5

If you can burn a disc but can’t install a game…can you install other games or read/play standard movies? Could be the game has some non standard copy protection and screws up the drive?? Drivers are obvious choices, but I’ve heard of some game vendors so over zealous in copy protection that the discs only work on a few ROMs and not DVDR.


#6

Hrm…

My abit IC7-G has 2 controlers…one is the Intel controler and the other is the Silicon controler…

I am NOT running any RAID at all. I have my Main HD (WD Raptor 74 gig) on SATA connection #1 using the Intel controler. I aslo have my WD 200 gig HD on IDE channel #1

for the plextor I’ve tried SATA #2 on the INTEL controler…like stated before…when on this controler…the Plextor drive detects in BIOS but NOT in XP.

Then…I switch my Plextor over to SATA #3 which is used by the Silicon controler. It NOW detects in XP but does NOT detect in Bios. odd…

so we have established this already…

Now…in XP Pro…under device manager…then under SCSI and RAID controlers I have the “Silicon 3112 drivers” installed. I see NO Intel ICH5 drivers anywhere at all…where are they? I’m guessing the only reason why the drive was detected in XP when I moved it over to the SATA #3 Silicon controler is becuase the drivers were installed. But where are my intel drivers?

I’ve searched through the whole bios (latest one for my motherboard is 28) and have found nothing that would cause these problems (that I think)

I have Raid Rom turned off
IDE is enabled
Auto is turned on for detection.
on board SATA is enabled (of course)

I’m confused though cuse my WD Raptor HD boots just fine! and its using the INTEL ICH5 controler…so why doesn’t my drive detect in XP?? is there some kind of conflict going on?

I’ve installed the latest 875P chipset drivers for my motherboard and all it does is find the Silicon 3112 controler and install the drivers. I try to force the ICH5 drivers but it states that “it contains no information for my HW” or sum crap from windows.

I have uninstalled all Intel Accelerator software. and am using the regular MS IDE controler drivers not the intel ones.

Everyone has been telling me its a driver issue w/ the Intel controler and thats why it doesn’t detect in XP. But damn… I can’t figure out how to get the drivers installed…maybe its cuse the plextor isn’t being detected thus i’m getting no prompt for drivers to be installed…i dunno.

I want this drive to work…soooo bad.

I also tested my BF2 DVD at my work today and it installed w/ out a hitch. no problems!

I’m really thinking driver issues here.

:a


#7

I have 2 IC7-G’s, both set up as RAID.
I am guessing / believe the reason you don’t see the ICH5R in the ‘SCSI and RAID controllers’ is that you did not enable the OnChip Serial ATA mode (Integrated Peripherals>OnChip IDE Device>OnChip Serial ATA=RAID), and set 'On Chip Serial ATA as ‘Enhanced’, along with the SATA RAID ROM. Unless this is enabled, the ICH5R drivers will not install from the floppy (the F6 thingy) and, therefore, the ICH5 acts as a ‘normal’ IDE controller using the native Windows drivers. (i.e. the ICH5R acts instead as an ICH5 (no RAID)).

The SilImg controller is the ‘on board’ controller and DOES require the 1 (or 2 drives for RAID) driver to be installed because you have the ‘on board controller’ enabled (not to be confused with the ICH5 ® ‘on chip’ controller). (Integrated Peripherals>On Board PCI Device>Serial ATA Device=enabled. To enable the SilImage RAID, you set Serial RAID ROM= enabled.

Depending on the controller, and how it is configured, drives may NOT show up in BIOS. As long as they are present in windows, that’s all that matters.

Serial optical drives have difficulties with certain controllers, and I believe the ICH5® is one of them.

Best Regards, hope this helps.


#8

Hrm… I haven’t tried what you have suggested… My pelt system failed on my cpu so I have to wait for my replacement to come in this week then I can test out the goods.

I always thought that the SATA controler has to be set to “IDE” and I always thought that becuase I AM NOT running a RAID system…that I need to turn RAID ROM off and set my controler to IDE and not any RAID…I hope I’m understanding this right thus far. So why does my silicon controler come up and how does my WD Raptor boot up when I was never prompted for drivers during XP install?? I mean the Raptor HD is fine and detects perfectly. I have no problem what so ever going to a format and reseting everything. I do need to get a floppy though heh.

Okay…

so what do i need to enable to get this damn drive working heh…

Do i need to format and start all over again? Do i need to use the Silicon or the ICH5r controler? Does my Raptor drive have to be on the same controler w/ the plextor?

and one more time…I’m not running a RAID configuration…yet I need to enable RAID in the bios??

uhg.

thanks so much for the help thus far…


#9

I may have caused some confusion by my long winded previous reply.

Your raptor is connnected to SATA1 (the ICH5 port) and boots fine, correct? That is because the ICH5 is operating as an IDE controller and uses the drivers that are part of WinXP (no need to install drivers from the floppy, because you did NOT set it up as RAID in mobo BIOS (see previous reply)). This is OK, no worry.

Your other HDD is an IDE drive connected to one of the IDE (40 connector) ports and works OK, right?

You hook your plex up to the SilImg controller (SATA port 3 or 4). Is it recognized by XP? can you read a DVD from it? can you burn to it? The reason it doesn’t show up in BIOS during post, is that it is hooked up to the SilImg controller and as long as XP sees it, that is OK.

You will not see the ICH5 under SCSI and RAID controlers is because you did not configure onchip SATA in mobo BIOS. It is operating as an IDE controller. No problemo.

No, the raptor does not have to be on the same controller as the Plex.
No, you shouldn’t have to enable RAID in mobo bios for your setup.

Best Regards. Let me know if everything is cool so far.


#10

BTW since your mobo has two IDE ports, if I could, I’d exchange the 716SA for the IDE version. The SA version has known compatibility issues with some SATA controllers.

Best REgards


#11

Yea. You were right on all that lats post. I am using the SATA ICH5 as just regular IDE.

If I want to…I can go back and reformat my WD HD (it has my OS) and reinstall xp pro and then install the ICH5r drivers and setup as RAID…

EVEN THOUGH I"M NOT USING A RAID SETUP?

i’m so confused about that. I always thought that If I wanted to to use RAID I had to have 2 HDs… but it sounds like If I simply just want to enable the ICH5r controler I need to switch Raid on my motherboard even though i’m NOT using 2 HDs. Interesting…is this correct?

Everything you mentioned is true. When I plug my plextor into the Silicon Image controler port #3 XP automatically detects the drive ane installs it and YES bios does not see it.

If bios cannot see it and it works in XP then I guess thats fine…but what if I want to reinstall XP…Id have to boot from my Plextor…how would bios be configed if it can’t see my bios and i need to boot from cdrom?

then again…whats the point of reinstalling xp to get the ICH5 drivers installed right if the plextor doesn’t work w/ the ICH5 controler anyway?

hrm…


#12

I’m not sure i’m getting this either but in my case, the SiI controller indentifies itself on boot-up (when activated in the setup) as RAID-controller never mind if I actually use the RAID feature or not (i do not, but have two HDs connected as regular independent drives). So maybe this is a simple problem of terminology?


#13

"If I want to…I can go back and reformat my WD HD (it has my OS) and reinstall xp pro and then install the ICH5r drivers and setup as RAID…

EVEN THOUGH I"M NOT USING A RAID SETUP?" You can, but you don’t have to. It’s not necessary.

“I always thought that If I wanted to to use RAID I had to have 2 HDs…” YES.
“but it sounds like If I simply just want to enable the ICH5r controler I need to switch Raid on my motherboard even though i’m NOT using 2 HDs. Interesting…is this correct?” YES and re-install the O/S and the ICH5R (iastor) driver from the floppy (F6 thingy). There is no real reason to change the mobo bios to enable the intel ICH5R RAID controller and re install the O/S and install the intel ICH5R drivers unless you want intel RAID.

“If bios cannot see it and it works in XP then I guess thats fine…but what if I want to reinstall XP…Id have to boot from my Plextor…how would bios be configed if it can’t see my bios and i need to boot from cdrom?” I would get or borrow a standard IDE cd burner/DVDrom combo unit (they’re dirt cheap!!!)

“whats the point of reinstalling xp to get the ICH5 drivers installed right if the plextor doesn’t work w/ the ICH5 controler anyway?” Only if you want intel / ICH5R RAID and Leave the Plex on the SiLImg controller.

If you are happy with the system as it is, leave it. If and when you feel you want to got to a RAID set up, then you can re-visit these issues later. IF you can exchange the Plex716SA for an IDE unit, do so. If you can’t, then get an IDE cd burner/DVD rom combo unit when you know you’ll need it.

Best Regards and don’t get all worked up. HAVE FUN!!!


#14

One more time…

can you recap why when my plextor is setup on the Intel ICH5 controler it detects in BIOS but not in XP? I’m still not quite understanding that. Its cuse the ICH5 intel raid drviers aren’t isntalled? yet…my Raptor reads fine on Sata Intel CH5 Sata #1. It has something to do w/ Raid drivers right? Couldn’t I simply enable the Raid Rom and switch IDE to RAID and change it to Enhance…and then install the intel drivers from xp pro…would my raptor still boot to xp? or does a format need to occur for this to work?

The reason I’m asking is becuase when I had the plextor on the Silicon controler…and it detected just fine…I had major issues install a DVD game. Though this was my first DVD game ever ( and i have since exchanged it for a new DVD game thinking it was a bad copy) It had major troulbe installing!

I was able to install Plextor Pro tools and stuff…was able to rip an audio CD. But when it came to installing the DVD game…i would get errors saying it failed and that it needs to be reinstalled or it was missing files…I took the game to work and it installed perfectly on the sysytem there. So i’m pointing the finger at the plextor unit. I was thinking it was also the silicon controler. I have yet to test out my new copy of the game becuase my peltier failed in my system. bleah.

wasnt’ there a way to boot from cdrom during post by doing some changes in the bios?


#15

I think I might be understanding the whole “RAID” concept w/ just a HD and a sata dvd r

In order to run more than 1 HD/DVD-R/what have you …on a SATA controler you must setup RAID regardless if your running 1 HD or 2…and then setup the RAID drivers and so on and so fourth…??

right? it would make sense in this aspect.

could be wrong but is this what your getting at?


#16

Meh…I’m going to go ahead and return this drive and get this new 716AL drive instead…however…I can’t seem to find out if this is a SATA drive aswell. I’ll just do an exchange for this newer drive.

hopefully it works better.


#17

IC7-G BIOS 27
Version: 27 Released Date: 2004-11-30

  1. Added adjustable MAX & MIN multiplier item for certain retail INTEL CPUs.
  2. Update CPU micro code.
  3. Supported certain SATA CDROM when “OnChip Serial ATA” in “Enhanced Mode”.
  4. Revised wording in PC health item.
  5. BIOS compile date: 11/01/2004

Have You tried this. It is a Bios Update. This release was from November but later Firmware should take care of it as well. Have you tried the enhanced mode?


#18

the 716AL is an IDE drive: http://www.plextor.com/english/products/716AL.htm

What I have been saying is that the SA may not be fully compatible with the ICH5 or the SilImg 3112A controller whether or not your configure them as RAID (with the drivers).

The reason Hard Disk drives work without enabling the RAID ROM / setting SATA = RAID and installing the RAID drivers, is that, by default, the controller uses the native drivers in Win XP.

Why, in one case, the 716SA shows up in BIOS and not in Windows or visa versa, I don’t know. I also don’t know if enabling RAID and installing the RAID drivers will allow/make the 716SA work with you vintage of RAID controllers (i.e. the ICH5R or the 3112A) or not.

I DO know, when configured as RAID, all four of my HD’s do NOT show up in the MOBO BIOS during post (they do show up when the RAID controllers BIOS’s post which happens right after the mobo bios post).

As it stands right now, I believe you have 2 SATA ports and 2 IDE ports. Each IDE port will hold 2 drives (master/slave). You don’t need to install the RAID drivers for any HD installed. You only need them if you want to build a RAID array using either or both of the RAID controllers.

You should get a non-SA DVD burner.

Best Regards


#19

Check Section 3-13 in your Manual or or 53 on the downloadable PDF version.


#20

53 where it talks about “speed read??”

What about the jumper that comes w/ this unit…it changes it to Multiword DMA…would that have anything to do w/ any of this tom foolery? haha.