Plextor 716A Problems (2x Amber Light Blinks)

vbimport

#1

I’m having the same issue.

I was reading DVDs w/ DVDDecrypter, and using DVDShrink to back up my personal DVD collection. One day it just stopped working. I put a disk in the drive, and got the Amber Light Blinking.

Contacted Tech Support, they sent me a new drive. The drive was put in, and flashed to the latest firmware (from v1.04) and worked great for literally 2 days, and now it’s doing the same thing w/ not reading disks, and has an amber blinky light.

What’s the deal? Others having these problems?

-Chris


#2

You could find something here
about the blinking codes! I had the problem sometimes, but after re-ejecting it works again fine. If it’s constantly i’d rma it again! :wink:


#3

Yes I have the same problem for 6 months…

RMA RMA RMA is the solution and again RMA…

They should send you a new firmware drive like 1.07 (not like 1.04)


#4

So I’m probably preaching to the choir here, but man, I thought Plextor was supposed to be one of the better Burner companies… After seeing all the issues with mine, and all the issues on MANY different forums, I guess that’s not the case.

-Chris


#5

Firmware is easily upgraded so it doesn’t matter if they send you a drive with a lower version installed. CPaladino, I agree with the others, if your drive constantly has this problem, RMA it again until you get a drive that works as it should.


#6

Firmware is easily upgraded so it doesn’t matter if they send you a drive with a lower version installed. CPaladino, I agree with the others, if your drive constantly has this problem, RMA it again until you get a drive that works as it should.

I just RMA’ed mine for “throwing” the bios, mine would do tho this a couple of times a week, I just re-flashed and everything was fine until the next time, finally got tired of it after it stopped my machine from booting properly. Hopefully i’ll get the replacement sooner than later.


#7

The problem you’re describing kamikazee could just as well be the result of your BIOS not working properly. But, I hope for you that it’s indeed the drive and that the replacement will work better :smiley: