Plextor 712A slow responding

Before upgrading to this system a week ago, my Plextor 712A worked perfectly. Now all of a sudden the DVD burner takes what would have taken 7 minutes to burn a data DVD to 57 minutes! The DVD is still readable. The drive seems to ‘lag’ at everything, including reading.

While burning, the writing light will flash for a few seconds, then it’ll go green for a few seconds and repeat, as if it is starting and stopping the write process. I also have an LG CD-RW connected and it runs fine. I’m not discounting it, but I find it odd that the moment after I upgrade my DVD drive decides to go.

Both drives are connected by primary ICH7R IDE controller. Plextor is set as master and LG as slave. Cables are connected correctly and I’ve tried 2 different cables.

I have Alcohol, CloneDVD and Nero 7 installed.

New System:
C2D e6600
Asus P5W DH Deluxe
2GB Corsair 8500C5
x1900xtx
X-Fi

Any ideas?

Sounds like the drive has fallen back to PIO instead of DMA: http://club.cdfreaks.com/showthread.php?t=49767#general-dma

The quickest cure usually is to unistall the IDE-channel the drive is connected to in the hardware manager and then reboot.

It is in PIO mode. I never thought that would cause the drive to run so slow. Thanks for the tip. I’ll give it a try.

What’s really odd is the slave LG drive didn’t fall to PIO mode.

Apparently Plextor’s customer support sucks because they mention nothing about slow response and the fact that it might be running in PIO mode on their website.

The FAQ of Plextor USA is quite extensive. However it needs searching until yoou eventually uncover info like this:

http://www.plextor.com/english/support/faqs/hw00024.htm
http://www.plextor.com/english/support/plexhelper/guide/enabledma.html

Hense their support sucks :slight_smile: Their info is hard to find and badly worded. This is their main support section. No where does it mention anything about DMA mode for slow writing issues. I don’t even know where you found those support pages :slight_smile:

But thank goodness for the good ol’ bulletin board systems. No company support can ever compare to the support fellow consumers can give.

After uninstalling the Primary IDE Controller and the Plextor drive, the Plextor went to U DMA33 mode after rebooting. Thanks for your help! I don’t have to buy a new Plextor now.