Plextor 708A

vbimport

#1

first and foremost, hello everyone^^

i am having a frustrating time with my Plextor 708A dvd player/burner.

until recently, the drive has worked great.

however, as of late, maybe the last couple of months, it has been increasingly difficult to play any DVD whether purchased or rented on my PC.

i have tried to search and even called Plextor for support but of course to no help. i was told by them that if any DVD played on the drive that it wasn’t their issue.

to make a long story short, we bought 4 dvd movies that came out last tuesday: aeon flux, match point, just friends, and fun with dick and jane. all four of these movies play perfectly fine on our home theater system, and also on my portable dvd player that i take with me on business flights. NONE of them however, will play on the plextor 708a. HOWEVER, i’ll pop in a movie like Seven and South Park: Bigger, Longer & Uncut, and it will work fine.

now i’ve read on these forums that there might be copyright or CD/DVD protection, but when i pop the DVD in the drive, it won’t even read anything. it will blink twice and when i go into “my computer”, there is no media.

i have recently upgraded to their latest firmware, and even cycled it from 1.04 all the way to 1.12 to see if that might be the issue. i have also installed aspi drivers as i thought that might help with forceaspi.

i don’t want to “rip” anything, i simply want to watch some of these movies on my PC while i am bored looking at reports and mail.

i am running win xp pro, and have had this custom PC for the last two years with no problems, but like i said, this is driving me nuts.

any help is sincerely appreciated.


#2

Do the self diagnostic test on the drive which is in the Plextor 708a manual. If you don’t have the manual do a search on the plextor website. If it fails the self diagnostic test then the drive is dead/dying.


#3

This is what I did and made my 708A work like new again. First perform the self diag test, if the test comes out positive (meaning there are problems) then check if it has been a year since your purchase date. If a year has past then that means your warranty has expired.

Now take the drive out of your case, remove the four screws on the bottom of the drive. After the internal components of the drive is exposed take a can of compressed air and spray directly at the lense. Then use a lint free Qtip (cotton swab) dip it in some alcohol and gently rub on the lens. Then switch to the dry side and rub again. After thats done use your can of compressed air and blow directly at the lens again and everywhere inside the drive where there’s dust. Reinstall the drive and it should work like new again.

FYI, my 708A couldn’t read cdrw, dvdrw and couldn’t burn dvd+r. After I cleaned it up everything worked like the first day I bought it again.


#4

before you take any extreme steps like taking your 708 apart, i would check Plextools Pro (hopefully you already have it installed - if not, do so or PM me) for the setting “Drive Spindown Time” and set it to 2mins or longer. i noticed with my 708UF that after flashing to the last few FW revisions, the Drive Spindown Time would reset to the lowest value and would cause skipping, buffering issues when reading both CDs and DVDs. once i set it at 2min or longer, those issues disappeared.

not saying this is what’s going on, but it’s an intermediate troubleshooting step you might want to try.


#5

Yes, this should fix the problem!


#6

hi everyone,

thanks for all of your help. i am in the process of opening up the dvd drive. drpino, i checked the plextor tools and the drive spindown was set to 2 minutes already. i bumped it up to 4 minutes and it was still the same issue. i then did the self-diagnostic per the manual and it checked out ok as well.

given that the warranty has expired, i then took out the drive. truth be told, when i took it out of the case, it was very, very dusty, so my assumption would also be that the respective lasers and it’s components would also be dusty as well.

now i took out the “void sticker” and removed the 4 small screws. my question is what is next? i am trying to search on where i can go to remove the rest of it so i can clean but having no luck (thus the late response).

do i need to remove the front plastic cover or have the tray out to remove the rest of the drive? i am having a tough time wiggling this thing out and don’t want to damage it. i can lift the back area to a certain extent, but if i lift it higher, i feel that i will break something in the front.

many, many thanks again as always, you guys are a wonderful help.


#7

hi again guys,

ok - was able to remove the drive, clean the laser. i had to pop out the tray first and then remove the face cover, then it was very, very easy to lift up the unit. once i flipped it over, i cleaned the laser with some alcohol and used a can of air around the surrounding areas. overall, i cleaned the majority of the dust, etc.

i rebooted the PC, logged on and then tried to test out the player.

i popped in “Match Point” a dvd my wife and i bought last tuesday.

sadly it was a no go. the front green light kept going on and on, and it looked like it tried to read it but it wasn’t happening. i checked all the settings on the plextor tools, and on My Computer/Control Panel/Sytem/Device Manager, and nothing seemed out of the ordinary (still the same settings as before).

so i popped in South Park: Bigger, Longer & Uncut, and sure enough it started up PowerDVD, and actually resumed playing to where i left off from last night (as a test).

both of these movies are original.

just so that i tested it right, i even popped in “The Notebook”, and it too loaded and played.

HOWEVER, when i popped in “Fun with Dick and Jane” another movie, purchased last tuesday, it was a no go.

so i tried another movie purchased about a month out “Wibledon”, and still no go.

so it seems that older movies have no problem playing on the DVD drive. the newer ones i can’t play.

i’m completely stumped.

self-diagnostics - fine.
remove drive, clean laser - check.
play old dvd movie - check.
play newly released movies - ><

thanks again in advance^^


#8

Maybe some sort of copy protection? Some recent protections need some software installed on the PC or the movie won’t play. I’d head over to http://club.cdfreaks.com/forumdisplay.php?f=80 and ask if anyone knows the titles involved…


#9

hi hwp,

thank you for the prompt reply - headed over there to check it out.

also one last thing, when i was with phone support with Plextor a couple days ago, they asked if i was getting any green flashing lights on the drive.

i told them i was getting 5 solid blinking green lights.

which according to the diagnostics meant:

Color: Green
Blink #: 5
Reason: Failure reading PMA, TOC or ATIP
Disc was detected, but the drive cannot read information from it

After that they asked if it was doing that for “ALL” of the dvd’s. i told them no, and then i got cut off saying it wasn’t the drive (lol).

anyways, that’s all i have.

my many, many thanks again for all of your help. if you guys can think of something else please let me know.


#10

one way to test if it is some sort of copy protection is to back one of them up to a double layer disc and see if that plays…that might point to it being some sort of protection scheme or weird stamping isssue…

i dunno, just throwing stuff out there…


#11

Have you tried opening the disc in DVD SHRINK? I’m wondering if you’re having a software issue with Power DVD. Open up DVD SHRINK to see if it can preview the disc then see if it plays back in there or not. If this doesn’t work then rip the disc with the latest DVDFAB DECRYPTER then use DVDSHRINK to preview the movie. If that doesn’t work then I’m just as stumped as everyone else. BTW my 708a is still going strong probably because I don’t use it much for dvd burning. I use it for dvd discs that aren’t readable in my other drives.


#12

hi dvd addict/drpino,

first and foremost, i appreciate all of your work through these forums, you guys are a tremendous help to a ton of noobs like myself^^

but getting back to it:

the thing is that the 708a doesn’t even recognize a disk being in the drive. if that was the case, i would have done what you suggested DA (dvd addict).

do you guys think it might be software related issues?

yesterday, i upgraded to the most recent PowerDVD software.

for burning, i use Nero 6 - one thing i did notice is that when i close out Nero after a successful burn is that it gives me some sort of hardware error that i just click on “don’t send to microsoft”.

i also have alcohol 120% running, and DaemonTools which i just recently installed to emulate whatever protection to help this thing work. i also installed AnyDVD, DVD Decrypter, and DVD Shrink.

do you guys think there are software conflicts at this point? it always goes back to point #1 which is that it makes an attempt to read the DVD but nothing, and when it’s an older DVD it works.

thanks again :slight_smile:


#13

In my eyes it doesn’t seem to be software related. What happens if the drive is put in an other computer?


#14

It sounds more to me like a software conflict. As Arrow pointed it out try putting the drive in another computer. What version of Nero are you using? Try uninstalling burning software, Dvdshrink, Decrypter, power dvd, Anydvd, Alcohol 120 & Daemon Tools. Uninstall NERO then use the NERO CLEAN TOOL then reinstall it. Install DVDSHRINK first then install NERO. Then see what happens. You should be able to view a dvd disc through DVDSHRINK.


#15

hi dvd_addict/arrow,

sorry for the late post. we don’t have an extra computer, so i went over to our in-laws and popped it on there.

same issues. plays the older dvd’s but not the new ones.

DA, i also uninstalled all of the software and reinstalled it and i still have the same issues.

i reinstalled it with dvdshrink first, then downloaded a new version of nero 7.x, etc.

just a quick question:

do you think it might be how these DVD’s are made these days that it can’t read the disk?

i just don’t understand what the issue is. i was able to burn a new audio cd for my wife and also burn her episodes of lost on dvd so she can watch them on her laptop.

i agree with you too DA, that it’s been a great drive so far, i just don’t get what could possibly be wrong with it at this point.

thanks again :slight_smile:


#16

all the titles you initially mentioned are very recent movies which leads me to believe something involved in the stamping process (most likely copy protection) could be at fault here…are they all from the same film studio?

i can’t recall if the 708 has any known issues reading OTP versus PTP double layer discs, anyone else know?


#17

hi drpino,

thanks as always for your reply. i am googling the OTP versus PTP double layer discs right now because i don’t know much about it.

maybe i just have an older version of the 708a and it can’t read the thing. i think dvd_addict mentioned that he also has a 708a and has had no problems with it. i bought the 708a when it was first released, so i’m thinking that this might be the case.

in any case, i think i’ve wasted enough of all of you guy’s time and would be better served possibly just buying a new dvd player/burner and swap out this drive and get a new one.

i think the real question is whether or not to stay with plextor at this point.

thanks again.


#18

I also have a 708A still in use. It never showed a behaviour like you described. As it didn’t work in an other computer either I would now say that there is definitely something wrong with your drive. Although I never heard about a 708 not reading newer DVDs I know that there have been 708s that stopped reading CDs while they still could read DVDs. If you will try another drive in your computer it will probably work.

But as always its just my opinion :iagree:


#19

no problem intouch :bigsmile:

here’s a brief definition of PTP/OTP - http://www.cdrinfo.com/Sections/Glossary/Details.aspx?TermId=532

i really have no idea if this is the problem (i haven’t done any explicit tests with PTP/OTP discs on my 708UF) but i’m as stumped as everyone else.

i have a very early 708UF (TLA 0001 i think) that’s more than 3 yrs old now (purchased it when they first came out) and it’s still going strong so i don’t think that’s the problem (though i haven’t purchased any recently released DVDs to try on it).

you haven’t wasted anyone’s time i don’t think - after all, these discussions are the primary reason for these forums.

i wouldn’t toss the drive out the window or anything (seems like it works fine with most pressed discs and still burns CDs and DVDs). look at everyone here - most of us have mulitple burners for a variety of reasons (dedicated rippers, readers, burners, etc.).

depending on your budget, the 760 might be a nice replacement (with a considerable speed increase) but it’s up to you to decide whether or not you need/want the advanced features available with it. if not, there are a ton of perfectly fine and cheaper alternatives out there…