Plextor 708A: Poor Transfer Speed Performance

Had to rebuild my machine recently and while copying mp3 DVD backups to my hard drive I noticed it not only took forever (forty minutes average) but practically froze my machine - I could do virtually nothing else. Programs took forever to load and my mouse skipped across the screen. I finally ran some Nero CD-DVDSpeed tests and noticed I’m getting some insanely crappy performance. I start at about 3.15-3.19x and, after about a gig to a gig-and-a-half of transfers, it plummets to 1.91x. Always 1.91x. And that’s how it ends.

And this is not a good graph either. The line dips, over and over, becoming incredibly jagged. I’ve tried all the usual fixes. I am a legitimate technoweenie, and have not skimped on testing and experimenting. Everything’s full UDMA… all good there. Firmware’s all up-to-date. IDE connections, power connections, jumper settings: check, check, check. Good.

I’ve looked at various becnhmarking sites just as a frame of reference and see transfer datagrams of between 4 and 6x for my same model. Any ideas as to the incredibly crappy performance?? Here’s my machine specs…

Intel Pentium 4 3.2GHz Northwood (800MHz FSB)
1GB (2×512MB) Corsair XMS PC3200 RAM, DDR400MHz Low Latency
MSI 865PE Neo-FIS2R Motherboard, latest Intel drivers
Seagate Barracuda PATA 120GB HDD, 7200rpm, 8MB cache, NTFS @ 4K clusters
Plextor Internal EIDE 52x32x52 CD-RW
Plextor Internal EIDE 8x DVD±RW (Model #: PX-708A/SW-BL, Firmware: 1.08)
Sapphire Toxic X800 XT 256MB 8xAGP Video Card
Creative Soundblaster Audigy 2ZS Soundcard, Gamer Edition
Netgear Triband (a/b/g) Wi-Fi PCI NIC
Vantec Stealth 520W PSU
Windows XP, Service Pack 2

IDE setup as follows:

IDE Channel 1: Hard drive (Primary Master), DVD±RW (Primary Slave)
IDE Channel 2: CD-RW (Secondary Master)

Any ideas are totally, utterly, greatly appreciated! Thanks for havin’ a look!

EDIT: And just to add, all other performance is good: writes a full DVD in 8min. exactly, averaging about 7.6-7.8x.

Welcome to the forums centerNegative. The things you described sound a lot like a DMA-related problem. You sure your Plex is running in UDMA mode 2? Have you installed the Inter Application Accelerator (IAA) drivers? Try updating them to the latest version or, if you’re already running the latest version, removing them to see if that makes a difference. IAA is known to cause problems sometimes. Report back with your findings!

Yawp, UDMA 2 on both opticals. UDMA 5 on the hard disk. Everything looks in order. But I’ll check on the Intel Application Accelerator drivers. I know I have latest Intel INF drivers from my mobo manufacturer. Guess I can fiddle with that, as well. Thanks!

This really sounds like a DMA issue. 1.91X is about the maximum transfer rate for PIO Mode 4. I think the discs you are trying to read are very poor quality and after a few read errors and re-trys Windows XP is dropping the transfer rate from UDMA Mode 2 to PIO Mode 4. Check the System Log in Event Viewer to see if there are any entries relating to CD-Rom, ATAPI or IDE

Have you tried reading some pressed DVDs to see if you get the same speeds?

What Taroth said is right. A couple nights ago all the sudden my plex 712a dropped to PIO mode. I remember now, I made it read a scratched disk. It took very looong to read the disk, and after it finished then it burn a 1gb of data in 5 minutes @8x :Z . When I checked again in Control Panel - System - Hardware - Device Manager - IDE ATA/ATAPI controller - Primary IDE Channel (where my 712a located) - Properties - Advanced Settings, it’s in PIO only! Had to uninstall the IDE channel and reboot twice to fix the problem (there’s an error in the first reboot). If an optical in PIO mode, not only it reads/burns slow, the PIE graph also looks silly. Damn!

you need to move the plextor DVD writer to the secondary IDE channel as MASTER. Plextor DVD writers do not function well as slave. what you are showing in your spec’s is that you have your Hard drive and your plextor DVD writer BOTH on the same channel very bad idea.

I’ve known of the PIO issue from a previous machine but I checked on that. It was solidly reading as DMA If Available/UDMA Mode 2 without any changes. And that was checked during the transfer test. The DVD was slightly scratched - mildly scuffed, really. Actually, I was shocked that it was scratched at all but that’s what I get for leaving it on my desk with books piled on it… :stuck_out_tongue:

So, by deleting the channels you guys mean going into the device manager to the IDE channels section and uninstalling them? S’pose I could try that. First thing to try, though, is swapping them to different channels. I talked with my older brother about it and had my logic backwards. I figured optical and hard disk on the same channel would be more efficient but I was told it’s more of a bottleneck than anything; like working your faucet and your toilet off the same tap… Whoops.

But it’ll only take me a few minutes to swap the opticals so I’ll try that first when I get home today. I sensed from the Plextor manual that the drive seems predestined to be a Master on whatever channel it’s on since they gave no indications ever of setting it up as Slave. If the issue remains I’ll then try zapping the IDE channels from within Windows and see what happens. I’ll post back with the progress! Thanks a lot, fellas!

EDIT: I will also be sure to check the event viewer. I hadn’t thought of it since I wasn’t getting any errors during the test but it’s a good idea. I’ll let you know if I find anything on that first.

I found another way to restore UDMA mode 2 for Plextor writers, after WinXP has dropped to PIO transfer mode. It requires only one reboot, but PlexTools Professional must be installed and working.

Within Plextools Professional, go to the “Advanced” tab of the “Drive Settings” option. Look at the “Enable DMA” checkbox. If it is enabled, uncheck it and answer NO to the restart prompt. Next, check it again and answer YES to enable DMA. Finally, answer YES to the restart prompt and allow the system to reboot. After getting back to the WinXP desktop, the Plextor writer should be running in UDMA mode 2 again.

I have tested this method successfully on PX-712A. PX-708A and Plextor Premium CD-RW, but YMMV. For me, this method is quicker than manually deleting the IDE channel (usually secondary) from WinXP and rebooting twice to get everything back to working order. And yes, I have seen WinXP drop my Plextors to PIO mode under certain conditions such as with hard-to-read media, and there doesn’t seem to be a comprehensive way to prevent that.

BTW, Microsoft has a hotfix WinXP IDE driver (ATAPI.SYS) which, along with some registry modifications, will make the transfer mode drop-down behavior less aggressive in response to CRC errors on the IDE bus:

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

This hotfix was released after WinXP SP1 but before SP2, so I don’t know what would happen if this hotfix is installed and then WinXP is upgraded from SP1 to SP2. I’ll need to research this…

thanks for your tip scan80269

Still no luck. Swapped everything around. Still getting crappie transfer rates. 1.91x. No PIO involved. I’ve checked the Device Manager again while running tests when it hit that speed and it isn’t visibly changing itself to PIO mode. I uninstalled the IDE channels and reinstalled them, still no luck. Out of ideas of my end, kids! Time to get crazy! :stuck_out_tongue:

How about the disk itself? have you tested the disk to see if it has errors that may be causing the slow transfer rate?

Well, honestly, no. I’m usually all for eliminating possibilities but it’s a fresh TDK DVD+R, right off the spindle, that was created using the Create Disc function of the Nero CD-DVD Speed tool. But I have performed this test on multiple discs and get the same results. It has admittedly mrginally improved, but after about read 1 to 1.5 GB, it just drops to 1.91x speed and levels off… :confused:

From your descriptions it sounds like your PX-708A creates rather poor quality burns with your TDK DVD+R media.

I just tried using both Nero CD-DVD Speed and Plextor PlexTools Professional “Read Transfer Rate Test” to scan a 4X TDK DVD+R disc (RICOHJPN R01) burned several weeks ago (with a PX-712A though) on my PX-708A, and both apps reported smooth transfer curves, starting at 3.30X and ending at almost 8X.

BTW, my PX-708A is currently a secondary slave, with Plextor Premium CD-RW as secondary master. I know the PX-708A really should be master, but I have not encountered any performance-related problems.

Have your tried reading DVD+R media burned by other drives? You can also try reading DVD movie disks, but Plextor SpeedRead should be enabled on the PX-708A to get 3-8X CAV read speed for dual-layer DVD disks and 5-12X CAV for single-layer DVD, otherwise you will get 2X CLV read speed.

Other things to try:

  1. If the IDE cable used for the PX-708A is the 40-wire type, try upgrading to the 80-wire type (same as for IDE hard disks), which delivers better signal quality.
  2. Disable any processor overclocking and memory turbo-charging settings in effect, as these can affect IDE bus reliability.

Nope, no luck there. Movie DVD is reading at 1.91x. With the SpeedRead enabled. :confused: Couldn’t tell you what kind of IDE cable it is. Just some black rounded cables I got online. Plextor support has given me some very, very rudimentary solutions. Dunno how many more times I’m going to have to prove to people that the DMA is enabled…

Are you enabling SpeedRead for the PX-708A using the “press and hold eject button for 5 seconds with the tray closed” method, or with PlexTools Professional?

Since your DVD burn speed is fine, but your read speed starts at 3.1X and drops to 1.91X, this suggests either your media was burned at a low quality level to prevent reading at rated speed, or your PX-708A is somehow deficient in its reading capability. Also, mouse skipping across the screen during DVD read is definitely not normal.

It would be tricky to find out if the problem is with media quality or PX-708A read capability, since you don’t have a PX-712A (good for running PlexTools Professional Q-Check PI/PO scans on DVD media) or a LiteOn DVD writer (good for running Kprobe2 DVD scans).

If you cannot tell the type of IDE cable you have, you can count the number of wires in parallel. It should be either 40 or 80.

Here are a few more troubleshooting suggestions:

  1. Remove your soundcard and Wi-Fi NIC (just in case the supporting drivers may be messing up the system) and check for improvement
  2. If you have multiple DVD burner software applications installed, try uninstalling them and leaving just one, such as Nero, etc.
  3. Update your motherboard BIOS if it is not current.
  4. Run a memory test on your PC. You can download Microsoft’s Windows Memory Diagnostic:
    http://oca.microsoft.com/en/windiag.asp

Well, sorry I lagged out on what happened with this. Let me put it simply: it was the media. It turned out to be a TDK DVD+R rated for 4x. It’s on the Plextor comaptibility list but, basically, it’s crap. I tested the burner with the blank Plextor media that came with the drive and, while it burned slower, like 6.82x instead of 7.68x, it read a lot faster. I think it average 5.21x, starting at around three and ending over 7x. So, I just need to get some better discs, as far as I can tell. Problem is, I’m brand loyal and TDKs look better than all other blanks. So, I guess I have to wait until they come up with some 8x-rated blanks. :frowning:

And, of course, if I didn’t mention it before, swapping the burner to the other channel fixed the Windows stuttering problem I was having. All-in-all, problem solved. Thanks, dudes, for all the helpful feedback. I guess maybe Plextor doesn’t suck so much after all. Of course, everyone who replied to this thread was no less than 315% more effective than Plextor tech support. I salute you! :stuck_out_tongue: