Plextor 708A burns as read by a BenQ 1640

I recently RMA’d a BenQ 1640 since it couldn’t read any of the burns I’d made previously on my Plextor 708A. I was able to view the Plextor burns on two different machines at work, though.

I got my second BenQ 1640 in the mail yesterday. It has the same problem as the first one did… It burns great but it cannot even see a disc burned by my old Plextor 708A.

Any ideas as to what might be going on?

The old burns are mostly DVD-R, on all kinds of media, mostly TYG01.

Are you running your 708 with firmware 1.05? There has been a readability issue with this firmware version.

Actually, no, my 708A has been flashed to 1.11. Seems like I was at 1.06 for a long time.

I really am at a loss as to what to do. Surely I couldn’t have gotten two bad BenQs in a row.

i’m not surprised by your experience in the least. the dw1640 is the most finicky -r reader i’ve ever owned (my current & past models include toshiba sd-r5002/sd-r5112, nec 2510a/3520a/3540a). i get the impression since most users on this forum strive for the utmost in burning excellence they are not as exposed to the vagaries of the drive with sub-excellent media. i own 2 of these fine drives & i can attest they are both equally abysmal readers, at least with the multitudes of mediocre media i’ve archived. it is often the case the dw1640 is unable to read crap media it has just burned, but i still get a marginally acceptible scan with the 3540a. mind you it’s only the reading performance i’m knocking, as far as i’m concerned the dw1640 is the best -r burner i’ve ever seen in regards to mediocre media

no probs here with 708 and 1640.
benq reads all media burned by px708. i tried mcc01rg20, mcc 02rg20, mcc002, mcc003, ricoh 8x +r, ritek 8x +r, mbi 4x +r, mbi 8x +r, cmc mag ae1, ty 4x-r, ty 4x +r and cd-r from mcc, ty, mbi, ritek.
i used fw 1.04, 1.06, 1.08 and 1.11 on px708.