Plextor 708A and ASPI problems

vbimport

#1

Problem Summary: I just purchased an internal Plextor 708A. I ran the procedure to install the ASPI files, and now I don’t have access to the 708A at all anymore.

Details:
The 708A is now installed on a Dell 530 Workstation running Win 2k Pro. I had previously installed a Plextor CD-RW (48/24/48u) USB drive that worked flawlessly, and it is still physically connected as well.

The 708 is giving me fits. It wouldn’t read disks reliably, it wouldn’t erase disks, it didn’t recognize disks. I made the mistake of doing a manual format and of course Easy CD Creator software said the drive was full with 417kb of data and that was on a DVD+RW disk.

I got it to work with one disk, for a short time, but it failed before completing the copy of the file it was working on.

After a full two days of playing with this, I called plextor tech support. Then I learned after running ASPI check that the ASPI files were not loaded. I followed their “How To:” Procedure here, except for steps 7 and 8 because now I don’t have access to my CD drive!:

http://www.plextor.com/english/support/faqs/How_To/HT00001.html

But now, my drive letters for BOTH my 708A and the CD-RW (USB device) are gone. Windows lists the driver files in the device manager, but I see an error message in device manager that says

“This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)”

I “de-installed” and reinstalled both drives, as the Troubleshooting Wizard suggested. Windows recognized the devices on startup, but when trying to install them, I wound up with the same errors. A yellow exclamation point does show up by these devices in Device Manager.

Part of the procedure Plextor said to follow required me to change the names of certain files, like cdrtc.dll, cdr4_2k.sys, etc. (see step 3 in above link). Do I have to change the names of those files back to gain access? I assumed that they would be replaced by the installation of Easy CD Creator files when the application software was re-installed.

Somebody help me! What do I need to do in order to get basic read access back to my CD-RW and 708 drives?

Please don’t tell me to reinstall Windows! aaaagh!!

Thank you!

zlaser


#2

I’m going to suggest to you to reinstall windows 2000. Sounds to me your operating system is corrupted at this point because of the dll files you renamed. Download the ASPI drivers from ADAPTEC’S site. Install the ASPI drivers right after you’re done reinstalling windows 2000.

http://www.adaptec.com/worldwide/support/drivers_by_product.html?sess=no&language=English+US&cat=%2FProduct%2FASPI-4.70&prodkey=ASPI-4.70

That’s just my opinion. I would start over and reinstall windows 2000. I know it’s a pain in the ass to do. But hey I just got done reinstalling windows 2000 for the 3rd time in my parents pc cuz they installed some cursor program that corrupted the registry. I feel your pain of having to reinstall windows. :(:frowning:


PENT 4 2.4 MHZ CHIP, 1 GB DDRAM, WIN2000 PRO W/SP4
PLEXTOR 708A DVD BURNER
PLEXTOR 40X12X40 CD BURNER
PLEXTOR 48X24X48 CD BURNER
TOSHIBA 1612 DVDROM (2)
TOSHIBA 1712 DVDROM
60 GB, 120 GB MAXTOR HD’s, 120 MAXTOR EXTERNAL HD
CANOPUS ADVC-100 DIGITAL CONVERTER
MAXTOR PCI CONTROLLER CARD
ANTEC TRUE POWER 430 WATT PS


#3

Let me see if i got this correctly.

  1. You had some problems with the 708 with recognising/burning media

  2. You contacted Plextor support and they suggested

a) uninstalling Roxio
b) installing Adaptec ASPI

  1. You used the guide from Plextor to remove Roxio and followed it to the letter

  2. Your drives are now not recognised

Did i get this straight?

Grab ASPI version 4.60 from the link in my sig or just google for it. Later versions are reported to cause problems with XP/2000.


#4
  1. You contacted Plextor support and they suggested

a) uninstalling Roxio
b) installing Adaptec ASPI

  1. You used the guide from Plextor to remove Roxio and followed it to the letter

  2. Your drives are now not recognised

That’s pretty much correct. They had me check and I had no ASPI layers installed according to the ASPICHK utility on the plextor CD. So, they had me go through this procedure so that I could install the ASPI layer they provide (4.7.1 I think).

What I didn’t realize, was that if I followed their procedure, I would totally lose contact with the CD-RW (USB device) and the 708, both of which are plextor drives. Device manager list the normal Windows driver files as the driver, but I also see the error 31 in device manager. I thought I would at least still see the drives as regular CD drives. There’s no reason I shouldn’t even have drive letter access to them, right?

I’ve done a lot of digging and got quite an education on ASPI layers from the site:

http://aspi.radified.com/

So, I have options. But right now, I don’t think the failure to recognize the drive letters should be an ASPI issue. The machine worked fine with the CD-RW USB device with NO ASPI layer installed using the supplied Easy CD creator 5 software and CLoneCD before.

So, at the moment, I’m a little uncertain as to what to try next. Reinstalling the regular drivers did not
work.

zlaser


#5

The files you renamed are related to Roxio, but at this point it would do no more harm if you would just rename them back to their original extensions.

Furthermore, if you followed Plextor’s instructions you should have a backup of your registry made at some point. Restoring this should bring everything back to “normal”. You can even try a system restore, although i am not sure this is available in 2000 - should be.


#6

@ zlaser
Yes, you’re right. Your missing drives are not due to a missing/malfunctioning ASPI layer.
What you can do is to (I’m assuming that you have the drive (PX-708A) connected to the secondary ide channel) is to remove that channel in Device Manager and reboot. Normally Windows should find it along with your dvd burner. You may need to feed Windows with ide drivers so be sure to grab those from Intel’s website before removing that device. As for your USB-device I think it may fix itself by switching USB-port.

As for ASPI layer I personally prefer Ahead’s (included in Nero for instance) since it works fine and actually allows Windows to update the discs label (doesn’t work in Adaptec’s ASPI layer 4.60). The only issue I’ve come across is that KProbe refuses to work with it correctly and the solution is to rename wnaspi32.dll temporary which is located in WinNT\System32 (you have to copy wnaspi32.dll to that directory) to make KProbe use SPTI instead.
//Danne


#7

I finally got Plextor tech support back on the phone. The tech guys do seem to have their act together. It’s ashame that Plextor is bundled with such junky software.

I asked the tech guy what software he might recommend other than the Roxio stuffy. He said about 90% of the techs there personally use Nero 6.

I tried Nero6’s demo online yesterday and it immediately gave me a “demo expired” message. Great… I downloaded an outdated demo of about 23 megs.

Anyway… here is how I got my drive letter access back, and it did work. I still have not yet re-loaded any burning software. One thing at at time…

============================

From Plextor tech support:

The solution to this issue is simple and dangerous at the same time. It involves going into the Windows registry and making changes to it

THIS CAN BE EXTREMELLY DANGEROUS, please exercise caution while implementing this fix

For Advanced users:

Back up Registry to another directory in case you need to reinstall it:

Start>Run>Regedit>Registry>Export Registry File to C:, now start the next step:

  1. Open Plus Box (Hkey_local_machine\system\control set 001\control\class)

  2. Find Key that starts with (4D36E965).

  3. Delete the (lower filter).

  4. Delete the (upper filter).

  5. Reboot and check each time to see if issue is solved.

  6. If it does not work for you then try the next entries in control set 002

  7. Then control set 003 each time check to see if issue is solved.

If this does not solve your issue then you may have to work with your Operating System (OEM) or Microsoft for further support on the Windows 2000 registry keys.

==========================
The theory that was explained to me was that Windows was trying to load some drivers that it sensed were already loaded, at least in part, so it aborted the whole procedure and refused to load any of the driver files. Deleting those keys in the registry eliminates this problem.

Incidentally, they definitely recommend ASPI 4.7.1 or later. Many people think the 4.6 stuff is great, but this tech said it was too old for my system. I did notice however that when I ran ASPI check, that only two of the four files said 4.7.1, and that was the way it was supposed to be.

I would never ever have figured this one out if I lived to be 200.

Hope this helps you guys. Thanks for the feedback.


#8

You too, zlaser. Thanks for letting us know how to solve this problem. As you said, I (and probably many others with me ;)) would have never thought of this myself.