Plextor 40/12/40ta reading problem

my plextor 40/12/40ta failed to read and play cd ’ s in windows xp using clone cd or nero , writing cd ’ s ( with a previous made image in clone cd ) works fine ,
when i switch to windows 2000 , everything works fine ( reading and writing ) ,
i think ( but i am no sure ) this problem started when i upgraded from firmware 1.04 to 1.05 ,
i tried to downgrade from 1.05 to 1.04 but the software refused to do so ,
first question : how can i downgrade from 1.05 to 1.04 ??
second question : why is reading working in os windows 2000 and not in os windows xp ?? ,

thanks ,

When you try to read a disc, are there any error messages displayed or does the drive simply not respond? Are there any LEDs blinking on the drive when you try to read a disc? How to downgrade the firmware of your drive has been answered in the other thread you started.

thanks for responding G@M3FR3@K ,
here are my answers :

  1. yes the leds on the drive are blinking , for a data cd - rom for example it took a long time to see the contence of the cd - rom , playing a audio disc , the sound stuttered ( goes on and off ) ( sorry for my poor englisch ) ,
    2 . the downgrade does not work like explained by parker in the other trhread , the software refuses to do so ,
    3 . for the rest , no error messages are displayed , but the drive is responding ,
    4 . the silly thing is that everything is working fine in windows 2000 ,

robert ,

in windows xp , it was impossible to do a downgrade from 1.05 to 1.04 , in windows 2000 , it works , and guess … everything is ok , so : there is something wrong with firmware 1.05 , i will email this information to plextor and tell you about their response ,

robert ,

Hmm judging from your information it could be a DMA problem under Windows XP. Can you check if DMA is enabled for your drive under XP? You can check this with Nero InfoTool or manually via Device Mangager, IDE ATA/ATAPI Controllers. Please report back.

my recorder is connected as master to the second channel ,
i checked it manually , and it says : ultra dma mode 2 ,
thats normal don ’ t you think so ??? ,
please tell me if it is not ,

robert ,

Ultra DMA Mode 2 is the correct mode the drive should be running in. I see that you solved your problem by downgrading firmware using Windows 2000?

yes , i was able to downgrade from 1.05 to 1.04 by switching to windows 2000 , but i also like to go to 1.05 one day because it gives support for 99 minutes cd ’ roms , and plextor, so far , did not respond to my email ,

robert ,