Plextor 24/10/40A Problem (Help?!)

Okay, I’ve tried everything I can think of, but I’m now stumped. A couple of months ago, my new PlexWriter PX-2410A worked fine. Now, EVERY SINGLE burn attempt turns out as a coaster, whether I’m trying to burn an ISO or even just copy some files from a hard drive. CDs the unit burns can be “seen” by Windows in that the file directory can be browsed, but the files themselves cannot be read.

Because a couple months passed (during which I didn’t do any CD burning) between the last good CD I burned and my recent LONG, unbroken string of coasters, I have no idea what might have changed on my system that has resulted in this current inability to burn anything successfully.

Checklist:

  • My CD-R is the master on the secondary IDE channel.
  • It (and the other drive on the channel, which is Toshiba DVD-ROM drive) are both in DMA mode (specifically UDMA-2).
  • The burner’s firmware is upgraded to v1.04 (it came with 1.02)–the current version for that drive.
  • The drive is recognized by CD burning software, and all burns complete without errors–but the CDs cannot be read.
  • I have tried three different supported blank media types, not just cheap media, and all burns have failed (this is getting expensive, by the way!).
  • No anti-virus running while burning. No CPU loading.
  • Auto-insert notification off
  • CD-burning support in Windows XP disabled.

Relevant System config:
Asus A7V333 w/KT333 chipset
AthlonXP 1800+
512Megs PC-2700 333MHz RAM
PlexWriter PX-2410A

Things I’ve tried:

I’ve uninstalled ALL CD-R applications and then reinstalled the latest NERO Burning ROM version (which worked fine before SOMETHING changed on my system to pork it up).

Re-installing or rolling back the firmware to v1.02 (unsuccessful). When either trying to re-install the v1.04 or install v1.03 of the firmware, I get an error. The error returned from trying to install v1.03 to replace v1.04 is one that Plextor support pages report as being fixed by installing the Via IDE tool (bus mastering), but it didn’t work on my system. The firmware update executable finds the drive, but cannot write the firware update to it. This might be related to my burning problem, but I don’t know how to address it!

I’ve tried updating the Via 4-in-1 drivers (v4.43) and installing the Via Bus Master IDE filter (v5.1.2600.3014). The 4-in-1s have to be installed for my Windows XP Pro system to recognize the graphics adapter. The IDE bus master filter improves performance but does not fix this problem.

After discovering that something had installed ASPI 4.71, I’ve used ForceASPI to force that back to v4.60 and when that didn’t work I uninstalled all ASPI drivers completely (and verified using ASPIcheck). Neither effort made any difference.

Nothing that I can think of, or find suggested on the Web anywhere seems to work. Is there ANYTHING else to try or is it time to consider that my Plextor drive is defective?

Thanks for your suggestions,

Kevin

If you could temporarily install the drive in another computer, that should confirm whether it’s a hardware failure or a conflict on your computer.

BTW, ASPI 4.71 is the version written specifically for WinXP by Adaptec. Development of v4.60 stopped with WinNT.

Is your computer overclocked? If so, this could be causing the problem.

Had same problem but with a teac scsi writer turned out to be problem with the scsi cable, try another IDE cable if you have one.