Plextor 24/10/40A and plextools

vbimport

#1

Hi,

I bought this drive a while back now, Nov 2001 it would have been when it was brand new. At the time I had a massive problem installing it and it took me 2 full days to get it working!

The main problem was that everytime I went to read anything to do with the cd drive (ie my computer, or run and browse and then trying to acces it from there) the computer would either refuse to cooperate and freeze or if you were lucky it might show you what you wanted. However if you actually went and explored the cd it would crash everytime.

The solution to this problem was going into the BIOS of my motherboard (Asus A7V266) and having to make sure that it didn't automatically detect my plextor or DVD Drive (Acer 10x dvd drive). When I did this I was amazed that it had actually fixed the problem.

I should have taken it back then, but since it was working I decided there was no point. However recently I have been noticing the following side effects:

  1. When writing a cd (using nero) the computer goes to an absolute pathetic speed. The sounds from programs such as trillian which go off in the background are played at like 25% their normal speed. I am sure I read you are supposed to be able to do anything on the computer when your writing a cd, but not the case here!

  2. When copying any file from cd, the computer would also fall into this coma speed, and any mp3s playing (from the hd) would be laughably slow. This has also been shown when playing mp3s straight from cd, there are frequent jumps and skips when playing, but when they are copied to the hard drive they play no problem.

  3. For some unknown reason, plextools (any version) or pxinfo (newest version i think) have never loaded on my computer. They just absolutely freeze it, and even in windows xp with its better crash handling abilities, it still couldn't recover. When I attempted to install plextools today (I don't know why I bothered) windows xp would hardly even load. Again the classic symptoms of My computer not loading and any sort of access to the cd drive would crash it. By the way, I have tried plextools in 98 and XP and as far as I know it has never loaded and only caused problems.

  4. I nearly forgot to mention this, but more frequently now, when I insert a cd and attempt to access it through my computer, when I double click on the cd drive, it shows the cd to be empty when I know it not to be. When I try inserting the same CD into the DVD rom drive I get the 'CD Not inserted' when it is clearly in. However a restart of windows xp seems to fix this, however I don't know why it occurs in the first place.

My specs are:

Motherboard: Asus A7V266 (Dont know what revision, should probably upgrade it)

Primary Master: IBM Deskstar 61.5GB
Primary Slave: None
Secondary Master: Plextor 24/10/40a (Oldest revision probably, I don't know if a firmware upgrade would fix it, its probably the next thing im going to try).
Secondary Slave: Acer 10x DVDrom (Same).

Obviously something is wrong here, this shouldn't happen but it unfortunately is. It was my second attempt at building a computer together, and for the past 9 months its worked fine. I've decided however Im going to get to the bottom of this plextor/cd issue.

There are also somethings I have never understood about CD drives. What the hell are these ASPI drivers, and why do I have to get them from adaptec? I have never understood these and why you need them.

Is there anybody out there who could advise on any course of action?

Should I just send the thing back? (what im thinking of) :stuck_out_tongue:

Kind Regards,

Adam


#2

QUICK UPDATE:

I just read a post on the site, and it was somebody with the same motherboard as me. They recommended removing the IDE controller, and installing newest Via 4in1 drivers. I’ve done that and its cured the coma state the computer went in when I wrote cds, so Im getting somewhere!!

I’ve also installed the Aspi layer to 4.60 using ForceAspi. Im not sure how much that had to do with it either, but anyway its a good start.

Regards,

Adam


#3

The link to the VIA 4-in-1 is here,

http://downloads.viaarena.com/drivers/4in1/VIA_4IN1_V440V(a)P3.zip

And you can find the link and faq for ForceASPI from a post I made on the “Plextor FAQ (under construction” thread.

Hope this helps, please try em one at a time, and tell us which one did the trick,
DFourthHorseman


#4

hi,

well in my quick reply post I updated the aspi and installed the 4in1 drivers at the same time. So I don’t know which was to praise for fixing that problem. But either way it has fixed it :slight_smile:

However, I did run into the problem again last night where I went to access my cd rom drive and there was a cd in with data on, but when exploring it nothing was shown.

I think a lot of this revolves around DMA/PIO data transfer in Windows XP. The plextor drive was initially set to PIO, but I think it was a post by yourself which suggested removing the controller to change it to DMA. It is DMA now, so maybe that fixed the problem?

Regards,

byb


#5

I don’t think it has anything to do with DMA/PIO transfer mode, they do vary in performance but that’s all. There are three possiblities, your ASPI Layer drivers, your VIA 4-in-1 drivers, or your VIA Busmaster IDE Controller, which you should reinstall if ever your Plextor does not come back to DMA from PIO, even when its enabled.

Hope this helps
DFourthHorseman