Plextor 12/10/32a

vbimport

#1

What firmware do you use? 1.08 ?
What do you think is the best?
Thanks.
Cheers.


#2

Using 1.08 and because of the fact that this drive has never made a coaster or had a failure I like it very much!


#3

Yes I agree with Wookie. Usually the latest FW is the best FW… I 'm also using FW1.8.

There are some TLA# that can do SafeDisc 2 with FW 1.4 though. For a list check here.


#4

I also use FW 1.08 which is fine,wouldn’t bother flashing FW 1.04 mine didn’t work :eek:


#5

Originally posted by idunno
I also use FW 1.08 which is fine,wouldn’t bother flashing FW 1.04 mine didn’t work :eek:
Nope most Plex PX-W1210A burners do not allow FirmWare downgrading… :frowning:


#6

anyway betablocker works with most sd2 games.


#7
                  (scsi)        Ive got 12/4/32 1.04 works great even with safedisk, Max Payne no problem!:cool:

#8

its true i can copy safedisk 1 and 2 what ever.
but with 1.08 its a no go.:cool:


#9

Maby 1.09 will be released soon which will rectify this problem, just wait and see. Plextor have not let us down yet, not entierly true they amost did, but now they rock again :cool:


#10

Originally posted by intercept
Maby 1.09 will be released soon which will rectify this problem, just wait and see. Plextor have not let us down yet, not entierly true they amost did, but now they rock again :cool:

I don’t think it will help. I think it’s more a chipset problem than a firmware problem with SafeDisc 2. Although there are reports that using the 1.4 firmware solves the SafeDisc 2 problems with some drives… Would be very nice if it were indeed a firmware problem and Plextor would release a new firmware :smiley: