PlexTools Professional XL 3.16 now freeware and freely downloadable

vbimport

#1

Dear fellow CDFreaks,

it gives me much pleasure to inform you that Plextor has finally decided to openly offer PlexTools Professional XL 3.16 as a free download, without conditions [such as proof of purchase] or limitations [as far as I can tell]. It’s linked to from the main navigation menu.

[ol]
[li]Go to Plextor’s IT products website
[/li][li]Click on ‘Downloads’
[/li][li]Click on ‘Software & Utilities’
[/li][li]At the bottom, you should find ‘PleXTools Professional XL Version:3.16’. Open the link.
[/li][li]Download away :bigsmile:
[/li][/ol]

So far, it has been working very well with my PX-760A. It definitely adds to the joy of owning a Plextor, and I look forward to the future.

Enjoy!


#2

It has been available freely for a while but initially only for those who contacted Plextor support. They added it to their main site a few months ago. I’ve been using it for a few months and it seems to work pretty well. I still keep a copy of Plextools Pro around as it seems to handle mp3 ID tags better.

Cheers

James.


#3

I didn’t realise Plextor had added an accessible and discoverable link that long ago, since that page said it was created on 2010-01-01. My Google searches yielded no announcements on other forums or tech sites. Searching MyCE brought up a single thread from 2008 that had the download link removed [since it was not supposed to be publicly downloadable at the time].

Also, as it stands now, the MyCE Plextor FAQ still states that a licence needs to be purchased for it. All these indicate that not many are aware of the good news.


#4

HWP posted a link back in August to Plextor’s web page that listed it but I agree, it isn’t very well known.

Cheers

James.


#5

ya like James said it’s been around for awhile. Glad you finally found it though.


#6

[QUOTE=alexanderino;2489131]I didn’t realise Plextor had added an accessible and discoverable link that long ago, since that page said it was created on 2010-01-01. My Google searches yielded no announcements on other forums or tech sites.[/QUOTE]

They had been openly available on the plextools.com and plextor.be web sites since around April of 2009. The plextor-digital.com domain is new and the site has been redesigned, which is why the dates seem recent.

Anyway, it’s good that you posted, because Plextor has been moving things around and acting in a callous and unprofessional manner, by breaking previous links and not renewing older domains, so it’s good to let everyone know where things are now.


#7

Thanks for the links, negritude (for what it’s worth, I located your first link later). However, as you noted, the posted download links are broken because plextools.com was not renewed. A Google search doesn’t bring up the current link in the original post, either [at the time this thread was created].


#8

[QUOTE=alexanderino;2489437]Thanks for the links, negritude (for what it’s worth, I located your first link later). However, as you noted, the posted download links are broken because plextools.com was not renewed. A Google search doesn’t bring up the current link in the original post, either [at the time this thread was created].[/QUOTE]

PlexTools Professional XL 3.16 can be downloaded from the Software and Utilities category in the Download section of the http://www.plextor-digital.com site …


#9

[QUOTE=cvs;2489533]PlexTools Professional XL 3.16 can be downloaded from the Software and Utilities category in the Download section of the http://www.plextor-digital.com site …[/QUOTE]

Yep, that’s what the OP already posted about. The comment you were responding to was in reference to changes that Plextor had made on their web sites. We were commenting on the fact of the changes, not asking where things are now.


#10

Does ANYONE know of an ASPI layer driver that will work in Win7 x64? I installed this version of PlexTools XL and it still fails to open because it does not see the Plextor drive. I ran ASPICHK and it confirmed there is no ASPI driver installed. But then how can/why does EAC work with my Plextor?

This is getting really annoying - HELP!


#11

PlexTools XL works fine for me on Win7 x64, though it was an in-place upgrade from Vista x64 and PTXL was already installed. Are you running it in elevated privilege mode?


#12

Yes. Tried it as Administrator and even in Win XP Compatibility mode. Can you run ASPICHK to see if you have an ASPI driver installed?


#13

[QUOTE=tony22;2496994]Yes. Tried it as Administrator and even in Win XP Compatibility mode. Can you run ASPICHK to see if you have an ASPI driver installed?[/QUOTE]

No ASPI layer installed.


#14

[QUOTE=Two Degrees;2496999]No ASPI layer installed.[/QUOTE]

??? Now I’m completely confused.


#15

PTP Pro XL shouldn’t need ASPI:

http://club.myce.com/f43/aspi-installation-plex-tools-prof-xl-3-04-a-150454/


#16

Okay, but what do I do now? I installed it as Admin and it still doesn’t see my drive.


#17

[QUOTE=tony22;2496978]I installed this version of PlexTools XL and it still fails to open because it does not see the Plextor drive. [/QUOTE]

Plextools doesn’t need a Plextor drive installed to open so I suspect that your problem isn’t the ASPI driver. Do you have any other CD/DVD related software or drivers running in the background? Plextools sometimes refuses to start up if some other software has taken over the drives.

Cheers

James.


#18

It’s not a rebadged drive is it? What drive do you have?


#19

[QUOTE=jamesp;2497117]Plextools doesn’t need a Plextor drive installed to open so I suspect that your problem isn’t the ASPI driver. Do you have any other CD/DVD related software or drivers running in the background? Plextools sometimes refuses to start up if some other software has taken over the drives.

Cheers

James.[/QUOTE]

James, really? I have no open programs or processes locking the drives. When I start PlexTools I get a warning pop-up panel saying “No Plextor Drive is Detected” and then it shuts down.


#20

Are you sure you installed PlexTools XL and not PlexUtilities? What Plextor drive do you have?