Plextools Plextools ""An invalid argument was encountered" except with admin privledg

I have searched everywhere for an answer to this. I am surprised that I have found nothing that relates.

I have a older Dell with Win2k pro installed. I share the computer with the rest of my family, so the default user intentionally does not have Administrator Privledge. If I try to use Plextools while logged in as that default user, I get several annoying error boxes titled “Plextool” and the text:

   "An invalid argument was encountered."

Once I acknowledge this error twice, I get into Plextools, & The program is unusable.

I can work around the problem by modifying the shortcut that launches Plextools to “Run as differant user”. This causes a login dialog to appear, and I can enter the admin password.

This is very annoying. It also means that I cannot place a “plextools” shortcut in the startup folder. This problem started the day I installed the Plextor PX-716A Plextools software (version 2.32a).

Please, if you are gong to offer help, please don’t make suggestions about how to set up multiple accounts. I already know how to do that. Setting up multiple accounts would create more annoyances than the original problem.

Hi,

maybe it helps, if you install Nero Burn Rights and allow burning for all users. This solved some related problems with some other software for me, as I am used to work as “limited user” as default (But I have my own account, as my wife has one, too).

Michael

hmmmm. I have the same plextor make and model and I did have that problem when using xp but have never encountered it on my server 2003 R2. It would seem to me that the xp configuration since it’s not running of the administrator account like server is, is the root of the problem no doubt. I can’t remember but it had something to do with the fact that the system had more privileges than my user account so I made my user account have the amount of right the same as being administrator…Is your plextor setup as the primary master cd/dvd drive?

I don’t think there is a better solution than what you’re already doing with the shortcut, gromittoo. Typing in a password once in a while isn’t that bad (in Linux you have to do it all the time - right, Michael? :slight_smile: / and even Vista is making a half-baked attempt at this atm).

Of course, you can complain to Plextor and maybe they’ll correct it in future releases…

I was having the same problem with Nero not seeing the drive until I installed BurnRights. Unfortunatly, installing BurnRights only fixed Nero. I suspect that whatever BurnRights does, needs to be done to Plextools.

For those who don’t know, installing BurnRights is a free download from Nero. You install the software while logged in as Administrator, and it creates a “Nero Burning” permissions group, and allows you to add any or all users to that group.

Thanks Michael for the suggestion.

The Plextor 716 is the only Removable media device. It replaced a CD burner that came with the Dell Computer. It only have three IDE devices:

  1. Primary IDE - Single Maxtor 20GB drive
  2. Secondary IDE - PX-716A
  3. Maxtor SATA add-in card (made by Promise) Maxtor 279GB SATA

Your question did suggest something. I may have installed some old CD burning software I had to use the Dell CD burner (Adaptec 4.0?). I should check to see if it is there, and uninstall it.

I tried an “uninstall” of the Adaptec 4 CD burning software, but it did not help.

Try the FAQ at http://www.plextor.com/english/support/faqs/SW00002.htm. or
http://www.plextor.com/english/support/faqs/SW00017.htm

Dunno what your OS is, but it may help.

This is not related to the problem. Plextools is a program that simply wasn’t designed for a multi-/limited-user environment. Only Plextor can solve this by re-writing the software.

I’ve encountered many such programs as I’m used to working with a limited user account (which Linux does as standard). Some programs can be “forced” to work by adapting the Security options of the program folder, but AFAIK Plextools isn’t one of them.