Plex Premium slow reads ?!?!

vbimport

#1

A while ago I noticed that my Plextor Premium (firmware 1.05) reads CDs at a much lower speed than it’s capable of (52X).

The drive is connected as the primary-master to an Asus P4C800 Deluxe mobo (bios 1019), a Plextor Premium is connected as the secondary-master. At boot time I do see the mobo detecting/configuring the drive to work at UltraDMA2, and WinXP (SP2) detects it as working in UltraDMA2 too.

In PlexTools 2.19a I’ve enabled SpeedRead, and set the read speed to 22-52 X CAV.

What could the reason be?

My System:
P4 3.2GHz (Northwood)
Asus P4C800 Deluxe 1019
2 x Corsair 512MB PC3200 (at 200MHz 2-3-3-6)
Adaptec 39160
Seaget Cheetah 15k.3 73GB
(I suspect the rest is entirely invalid to this issue)

Thanks!
Tom


#2

Make sure your DMA is set and then when you go to insert the disk, hold the eject button for about three seconds, or wait for the light to blink 3 times before releasing the eject button, see what that does for you.

In Plextools you can set it by pick the drive and then drive settings and then the advanced tab select enable read speed and then go to the basic tab, that too should unlock the settings with plextools installed.


#3

quality of the disc? is it new? scratches, dust, fingerprints, etc. would cause slow-downs in disc reading, but i’m assuming you’ve already tried cleaning the disc(s) prior to running your rip tests.


#4

This happens with any disk, burned or pressed.


#5

3-seconds eject button procedure solved this !!!
Damn, even when all settings seem to be perfect, you can never know what’s going on inside…

Thanks kamikazee!!!
Tom