Please help''urgent help needed

hi,
i flashed my 1004 drive with 049 beta and it was working fine but i had problem reading some discs so i tired to flash my drive back to 043 in dos but when i was flashing the update ran and it did not run from 00% to 100 and it was stuck there for a long time. Now the drive is dead no power , no tray eject. I used the command line
mtkflash 3 w /a0 all0.hex for first file
but it doesnt go to 100 % and is stuck at 0 and therefore i cannot flash other files. Now its completly dead no light no power. Please can anyone help.
thanks,
dvd_rw:bow: :bow: :bow:

hi,
ok i tried to use marcos way by using another cd rom and then switiching the cables but when i try to flash the 1004 after changing the cable it says
Err: fail to initial IDE port, please reboot PC.

Does anyone know what is this and how can i flash it otherwise.
thanks,
dvd_rw

when i tried to flash this time it says

Flash type: Unknown Flash memory

very sad now…drive dead

:sad:

i get same error after trying to flash in dos
“fail to initial ide port please reboot”
i have tried everything i.e replacing dvdr with working cdr booting to dos, replacing cdr with dvdr while pc still on
run mtkflash “still get error”!!!
anyone help please my drive is 3months old only flashing it to try and get dvds that work!!!