Please Help....SIS 530 ChipSet w/ No UDMA

vbimport

#1

I am baffled at this point, so I am looking to the internet community for some more insight on this aggrevating problem. I have not been able to successfully change my secondary IDE DMA transfer mode to Ultra DMA in Win2k. My configuration is as follows:

*2170-802 450Mhz IBM Aptiva
*SIS 530 Chipset
*Maxtor L01P120 IDE HDD attached with a 40-pin/40-wire IDE cable as master device on primary IDE channel
*Sony DRU-710A IDE Dual Layer DVD Burner attached with a 40-pin/80-wire IDE cable as master device on secondary IDE channel
*Win2k OS w/ SP4
*Using default windows IDE drivers

Here is what I have done and my observed results:

(1) Initially both the Maxtor HDD and the Sony DVD transfer modes were showing up as PIO. I dl’ed DMACHECK.exe and ran it. It showed the DMA Detection Status to be disabled for both IDE channels. I enabled both DMA channels for DMA Detection and rebooted the machine. After the reboot, both IDE channels were still showing up as PIO.

(2) Then I changed the transfer mode drop down box to “DMA if available” for both IDE channels and both device 0 (master) and device 1 (slave). I rebooted the machine and again both IDE channels showed PIO as their transfer modes.

(3) I found some literature on the internet stating that DMA mode would still not work after doing all this if you had not run SISIDE.exe. So I dl’ed this executable and ran it with the /D option to prompt for a reboot. After the reboot the HDD on the primary IDE channel showed Ultra DMA (UDMA2), but the secondary IDE channel still showed PIO. BTW, I understand to achieve a xfer rate > 33Mhz you have to install a 40-pin/80-wire IDE cable, so the UDMA2 is not a concern for me on my primary channel.

(4) I then tried other suggestions I read on the internet about uninstalling the second IDE channel and rebooting to let windows re-install the device drivers. This had no effect on the PIO status of my second IDE channel.

(5) The next thing I tried was to add the “EnableUDMA66” DWORD with a value of “1” to my HKLM\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000 registry keyname. This also did not have any effect on the PIO xfer mode.

(6) Then I tried another hack I found on the net that stated you needed to add more registry entries before running the SISIDE.exe utility. So I added the following lines to my registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000
Make a new DWord named "Rene Isbrandts DMA fix” (or just DMA FIX please give credit where it is deserved ok ; ) and give it the value: 1

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001
Make a new DWord named: "DmaDetectionLevel” and give it the value: 2

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002
Make a new DWord named “DmaDetectionLevel” and give it the value: 2

After the reboot I observed that the primary IDE channel was still set to Ultra DMA and secondary IDE channel was NOW set to DMA mode, but WHY NOT UDMA? I used Nero’s CD-DVD Speed utility to test the burst rate of that DVD drive and it was only 11MB/s. Although alot better than the 3MB/s I measure in PIO mode, it was still not working correctly. Even at 11MB/s the video is choppy when watching a DVD.

(7) I tried replacing the Sony DVD burner with a CD-RW Blaster from Creative Labs on the secondary IDE channel and it too shows PIO as the xfer mode. The Creative Labs burner is the CD-RW 8432 and is also capable of DMA xfers.

Please.Please. Help!!!


#2

That’s a nice opening you have there. Quite complete and very informative. Keep that up :slight_smile:

About your problem:
Try your system’s BIOS and see if DMA is enabled for all IDE channels. It that isn’t enabled. problems like these might occur!


#3

How brave are you?
http://alter.org.ua/soft/win/uni_ata/index.php?lang=en&
It’s a “work in progress”, and the advice to set up two hardware configurations, one with original drivers and one with these (plus restore points and backups) should be followed - no confirmed sightings of these actually in use on Sis530 are noted.

The other option is to get hold of a “good” PCI controller - not all of them (especially Promise) are useable with writers.


#4

@ brownaj
It doesn’t really matter whether it shows (M)WDMA-2 or UDMA, that comp will have serious issues exceeding 16,6Mbyte/s anyways and it’ll probably never be able to decode MPEG-2 @ ~6mbit by using integrated video.
//Danne


#5

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-4JSSC9
There are some BIOS related issues as well, so it may be worth updating if not already up to this level.


#6

Thanks guys for all of the input. I will try to respond to all of the comments + add some additional comments.

[Dee-ehn]
The BIOS settings for my IDE Channels are all set to AUTO. I tried to manually change them to Ultra DMA but this had no effect on windows.

[Matth]
I would love to try that driver but I don’t have the ability to ghost my drive and I definitely do not want to do a re-install. I am pretty sure the problem is related to this SIS IDE driver.

[DiiZzY]
Although this PC is quite old it should be capable of running much faster than 16MB/s. You can acheive 66MB/s burst speeds with UDMA4 and both my mobo & DVD drive claim they support UDMA4. I have moved my Ultra IDE cable from the secondary channel to the primary channel where my hard-drive is located and now that channel is reporting UDMA4 as expected. I am not using the on-board sound or video. I have a 16MB Voodoo3 3000 PCI video card, a sound blaster live PCI sound card, and a ethernet NIC in my 3 PCI slots.

[Matth]
I already have that BIOS installed (aujt01a.exe). It was the latest one I could find.

[comments]
I did figure out how to achieve DMA transfer modes on my CD-RW and DVD drives without the registery hacks. I upgraded my SIS IDE Controller driver to 2.2.1.0 and magically my CD-RW and DVD drives changed from PIO to DMA2 transfer modes. The IDE controller name also changed from SIS PCI IDE Controller to SIS PCI IDE UDMA Controller. I didn’t try this earlier because the SIS website says that the windows default driver is good enough to achieve UDMA speeds.

Right now I get 10MB/s on my CD-RW and 11MB/s on my DVD drive. Unfortunately my DVD playback is still choppy :frowning:


#7

Just for a test, try putting the hardrive on the secondary IDE and the DVD on primary to see if the DVD shows up as UDMA. If it does, I’d suggest you get a PCI controller to put the HD on leaving the DVD on the primary channel…

Additionally, I think you’ll ultimately find out that DiiZzY is correct and you’re not gonna be satisfied with this configuration… :wink:


#8

Are you running the Sis 530 1.08 graphics driver?

The Sis530 is supposed to support DVD acceleration, though how many of the features that count as “accelerated” are available is unknown. It may be that the features it doies have are unsupported by the software.


#9

@ brownaj
Well, you can always dream but it wont happen.
Accept the fact it’s too slow and old especially since you’re trying to push everything over the PCI bus.
//Danne


#10

I just joined and don’t know if I’m doing this right but I found this page while searching for a BIOS file for my IBM Aptiva 2170-190 the file name is aujt01.exe. The post I saw was from January 2005 I believe when I try to get the file from IBM it is no longer there. Their tech support people were very nice but said it may have been removed because the machine is to old. I got a BIOS file from ACER the motherboard manufacturer but it has left the machine bearly running. Does anyone have the BIOS file? And how can I get it from them? I can not recieve an .exe file in my E-mail because Outlook deletes them (a seperate issue)


#11

I see that you have tried almost everything possible except formatting and reinstalling Windows…. :wink: Could this be a problem with the IDE cable? Just a guess.
Also try uninstalling the secondary IDE channel from the device manager and refresh it. It fixes mine when sometimes my drives get in to PIO mode for some wired reason.


#12

I have the same problem, but with Windows XP.

I tried everything, but nothing worked.

Is there someone who knows how to enable UDMA on WinXP?


#13

[QUOTE=frank2243;1970558]I have the same problem, but with Windows XP.

I tried everything, but nothing worked.

Is there someone who knows how to enable UDMA on WinXP?[/QUOTE]

Have you ever read all posts carefully in this OLD thread???


#14

Yes, but

I can’'t find a version of SISIDE.exe that works correctly under Windows XP without the “SIS IDE DRIVER” (which are not compatible with the SIS530 chipset).

I did all the registry tweaks from the first post, but that didn’t help.

I updated the BIOS, but that didn’t help.

I tried to install the Universal ATA driver, but when I install it I always got a message like “SERVICE INSTALLATION SECTION IN INF FILE INVALID”.


#15

Did you find one that is “xp compatible”?
Then maybe you can unpack it using winrar and install them without the ide drivers?


#16

Yes I found one in the IDE driver 2.04a that is compatible with Windows XP, but when I start it it says that I need to install the driver or the information will not display correctly. I clicked ok, but only my hard-drive is recognized and my cd-rw is not.

I think I will retry to install the SIS IDE driver 2.04a without any registry tweaks and I will tell you if it works or not.